summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-05 13:51:36 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-05 13:51:36 +0200
commit12c43609da2bd29996b895d1e79e0209092dfa7b (patch)
tree03c1a683779e1eca7b2e569a2fc3d420bb92f178 /media-libs/libvpl
parentlicenses: add OSI approved BlueOak-1.0.0 license (diff)
downloadgentoo-12c43609da2bd29996b895d1e79e0209092dfa7b.tar.gz
gentoo-12c43609da2bd29996b895d1e79e0209092dfa7b.tar.bz2
gentoo-12c43609da2bd29996b895d1e79e0209092dfa7b.zip
media-libs/libvpl: add 2.12.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-libs/libvpl')
-rw-r--r--media-libs/libvpl/Manifest1
-rw-r--r--media-libs/libvpl/libvpl-2.12.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/libvpl/Manifest b/media-libs/libvpl/Manifest
index be8623d88773..645a63e666c2 100644
--- a/media-libs/libvpl/Manifest
+++ b/media-libs/libvpl/Manifest
@@ -1,2 +1,3 @@
DIST libvpl-2.10.2.tar.gz 11872075 BLAKE2B 6d9b6ba66b1e1c191a309ff26ec54a5bb62fa542ca9eab042a437eca9a82cf9d7e3056247a8110b49e28388bdbd8e4c0793dda8dd84d229937524faa96b10f37 SHA512 e4f6e1656371a8edb54a3a67726439d97dd5e8225fa37fdfc309602dd83c51e4a2b4e72bdb18b81dc6691f666a8857b460c45392cf030a8309abd368037be49d
DIST libvpl-2.11.0.tar.gz 11372299 BLAKE2B b9e95505468d8771ba9fa29c3024db2f3d2ad78d2be62c7b405c8cfd29cd5601ee10445de4ffb42c27c412760192c7505b6fb94391dddadf5118d5c785b8df74 SHA512 9b6be42fbf6c8ac48b6f04607b6c6acea7ba0ef8434b323cb1d307ac4e917144351ae9f64d2f8c5f9a5668b8623557e231b0aaf0d579cc9718c6113c37f81804
+DIST libvpl-2.12.0.tar.gz 11398775 BLAKE2B e1f0a59f7261dae399eae39318b0c9c9fc671a013c4b7442af34025dce981112f6d254e39f1de432e4f4f155d00148ec9c89652e05734e1ba9cfd6e14f54d4c0 SHA512 4a9f0272684c896ca8a11c316fe05f7ea60c0cd402b0b474a90523f5aca1a16cffac84d89758c27d837ca6e7ac68b82d6aec028ee7aa237626a2194709f48782
diff --git a/media-libs/libvpl/libvpl-2.12.0.ebuild b/media-libs/libvpl/libvpl-2.12.0.ebuild
new file mode 100644
index 000000000000..915dea848836
--- /dev/null
+++ b/media-libs/libvpl/libvpl-2.12.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib optfeature flag-o-matic
+
+DESCRIPTION="Intel Video Processing Library dispatcher"
+HOMEPAGE="https://github.com/intel/libvpl/"
+SRC_URI="https://github.com/intel/libvpl/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ x11-libs/libpciaccess[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ filter-lto
+ cmake_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTS="$(usex test)"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+ )
+ cmake_src_configure
+}
+
+multilib_src_install() {
+ cmake_src_install
+ # Remove these license files
+ rm -r "${ED}/usr/share/vpl/licensing" || die
+}
+
+pkg_postinst() {
+ optfeature_header "This package provides only the dispatcher, to use it install one or more implementations"
+ optfeature "CPUs" media-libs/oneVPL-cpu
+ optfeature "Intel GPUs newer then, and including, Intel Xe" media-libs/oneVPL-intel-gpu
+ optfeature "Intel GPUs older then Intel Xe" media-libs/intel-mediasdk
+}