summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon van der Veldt <simon.vanderveldt+gentoo@gmail.com>2021-02-05 20:14:19 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-02-06 11:35:09 +0100
commit62ee1d0a5afc78fda0054859c0329de918d7d22e (patch)
tree9a577be7aa472f363ff01aec947f7c721adba3a2 /media-libs/lsp-plugins/lsp-plugins-1.1.29.ebuild
parentsys-apps/baselayout-prefix: revbump for Darwin MANPATH update (diff)
downloadgentoo-62ee1d0a5afc78fda0054859c0329de918d7d22e.tar.gz
gentoo-62ee1d0a5afc78fda0054859c0329de918d7d22e.tar.bz2
gentoo-62ee1d0a5afc78fda0054859c0329de918d7d22e.zip
media-libs/lsp-plugins: Bump to 1.1.29
Signed-off-by: Simon van der Veldt <simon.vanderveldt+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19345 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/lsp-plugins/lsp-plugins-1.1.29.ebuild')
-rw-r--r--media-libs/lsp-plugins/lsp-plugins-1.1.29.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/lsp-plugins/lsp-plugins-1.1.29.ebuild b/media-libs/lsp-plugins/lsp-plugins-1.1.29.ebuild
new file mode 100644
index 000000000000..6e275d247806
--- /dev/null
+++ b/media-libs/lsp-plugins/lsp-plugins-1.1.29.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="Linux Studio Plugins"
+HOMEPAGE="https://lsp-plug.in"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/sadko4u/lsp-plugins"
+ EGIT_BRANCH="devel"
+else
+ SRC_URI="https://github.com/sadko4u/lsp-plugins/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="doc jack ladspa +lv2"
+REQUIRED_USE="|| ( jack ladspa lv2 )"
+
+DEPEND="
+ dev-libs/expat
+ media-libs/libsndfile
+ media-libs/libglvnd[X]
+ doc? ( dev-lang/php:* )
+ jack? (
+ virtual/jack
+ x11-libs/cairo[X]
+ )
+ ladspa? ( media-libs/ladspa-sdk )
+ lv2? (
+ media-libs/lv2
+ x11-libs/cairo[X]
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ use doc && MODULES+="doc"
+ use jack && MODULES+=" jack"
+ use ladspa && MODULES+=" ladspa"
+ use lv2 && MODULES+=" lv2"
+ emake BUILD_MODULES="${MODULES}"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${ED}" LIB_PATH="/usr/$(get_libdir)" install
+}