summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-02-12 15:33:47 +0100
committerTupone Alfredo <tupone@gentoo.org>2017-02-12 15:33:47 +0100
commita18a8c4cbfc39c02825851d24e9e9ab777c4706b (patch)
treed3cf6f9c2946d1791cf7622ca673a2a1c1a2185a /media-libs/raspberrypi-userland/files
parentmedia-sound/mt-daapd: fix bug 335298 (diff)
downloadgentoo-a18a8c4cbfc39c02825851d24e9e9ab777c4706b.tar.gz
gentoo-a18a8c4cbfc39c02825851d24e9e9ab777c4706b.tar.bz2
gentoo-a18a8c4cbfc39c02825851d24e9e9ab777c4706b.zip
media-libs/raspberrypi-userland: Fix devices permissions
Not using anymore eselect opengl (includes not compatible) Package-Manager: portage-2.3.3
Diffstat (limited to 'media-libs/raspberrypi-userland/files')
-rw-r--r--media-libs/raspberrypi-userland/files/92-local-vchiq-permissions.rules2
-rw-r--r--media-libs/raspberrypi-userland/files/raspberrypi-userland-9999-gentoo.patch15
2 files changed, 17 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland/files/92-local-vchiq-permissions.rules b/media-libs/raspberrypi-userland/files/92-local-vchiq-permissions.rules
index bacea0e0665e..fd95502940a5 100644
--- a/media-libs/raspberrypi-userland/files/92-local-vchiq-permissions.rules
+++ b/media-libs/raspberrypi-userland/files/92-local-vchiq-permissions.rules
@@ -1 +1,3 @@
SUBSYSTEM=="vchiq",GROUP="video",MODE="0660"
+SUBSYSTEM=="vc-sm",GROUP="video",MODE="0660"
+SUBSYSTEM=="bcm2708_vcio",GROUP="video",MODE="0660"
diff --git a/media-libs/raspberrypi-userland/files/raspberrypi-userland-9999-gentoo.patch b/media-libs/raspberrypi-userland/files/raspberrypi-userland-9999-gentoo.patch
new file mode 100644
index 000000000000..a5e60554cd13
--- /dev/null
+++ b/media-libs/raspberrypi-userland/files/raspberrypi-userland-9999-gentoo.patch
@@ -0,0 +1,15 @@
+--- raspberrypi-userland-9999/host_applications/linux/apps/dtoverlay/CMakeLists.txt.old 2017-02-04 19:01:38.944537134 +0100
++++ raspberrypi-userland-9999/host_applications/linux/apps/dtoverlay/CMakeLists.txt 2017-02-04 19:02:09.634401479 +0100
+@@ -22,12 +22,4 @@
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/dtparam DESTINATION bin)
+
+ set(DTOVERLAY_SCRIPTS dtoverlay-pre dtoverlay-post)
+-foreach(_script ${DTOVERLAY_SCRIPTS})
+- add_custom_command(
+- TARGET dtoverlay
+- COMMAND ${CMAKE_COMMAND}
+- -E copy ${CMAKE_CURRENT_SOURCE_DIR}/${_script}
+- ${CMAKE_BINARY_DIR}/../../bin/${_script}
+- )
+-endforeach()
+ install(PROGRAMS ${DTOVERLAY_SCRIPTS} DESTINATION bin)