summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-10 10:04:58 +0000
committerSam James <sam@gentoo.org>2022-11-10 10:05:29 +0000
commit3ece26abf8b9b5a09d17bf166e441cb9746ee4d8 (patch)
treed0596cd39321238b3b3424201d1a4408fc03402a /media-libs/sdl-mixer
parentsys-devel/mold: remove system-tbb USE flag (diff)
downloadgentoo-3ece26abf8b9b5a09d17bf166e441cb9746ee4d8.tar.gz
gentoo-3ece26abf8b9b5a09d17bf166e441cb9746ee4d8.tar.bz2
gentoo-3ece26abf8b9b5a09d17bf166e441cb9746ee4d8.zip
media-libs/sdl-mixer: backport additional header patch
We're going to do a snapshot but it feels right to fix this bit first as it got introduced by one of the previous patches (only shows up with some USE flag combos). Bug: https://bugs.gentoo.org/880619 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/sdl-mixer')
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.12-incompatible-func-clang16.patch30
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.12-r7.ebuild (renamed from media-libs/sdl-mixer/sdl-mixer-1.2.12-r6.ebuild)0
2 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-incompatible-func-clang16.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-incompatible-func-clang16.patch
index 0f104d5d6ffe..747611880255 100644
--- a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-incompatible-func-clang16.patch
+++ b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-incompatible-func-clang16.patch
@@ -1,6 +1,7 @@
https://github.com/libsdl-org/SDL_mixer/commit/03bd4ca6aa38c1a382c892cef86296cd621ecc1d
https://github.com/libsdl-org/SDL_mixer/commit/9e6d7b67a00656a68ea0c2eace75c587871549b9
https://github.com/libsdl-org/SDL_mixer/commit/d28cbc34d63dd20b256103c3fe506ecf3d34d379
+https://github.com/libsdl-org/SDL_mixer/commit/05b12a3c22c0746c29dc5478f5b7fbd8a51a1303
From 03bd4ca6aa38c1a382c892cef86296cd621ecc1d Mon Sep 17 00:00:00 2001
From: Ozkan Sezer <sezeroz@gmail.com>
@@ -62,3 +63,32 @@ reported by Vitaly Novichkov.
(int (*)(OggVorbis_File *,double))
#endif
+
+From 05b12a3c22c0746c29dc5478f5b7fbd8a51a1303 Mon Sep 17 00:00:00 2001
+From: Ozkan Sezer <sezeroz@gmail.com>
+Date: Wed, 23 Sep 2020 05:32:00 +0300
+Subject: [PATCH] mixer.c: add missing dynamic_fluidsynth.h include -- fixes
+ bug #5296.
+
+---
+ mixer.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mixer.c b/mixer.c
+index c653d6ed..431f6e69 100644
+--- a/mixer.c
++++ b/mixer.c
+@@ -34,6 +34,7 @@
+ #include "load_voc.h"
+ #include "load_ogg.h"
+ #include "load_flac.h"
++#include "dynamic_fluidsynth.h"
+ #include "dynamic_flac.h"
+ #include "dynamic_mod.h"
+ #include "dynamic_mp3.h"
+@@ -1499,4 +1500,3 @@ int Mix_UnregisterAllEffects(int channel)
+ }
+
+ /* end of mixer.c ... */
+-
+
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.12-r6.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.12-r7.ebuild
index 04a69cf22ab4..04a69cf22ab4 100644
--- a/media-libs/sdl-mixer/sdl-mixer-1.2.12-r6.ebuild
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.12-r7.ebuild