summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-25 23:20:41 -0400
committerSam James <sam@gentoo.org>2024-03-26 12:27:31 +0000
commit039e3cb218f244bbcd2790c78c986a1c13c3ce57 (patch)
tree1baf6b6a04806b0cf43ba9200ffa8620d8cd0489 /media-libs/sdl2-net
parentsys-fs/aufs-util: update EAPI 7 -> 8 (diff)
downloadgentoo-039e3cb218f244bbcd2790c78c986a1c13c3ce57.tar.gz
gentoo-039e3cb218f244bbcd2790c78c986a1c13c3ce57.tar.bz2
gentoo-039e3cb218f244bbcd2790c78c986a1c13c3ce57.zip
media-libs/sdl2-net: make sure elibtoolize is applied
Since the libtool available is very old, that means running a full eautoreconf. Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/sdl2-net')
-rw-r--r--media-libs/sdl2-net/sdl2-net-2.2.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/sdl2-net/sdl2-net-2.2.0.ebuild b/media-libs/sdl2-net/sdl2-net-2.2.0.ebuild
index 0e98342e1fa7..751c71d2ba1b 100644
--- a/media-libs/sdl2-net/sdl2-net-2.2.0.ebuild
+++ b/media-libs/sdl2-net/sdl2-net-2.2.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
MY_P=SDL2_net-${PV}
-inherit multilib-minimal
+inherit autotools multilib-minimal
DESCRIPTION="Simple Direct Media Layer Network Support Library"
HOMEPAGE="https://www.libsdl.org/projects/SDL_net/index.html"
@@ -19,6 +19,11 @@ IUSE="static-libs"
RDEPEND=">=media-libs/libsdl2-2.0.4[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ eautoreconf
+}
+
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
--disable-examples \