summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/sdl2-ttf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/sdl2-ttf')
-rw-r--r--media-libs/sdl2-ttf/Manifest1
-rw-r--r--media-libs/sdl2-ttf/files/sdl2-ttf-2.0.12-linking.patch16
-rw-r--r--media-libs/sdl2-ttf/metadata.xml12
-rw-r--r--media-libs/sdl2-ttf/sdl2-ttf-2.0.12-r1.ebuild45
4 files changed, 74 insertions, 0 deletions
diff --git a/media-libs/sdl2-ttf/Manifest b/media-libs/sdl2-ttf/Manifest
new file mode 100644
index 000000000000..9b1cfdade06c
--- /dev/null
+++ b/media-libs/sdl2-ttf/Manifest
@@ -0,0 +1 @@
+DIST SDL2_ttf-2.0.12.tar.gz 5517665 SHA256 8728605443ea1cca5cad501dc34dc0cb15135d1e575551da6d151d213d356f6e SHA512 2dfd7d9a87d86b0446e52c78dcf4c45dba747256ff9cb4cc010818eac725410f5a1a781e6695ca0bcead756c70519d8d5b4df6c1b2935085e0356d9b4d7844fa WHIRLPOOL 7b3457925237f741bdcb1b6b00aa0463f33bde4c8886f03de4cc20885bffadfe3759fb31852dfee1ced06e0e494ec639f0a6a0f415520d9998683b81d010836b
diff --git a/media-libs/sdl2-ttf/files/sdl2-ttf-2.0.12-linking.patch b/media-libs/sdl2-ttf/files/sdl2-ttf-2.0.12-linking.patch
new file mode 100644
index 000000000000..88a7e7fdabfd
--- /dev/null
+++ b/media-libs/sdl2-ttf/files/sdl2-ttf-2.0.12-linking.patch
@@ -0,0 +1,16 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Mon Sep 2 20:29:16 UTC 2013
+Subject: fix linking with newer glibc
+
+https://bugzilla.libsdl.org/show_bug.cgi?id=1401
+
+--- SDL2_ttf-2.0.12/Makefile.am
++++ SDL2_ttf-2.0.12/Makefile.am
+@@ -35,6 +35,7 @@
+ -release $(LT_RELEASE) \
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+ endif
++libSDL2_ttf_la_LIBADD = @MATHLIB@
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = SDL2_ttf.pc
diff --git a/media-libs/sdl2-ttf/metadata.xml b/media-libs/sdl2-ttf/metadata.xml
new file mode 100644
index 000000000000..e7ce72ada858
--- /dev/null
+++ b/media-libs/sdl2-ttf/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription>
+ This is a sample library which allows you to use TrueType
+ fonts in your SDL applications. It
+ comes with an example program "showfont" which displays an
+ example string for a given
+ TrueType font file.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-libs/sdl2-ttf/sdl2-ttf-2.0.12-r1.ebuild b/media-libs/sdl2-ttf/sdl2-ttf-2.0.12-r1.ebuild
new file mode 100644
index 000000000000..8a1f83e3a986
--- /dev/null
+++ b/media-libs/sdl2-ttf/sdl2-ttf-2.0.12-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+MY_P=SDL2_ttf-${PV}
+DESCRIPTION="library that allows you to use TrueType fonts in SDL applications"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_ttf/"
+SRC_URI="http://www.libsdl.org/projects/SDL_ttf/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs X"
+
+RDEPEND="X? ( >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}] )
+ >=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-linking.patch
+ mv configure.in configure.ac || die
+ eautoreconf
+ rm -r external || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_with X x)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,README}.txt
+ use static-libs || prune_libtool_files
+}