summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-18 08:09:30 +0000
committerSam James <sam@gentoo.org>2022-12-18 08:30:30 +0000
commitb1f3c4f08cc26126f9bd4c7a90b6907e1cafb092 (patch)
tree96e1a0694422d637e96f8c18ca5f92277acd7143 /media-libs/simage
parentsci-astronomy/siril: drop 1.0.3-r1 (diff)
downloadgentoo-b1f3c4f08cc26126f9bd4c7a90b6907e1cafb092.tar.gz
gentoo-b1f3c4f08cc26126f9bd4c7a90b6907e1cafb092.tar.bz2
gentoo-b1f3c4f08cc26126f9bd4c7a90b6907e1cafb092.zip
media-libs/simage: drop 1.8.0-r3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/simage')
-rw-r--r--media-libs/simage/Manifest1
-rw-r--r--media-libs/simage/files/simage-1.7.1-cmake-automagic-deps.patch85
-rw-r--r--media-libs/simage/files/simage-1.7.1-disable-examples.patch44
-rw-r--r--media-libs/simage/files/simage-1.7.1-disable-gif-quantize-buffer.patch31
-rw-r--r--media-libs/simage/files/simage-1.7.1-tests-conditional.patch52
-rw-r--r--media-libs/simage/files/simage-1.8.0-0001-CMakeLists.txt-comment-cpack.d-inclusion.patch25
-rw-r--r--media-libs/simage/simage-1.8.0-r3.ebuild82
7 files changed, 0 insertions, 320 deletions
diff --git a/media-libs/simage/Manifest b/media-libs/simage/Manifest
index 6af22527239c..f01f4b90a2a4 100644
--- a/media-libs/simage/Manifest
+++ b/media-libs/simage/Manifest
@@ -1,2 +1 @@
-DIST simage-1.8.0-src.tar.gz 797069 BLAKE2B 6f9e3512c9815974b1b2799306c6567f6b5aec6771fe31e0a5fa47a827819df02e80e976063ddbae3e3aa3a4d33da68a23c9067e7b91f82c28592f83d0e782cc SHA512 fb4943c38f418461b087d5d013c2054f25d553a872fc80f9445a5e907901eb40265d838c5cc1031032dd84885f066f1c640a1949bc450591fb0ea88c05d1e38f
DIST simage-1.8.1.tar.gz 829490 BLAKE2B 05d3a3f7ff7c195b55d454a2bc6e086cd4439fd6e9fb694c1926a4c0be5142661bf2c7d6593f6b7ae0681234f28c7b92e325ed0928a0fb4df5e846b30fbf9156 SHA512 e6f211f453f67f601d157e36c6c4845af1e0601dd3d8d97fbb993c50dc54c8908c2e1e345ea1dd578b8fa2dca823d8e1bab7f29a0a0d73732ca597cc5c673cbe
diff --git a/media-libs/simage/files/simage-1.7.1-cmake-automagic-deps.patch b/media-libs/simage/files/simage-1.7.1-cmake-automagic-deps.patch
deleted file mode 100644
index 5f3fd2db7146..000000000000
--- a/media-libs/simage/files/simage-1.7.1-cmake-automagic-deps.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 5536922..8225dc4 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -218,14 +218,14 @@ if(NOT SIMAGE_QUICKTIME_SUPPORT AND NOT SIMAGE_CGIMAGE_SUPPORT AND NOT SIMAGE_GD
- find_package(TIFF)
-
- set(HAVE_ZLIB ${ZLIB_FOUND})
-- set(HAVE_GIFLIB ${GIF_FOUND})
-- set(HAVE_JPEGLIB ${JPEG_FOUND})
-- set(HAVE_PNGLIB ${PNG_FOUND})
-- set(HAVE_TIFFLIB ${TIFF_FOUND})
-+ set(HAVE_GIFLIB ${SIMAGE_GIF_SUPPORT})
-+ set(HAVE_JPEGLIB ${SIMAGE_JPEG_SUPPORT})
-+ set(HAVE_PNGLIB ${SIMAGE_PNG_SUPPORT})
-+ set(HAVE_TIFFLIB ${SIMAGE_TIFF_SUPPORT})
- endif()
-
--set(HAVE_JASPER ${JASPER_FOUND})
--set(HAVE_VFW ${VFW_FOUND})
-+set(HAVE_JASPER ${SIMAGE_JASPER_SUPPORT})
-+set(HAVE_VFW ${SIMAGE_AVIENC_SUPPORT})
-
- check_include_files(guile/gh.h HAVE_GUILE_GH_H)
- check_include_files(inttypes.h HAVE_INTTYPES_H)
-@@ -430,27 +430,27 @@ if(SIMAGE_GDIPLUS_SUPPORT)
- target_link_libraries(simage PRIVATE ${GDIPLUS_LIBRARIES})
- endif()
-
--if(GIF_FOUND)
-+if(SIMAGE_GIF_SUPPORT)
- target_include_directories(simage PRIVATE ${GIF_INCLUDE_DIR})
- target_link_libraries(simage PRIVATE ${GIF_LIBRARIES})
- endif()
-
--if(JASPER_FOUND)
-+if(SIMAGE_JASPER_SUPPORT)
- target_include_directories(simage PRIVATE ${JASPER_INCLUDE_DIR})
- target_link_libraries(simage PRIVATE ${JASPER_LIBRARIES})
- endif()
-
--if(JPEG_FOUND)
-+if(SIMAGE_JPEG_SUPPORT)
- target_include_directories(simage PRIVATE ${JPEG_INCLUDE_DIR})
- target_link_libraries(simage PRIVATE ${JPEG_LIBRARIES})
- endif()
-
--if(OGGVORBIS_FOUND)
-+if(SIMAGE_OGGVORBIS_SUPPORT)
- target_include_directories(simage PRIVATE ${OGGVORBIS_INCLUDE_DIRS})
- target_link_libraries(simage PRIVATE ${OGGVORBIS_LIBRARIES})
- endif()
-
--if(PNG_FOUND)
-+if(SIMAGE_PNG_SUPPORT)
- target_include_directories(simage PRIVATE ${PNG_INCLUDE_DIR})
- target_link_libraries(simage PRIVATE ${PNG_LIBRARIES})
- endif()
-@@ -459,22 +459,22 @@ if(SIMAGE_QIMAGE_SUPPORT)
- target_link_libraries(simage PRIVATE ${QT_LIBRARIES})
- endif()
-
--if(QUICKTIME_FOUND)
-+if(SIMAGE_QUICKTIME_SUPPORT)
- target_include_directories(simage PRIVATE ${QUICKTIME_INCLUDE_DIR})
- target_link_libraries(simage PRIVATE ${QUICKTIME_LIBRARIES})
- endif()
-
--if(SNDFILE_FOUND)
-+if(SIMAGE_SNDFILE_SUPPORT)
- target_include_directories(simage PRIVATE ${SNDFILE_INCLUDE_DIRS})
- target_link_libraries(simage PRIVATE ${SNDFILE_LIBRARIES})
- endif()
-
--if(TIFF_FOUND)
-+if(SIMAGE_TIFF_SUPPORT)
- target_include_directories(simage PRIVATE ${TIFF_INCLUDE_DIR})
- target_link_libraries(simage PRIVATE ${TIFF_LIBRARY})
- endif()
-
--if(VFW_FOUND)
-+if(SIMAGE_VFW_SUPPORT)
- target_link_libraries(simage PRIVATE ${VFW_LIBRARIES})
- endif()
-
diff --git a/media-libs/simage/files/simage-1.7.1-disable-examples.patch b/media-libs/simage/files/simage-1.7.1-disable-examples.patch
deleted file mode 100644
index 9e43e073ccd1..000000000000
--- a/media-libs/simage/files/simage-1.7.1-disable-examples.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 5536922..07df95a 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -482,23 +482,23 @@ endif()
- # Build examples
- # ############################################################################
-
--set(SIMAGE_EXAMPLE_SOURCE
-- ${CMAKE_CURRENT_SOURCE_DIR}/examples/audio2raw.c
-- ${CMAKE_CURRENT_SOURCE_DIR}/examples/img2avi.c
-+#set(SIMAGE_EXAMPLE_SOURCE
-+# ${CMAKE_CURRENT_SOURCE_DIR}/examples/audio2raw.c
-+# ${CMAKE_CURRENT_SOURCE_DIR}/examples/img2avi.c
- # ${CMAKE_CURRENT_SOURCE_DIR}/examples/mpeg2enc.cpp # requires Coin to build
-- ${CMAKE_CURRENT_SOURCE_DIR}/examples/simage-convert.c
-- ${CMAKE_CURRENT_SOURCE_DIR}/examples/simage-read-line-test.c
--)
--
--foreach(_source ${SIMAGE_EXAMPLE_SOURCE})
-- get_filename_component(_example ${_source} NAME_WE)
-- add_executable(${_example} ${_source})
-- target_compile_definitions(${_example} PRIVATE _CRT_NONSTDC_NO_DEPRECATE _CRT_SECURE_NO_DEPRECATE _CRT_SECURE_NO_WARNINGS _USE_MATH_DEFINES)
-- target_link_libraries(${_example} simage)
-- if(UNIX)
-- target_link_libraries(${_example} m)
-- endif()
--endforeach()
-+# ${CMAKE_CURRENT_SOURCE_DIR}/examples/simage-convert.c
-+# ${CMAKE_CURRENT_SOURCE_DIR}/examples/simage-read-line-test.c
-+#)
-+
-+#foreach(_source ${SIMAGE_EXAMPLE_SOURCE})
-+# get_filename_component(_example ${_source} NAME_WE)
-+# add_executable(${_example} ${_source})
-+# target_compile_definitions(${_example} PRIVATE _CRT_NONSTDC_NO_DEPRECATE _CRT_SECURE_NO_DEPRECATE _CRT_SECURE_NO_WARNINGS _USE_MATH_DEFINES)
-+# target_link_libraries(${_example} simage)
-+# if(UNIX)
-+# target_link_libraries(${_example} m)
-+# endif()
-+#endforeach()
-
- # ############################################################################
- # Build tests
diff --git a/media-libs/simage/files/simage-1.7.1-disable-gif-quantize-buffer.patch b/media-libs/simage/files/simage-1.7.1-disable-gif-quantize-buffer.patch
deleted file mode 100644
index 99535b221422..000000000000
--- a/media-libs/simage/files/simage-1.7.1-disable-gif-quantize-buffer.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/src/simage_gif.c b/src/simage_gif.c
-index 0819ef8..f959127 100644
---- a/src/simage_gif.c
-+++ b/src/simage_gif.c
-@@ -37,7 +37,7 @@
- #define DGifOpenFileName(gif) DGifOpenFileName(gif, NULL)
- #define EGifOpenFileName(gif, exist) EGifOpenFileName(gif, exist, NULL)
- //see https://sourceforge.net/p/giflib/mailman/message/29367749/
--#define QuantizeBuffer GifQuantizeBuffer
-+//#define QuantizeBuffer GifQuantizeBuffer
- #define MakeMapObject GifMakeMapObject
- #define FreeMapObject GifFreeMapObject
- #endif
-@@ -347,7 +347,7 @@ simage_gif_save(const char * filename,
- free(outbuf);
- return 0;
- }
--
-+/*
- if (QuantizeBuffer(width, height, &colormapsize,
- rgbbuf, &rgbbuf[bufsize], &rgbbuf[bufsize*2],
- outbuf, cmapobj->Colors) == GIF_ERROR) {
-@@ -357,7 +357,7 @@ simage_gif_save(const char * filename,
- FreeMapObject(cmapobj);
- return 0;
- }
--
-+*/
- /* open gif file and overwrite any existing file */
- if (!(giffile = EGifOpenFileName(filename, FALSE))) {
- giferror = ERR_OPEN;
diff --git a/media-libs/simage/files/simage-1.7.1-tests-conditional.patch b/media-libs/simage/files/simage-1.7.1-tests-conditional.patch
deleted file mode 100644
index ced49159ba69..000000000000
--- a/media-libs/simage/files/simage-1.7.1-tests-conditional.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 5536922..b6de403 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -504,25 +504,28 @@ endforeach()
- # Build tests
- # ############################################################################
-
--enable_testing()
--
--add_executable(loaders tests/loaders.c)
--target_link_libraries(loaders simage)
--target_compile_definitions(loaders PRIVATE _CRT_NONSTDC_NO_DEPRECATE _CRT_SECURE_NO_DEPRECATE _CRT_SECURE_NO_WARNINGS _USE_MATH_DEFINES)
--if(UNIX)
-- target_link_libraries(loaders m)
--endif()
--
--add_test(
-- loaders
-- ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/loaders
-- ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.gif
-- ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.jpg
-- ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.png
-- ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.rgb
-- ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.tga
-- ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.tif
--)
-+if(TESTS)
-+ enable_testing()
-+
-+ add_executable(loaders tests/loaders.c)
-+ target_link_libraries(loaders simage)
-+ target_compile_definitions(loaders PRIVATE _CRT_NONSTDC_NO_DEPRECATE _CRT_SECURE_NO_DEPRECATE _CRT_SECURE_NO_WARNINGS _USE_MATH_DEFINES)
-+ if(UNIX)
-+ target_link_libraries(loaders m)
-+ target_link_libraries(loaders sndfile)
-+ endif()
-+
-+ add_test(
-+ loaders
-+ ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/loaders
-+ ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.gif
-+ ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.jpg
-+ ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.png
-+ ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.rgb
-+ ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.tga
-+ ${CMAKE_CURRENT_SOURCE_DIR}/tests/img.tif
-+ )
-+endif()
-
- # Add a target to generate API documentation with Doxygen
- if(SIMAGE_BUILD_DOCUMENTATION)
diff --git a/media-libs/simage/files/simage-1.8.0-0001-CMakeLists.txt-comment-cpack.d-inclusion.patch b/media-libs/simage/files/simage-1.8.0-0001-CMakeLists.txt-comment-cpack.d-inclusion.patch
deleted file mode 100644
index 4dcc5994f360..000000000000
--- a/media-libs/simage/files/simage-1.8.0-0001-CMakeLists.txt-comment-cpack.d-inclusion.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 1c0e3fb6deb9c3d3c1dd1d4940ffe8d71c2158c9 Mon Sep 17 00:00:00 2001
-From: Bernd Waibel <waebbl@gmail.com>
-Date: Mon, 20 Jan 2020 18:45:10 +0100
-Subject: [PATCH] CMakeLists.txt: comment cpack.d inclusion
-
-Directory is not included in tarball and not needed on Gentoo.
-
-Signed-off-by: Bernd Waibel <waebbl@gmail.com>
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 775037a..e3deb01 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -627,4 +627,4 @@ install(EXPORT ${PROJECT_NAME}
-
- # ############################################################################
- # New CPACK section, please see the README file inside cpack.d directory.
--add_subdirectory(cpack.d)
-+#add_subdirectory(cpack.d)
---
-2.25.0
-
diff --git a/media-libs/simage/simage-1.8.0-r3.ebuild b/media-libs/simage/simage-1.8.0-r3.ebuild
deleted file mode 100644
index 866372cc6409..000000000000
--- a/media-libs/simage/simage-1.8.0-r3.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Image and video texturing library"
-HOMEPAGE="https://github.com/coin3d/simage/"
-SRC_URI="https://github.com/coin3d/simage/releases/download/${P}/${P}-src.tar.gz"
-
-LICENSE="BSD-1"
-KEYWORDS="amd64 ~arm ~hppa ~ia64 ppc ppc64 ~sparc x86"
-SLOT="0"
-IUSE="debug gif jpeg png qt5 sndfile test tiff vorbis"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- sys-libs/zlib:=
- gif? ( media-libs/giflib:= )
- jpeg? ( media-libs/libjpeg-turbo:= )
- png? ( media-libs/libpng:0= )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- )
- sndfile? ( media-libs/libsndfile )
- tiff? ( media-libs/tiff:= )
- vorbis? (
- media-libs/libogg
- media-libs/libvorbis
- )
-"
-DEPEND="
- ${RDEPEND}
- test? ( media-libs/libsndfile )
-"
-
-S="${WORKDIR}/${PN}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.7.1-cmake-automagic-deps.patch"
- # examples need to link against libsndfile unconditionally so either we could
- # make the dep unconditional or not build the examples. i chose the latter way.
- # btw, examples are not installed anyway, they are just compiled.
- "${FILESDIR}/${PN}-1.7.1-disable-examples.patch"
- "${FILESDIR}/${PN}-1.7.1-tests-conditional.patch"
- "${FILESDIR}/${PN}-1.7.1-disable-gif-quantize-buffer.patch"
- "${FILESDIR}/${P}-0001-CMakeLists.txt-comment-cpack.d-inclusion.patch"
-)
-
-DOCS=(AUTHORS ChangeLog NEWS README)
-
-src_configure() {
- use debug && append-cppflags -DSIMAGE_DEBUG=1
-
- local mycmakeargs=(
- -DSIMAGE_AVIENC_SUPPORT=OFF # Windows only
- -DSIMAGE_BUILD_SHARED_LIBS=ON
- -DSIMAGE_CGIMAGE_SUPPORT=OFF # OS X only
- -DSIMAGE_EPS_SUPPORT=ON
- -DSIMAGE_GDIPLUS_SUPPORT=OFF # Windows only
- -DSIMAGE_GIF_SUPPORT=$(usex gif)
- -DSIMAGE_JASPER_SUPPORT=OFF
- -DSIMAGE_JPEG_SUPPORT=$(usex jpeg)
- -DSIMAGE_MPEG2ENC_SUPPORT=ON
- -DSIMAGE_OGGVORBIS_SUPPORT=$(usex vorbis)
- -DSIMAGE_PIC_SUPPORT=ON
- -DSIMAGE_PNG_SUPPORT=$(usex png)
- -DSIMAGE_QIMAGE_SUPPORT=$(usex qt5)
- -DSIMAGE_QUICKTIME_SUPPORT=OFF # OS X only
- -DSIMAGE_SNDFILE_SUPPORT=$(usex sndfile)
- -DSIMAGE_TIFF_SUPPORT=$(usex tiff)
- -DSIMAGE_USE_QT5=ON
- -DSIMAGE_RGB_SUPPORT=ON
- -DSIMAGE_TGA_SUPPORT=ON
- -DSIMAGE_XWD_SUPPORT=ON
- -DTESTS=$(usex test)
- )
-
- cmake_src_configure
-}