summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-08-26 13:53:58 +0100
committerSam James <sam@gentoo.org>2022-08-26 14:09:21 +0100
commit18d58972d3de49d1f9fff807a8f187caa54f47ea (patch)
tree79b0457e2d0dfa83e456e64c302150c886f0c23d /media-libs
parentmedia-libs/gst-plugins-ugly: add 1.20.3 (diff)
downloadgentoo-18d58972d3de49d1f9fff807a8f187caa54f47ea.tar.gz
gentoo-18d58972d3de49d1f9fff807a8f187caa54f47ea.tar.bz2
gentoo-18d58972d3de49d1f9fff807a8f187caa54f47ea.zip
media-libs/gstreamer: add 1.20.3
Closes: https://bugs.gentoo.org/855980 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gstreamer/Manifest1
-rw-r--r--media-libs/gstreamer/gstreamer-1.20.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/media-libs/gstreamer/Manifest b/media-libs/gstreamer/Manifest
index dc2e0ff55b47..e185260f4ba3 100644
--- a/media-libs/gstreamer/Manifest
+++ b/media-libs/gstreamer/Manifest
@@ -1 +1,2 @@
DIST gstreamer-1.20.2.tar.xz 2677552 BLAKE2B 0e6a818fd900c4f0c2748f15262e1d166755e3c419dfa04d7fc4a434ad9a84474d0eb43b9cf0286008497d7ff3e5340b737aeafc45d2994d7c713d5a12e3e2e3 SHA512 994378b656fa593e134624d5d4d5014e78074199d80152eafce29bc09864bd6d0f32a31eafda6cb8caec60aa85b0bda7c42a8c3b388b47d59f2cf4bc729d551f
+DIST gstreamer-1.20.3.tar.xz 2681088 BLAKE2B 423669ff2224cc5d9b979a1353eb1dbcaea5dacca374e83630abf23574f813cbecf5144cdd3209f638aeb50e6764004c3d8020db7f11b21726a9f4b56b513d10 SHA512 e93f9fbf2d7a839dcbe2030ed16dd53eb250741db7c2f1cea396c23e4fabf9a0caff6be4babf7c10aec4b56dc8319a970b1b0bfa6eea2e36aed3e6e1265d9278
diff --git a/media-libs/gstreamer/gstreamer-1.20.3.ebuild b/media-libs/gstreamer/gstreamer-1.20.3.ebuild
new file mode 100644
index 000000000000..c44deb5aeb41
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-1.20.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson pax-utils
+
+DESCRIPTION="Open source multimedia framework"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+caps +introspection +orc unwind"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2[${MULTILIB_USEDEP}]
+ caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+ unwind? (
+ >=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
+ dev-libs/elfutils[${MULTILIB_USEDEP}]
+ )
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ sys-devel/bison
+ sys-devel/flex
+"
+
+DOCS=( AUTHORS ChangeLog NEWS MAINTAINERS README.md RELEASE )
+
+PATCHES=(
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbenchmarks=disabled
+ -Dexamples=disabled
+ -Dcheck=enabled
+ $(meson_feature unwind libunwind)
+ $(meson_feature unwind libdw)
+ )
+
+ if use caps ; then
+ emesonargs+=( -Dptp-helper-permissions=capabilities )
+ else
+ emesonargs+=(
+ -Dptp-helper-permissions=setuid-root
+ -Dptp-helper-setuid-user=nobody
+ -Dptp-helper-setuid-group=nobody
+ )
+ fi
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install() {
+ # can't do "default", we want to install docs in multilib_src_install_all
+ DESTDIR="${D}" eninja install
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/bin/gst-launch-${SLOT}"
+}