summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-14 09:30:19 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-14 09:35:44 -0400
commit3b7afdfc1b3f1b3d5196e1377d0f0daed265c341 (patch)
tree83555d79eadf9d3d0ad0478b65a2255e1e6eede4 /media-libs
parentmedia-libs/mesa: Reduce line length (diff)
downloadgentoo-3b7afdfc1b3f1b3d5196e1377d0f0daed265c341.tar.gz
gentoo-3b7afdfc1b3f1b3d5196e1377d0f0daed265c341.tar.bz2
gentoo-3b7afdfc1b3f1b3d5196e1377d0f0daed265c341.zip
media-libs/mesa: Depend on dev-python/ply
For Intel Vulkan ray tracing. Closes: https://bugs.gentoo.org/906327 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-23.1.0.ebuild12
-rw-r--r--media-libs/mesa/mesa-9999.ebuild12
2 files changed, 22 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-23.1.0.ebuild b/media-libs/mesa/mesa-23.1.0.ebuild
index 77a082163db6..0f1ac3b60433 100644
--- a/media-libs/mesa/mesa-23.1.0.ebuild
+++ b/media-libs/mesa/mesa-23.1.0.ebuild
@@ -168,7 +168,14 @@ BDEPEND="
sys-devel/flex
virtual/pkgconfig
$(python_gen_any_dep ">=dev-python/mako-0.8.0[\${PYTHON_USEDEP}]")
- vulkan? ( dev-util/glslang )
+ vulkan? (
+ dev-util/glslang
+ video_cards_intel? (
+ amd64? (
+ $(python_gen_any_dep "dev-python/ply[\${PYTHON_USEDEP}]")
+ )
+ )
+ )
wayland? ( dev-util/wayland-scanner )
"
@@ -248,6 +255,9 @@ pkg_pretend() {
python_check_deps() {
python_has_version -b ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]"
+ if use vulkan && use video_cards_intel && use amd64; then
+ python_has_version -b "dev-python/ply[${PYTHON_USEDEP}]"
+ fi
}
pkg_setup() {
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 53b4182fdad3..c97b387abfac 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -168,7 +168,14 @@ BDEPEND="
sys-devel/flex
virtual/pkgconfig
$(python_gen_any_dep ">=dev-python/mako-0.8.0[\${PYTHON_USEDEP}]")
- vulkan? ( dev-util/glslang )
+ vulkan? (
+ dev-util/glslang
+ video_cards_intel? (
+ amd64? (
+ $(python_gen_any_dep "dev-python/ply[\${PYTHON_USEDEP}]")
+ )
+ )
+ )
wayland? ( dev-util/wayland-scanner )
"
@@ -246,6 +253,9 @@ pkg_pretend() {
python_check_deps() {
python_has_version -b ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]"
+ if use vulkan && use video_cards_intel && use amd64; then
+ python_has_version -b "dev-python/ply[${PYTHON_USEDEP}]"
+ fi
}
pkg_setup() {