summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-01-13 15:21:43 +0000
committerJames Le Cuirot <chewi@gentoo.org>2017-01-13 15:23:35 +0000
commitac73a8ec52ba3303ca5e22c3f635043f9bca09c7 (patch)
tree2557fd8d77f9a26ef7a42b573f18becf20f245ea /media-libs
parentAdd description for video_cards_imx (diff)
downloadgentoo-ac73a8ec52ba3303ca5e22c3f635043f9bca09c7.tar.gz
gentoo-ac73a8ec52ba3303ca5e22c3f635043f9bca09c7.tar.bz2
gentoo-ac73a8ec52ba3303ca5e22c3f635043f9bca09c7.zip
media-libs/mesa: Add imx and etnaviv/vivante gallium drivers to 9999
Package-Manager: portage-2.3.3
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 356419721bf4..a1105053dd40 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -37,7 +37,7 @@ RESTRICT="!bindist? ( bindist )"
INTEL_CARDS="i915 i965 ilo intel"
RADEON_CARDS="r100 r200 r300 r600 radeon radeonsi"
-VIDEO_CARDS="${INTEL_CARDS} ${RADEON_CARDS} freedreno nouveau vc4 vmware"
+VIDEO_CARDS="${INTEL_CARDS} ${RADEON_CARDS} freedreno imx nouveau vc4 vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -65,6 +65,7 @@ REQUIRED_USE="
video_cards_i915? ( || ( classic gallium ) )
video_cards_i965? ( classic )
video_cards_ilo? ( gallium )
+ video_cards_imx? ( gallium )
video_cards_nouveau? ( || ( classic gallium ) )
video_cards_radeon? ( || ( classic gallium )
gallium? ( x86? ( llvm ) amd64? ( llvm ) ) )
@@ -73,6 +74,7 @@ REQUIRED_USE="
video_cards_r300? ( gallium x86? ( llvm ) amd64? ( llvm ) )
video_cards_r600? ( gallium )
video_cards_radeonsi? ( gallium llvm )
+ video_cards_vivante? ( gallium gbm )
video_cards_vmware? ( gallium )
${PYTHON_REQUIRED_USE}
"
@@ -123,7 +125,7 @@ RDEPEND="
vdpau? ( >=x11-libs/libvdpau-1.1:=[${MULTILIB_USEDEP}] )
wayland? ( >=dev-libs/wayland-1.2.0:=[${MULTILIB_USEDEP}] )
xvmc? ( >=x11-libs/libXvMC-1.0.8:=[${MULTILIB_USEDEP}] )
- ${LIBDRM_DEPSTRING}[video_cards_freedreno?,video_cards_nouveau?,video_cards_vc4?,video_cards_vmware?,${MULTILIB_USEDEP}]
+ ${LIBDRM_DEPSTRING}[video_cards_freedreno?,video_cards_nouveau?,video_cards_vc4?,video_cards_vivante?,video_cards_vmware?,${MULTILIB_USEDEP}]
"
for card in ${INTEL_CARDS}; do
RDEPEND="${RDEPEND}
@@ -247,10 +249,12 @@ multilib_src_configure() {
gallium_enable swrast
gallium_enable video_cards_vc4 vc4
+ gallium_enable video_cards_vivante etnaviv
gallium_enable video_cards_vmware svga
gallium_enable video_cards_nouveau nouveau
gallium_enable video_cards_i915 i915
gallium_enable video_cards_ilo ilo
+ gallium_enable video_cards_imx imx
if ! use video_cards_i915 && \
! use video_cards_i965; then
gallium_enable video_cards_intel i915