summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2023-11-30 14:08:22 -0500
committerSam James <sam@gentoo.org>2023-12-01 03:27:45 +0000
commitba193cfcd1b2bb95055083c52f1f7f3c81ae4b99 (patch)
tree9c80ca76d8ae7f828d228f90383636b414020622 /media-libs
parentmedia-libs/lcms: Stabilize 2.15 hppa, #913067 (diff)
downloadgentoo-ba193cfcd1b2bb95055083c52f1f7f3c81ae4b99.tar.gz
gentoo-ba193cfcd1b2bb95055083c52f1f7f3c81ae4b99.tar.bz2
gentoo-ba193cfcd1b2bb95055083c52f1f7f3c81ae4b99.zip
media-libs/libglvnd: backport hppa test fix
See: https://gitlab.freedesktop.org/glvnd/libglvnd/-/merge_requests/291 Bug: https://bugs.gentoo.org/915660 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libglvnd/files/libglvnd-1.7.0-backport-pr291.patch31
-rw-r--r--media-libs/libglvnd/libglvnd-1.7.0.ebuild2
2 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/libglvnd/files/libglvnd-1.7.0-backport-pr291.patch b/media-libs/libglvnd/files/libglvnd-1.7.0-backport-pr291.patch
new file mode 100644
index 000000000000..43a2fba821ef
--- /dev/null
+++ b/media-libs/libglvnd/files/libglvnd-1.7.0-backport-pr291.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/915660
+https://gitlab.freedesktop.org/glvnd/libglvnd/-/merge_requests/291
+
+From a0945923439d765217cf1cd97d8e948930190c2b Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Wed, 15 Jan 2020 19:21:02 -0800
+Subject: [PATCH] tests: Add _GLOBAL_OFFSET_TABLE_ to PLATFORM_SYMBOLS
+
+On PA-RISC, the _GLOBAL_OFFSET_TABLE_ symbol is always exposed. See
+
+https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=blob;f=bfd/elf32-hppa.c;h=2e653083ce05a77b3e33c056e2f9a51b327c2b22#l1001
+https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=blob;f=sysdeps/hppa/dl-machine.h;h=9e98366ea3b09612d54a3e956d5c35c1bdc86560#l80
+---
+ bin/symbols-check.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/bin/symbols-check.py b/bin/symbols-check.py
+index 947105f..812c3d5 100644
+--- a/bin/symbols-check.py
++++ b/bin/symbols-check.py
+@@ -7,6 +7,7 @@ import subprocess
+
+ # This list contains symbols that _might_ be exported for some platforms
+ PLATFORM_SYMBOLS = [
++ '_GLOBAL_OFFSET_TABLE_',
+ '__bss_end__',
+ '__bss_start__',
+ '__bss_start',
+--
+GitLab
+
diff --git a/media-libs/libglvnd/libglvnd-1.7.0.ebuild b/media-libs/libglvnd/libglvnd-1.7.0.ebuild
index 1f9fbb67d4d9..d1130059daa5 100644
--- a/media-libs/libglvnd/libglvnd-1.7.0.ebuild
+++ b/media-libs/libglvnd/libglvnd-1.7.0.ebuild
@@ -40,6 +40,8 @@ RDEPEND="
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )"
+PATCHES=( "${FILESDIR}/${PN}-1.7.0-backport-pr291.patch" )
+
src_prepare() {
default
sed -i -e "/^PLATFORM_SYMBOLS/a '__gentoo_check_ldflags__'," \