summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-09 10:10:20 +0000
committerSam James <sam@gentoo.org>2021-01-09 10:36:05 +0000
commitf53aea4d85777d68ff790eb6b877a5d83d31f2ab (patch)
treec5a00c2e1efe2313c9a3f8e6fce52fd9ccddfc4e /media-libs
parentmedia-libs/libsdl2: fix trailing whitespace (diff)
downloadgentoo-f53aea4d85777d68ff790eb6b877a5d83d31f2ab.tar.gz
gentoo-f53aea4d85777d68ff790eb6b877a5d83d31f2ab.tar.bz2
gentoo-f53aea4d85777d68ff790eb6b877a5d83d31f2ab.zip
media-libs/lastfmlib: port to EAPI 7, fix StaticSrcUri
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild8
-rw-r--r--media-libs/lastfmlib/lastfmlib-0.4.0.ebuild10
2 files changed, 9 insertions, 9 deletions
diff --git a/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild b/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild
index f10290636479..877bb72bb059 100644
--- a/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild
+++ b/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="C++ library to scrobble tracks on Last.fm"
HOMEPAGE="https://github.com/dirkvdb/lastfmlib/releases"
-SRC_URI="https://github.com/dirkvdb/lastfmlib/archive/lastfmlib-0.4.0.tar.gz"
+SRC_URI="https://github.com/dirkvdb/lastfmlib/archive/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug syslog"
+BDEPEND="virtual/pkgconfig"
RDEPEND="net-misc/curl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${P}-string-conv.patch"
diff --git a/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild b/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild
index 3b55a002f90e..36000699d5c8 100644
--- a/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild
+++ b/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="C++ library to scrobble tracks on Last.fm"
HOMEPAGE="https://github.com/dirkvdb/lastfmlib/releases"
-SRC_URI="https://github.com/dirkvdb/lastfmlib/archive/lastfmlib-0.4.0.tar.gz"
+SRC_URI="https://github.com/dirkvdb/lastfmlib/archive/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="debug syslog"
+BDEPEND="virtual/pkgconfig"
RDEPEND="net-misc/curl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
src_configure() {
econf \