summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-07-23 05:17:53 +0200
committerJames Le Cuirot <chewi@gentoo.org>2023-01-08 23:21:04 +0000
commitf5f8b6bf7e7db6f2119f2f0ae7edfa803ac59da0 (patch)
treea9543aa107b6bd1be4043cb55de8cd4a9c6c6966 /media-libs
parentdev-db/rqlite: add 7.13.1 (diff)
downloadgentoo-f5f8b6bf7e7db6f2119f2f0ae7edfa803ac59da0.tar.gz
gentoo-f5f8b6bf7e7db6f2119f2f0ae7edfa803ac59da0.tar.bz2
gentoo-f5f8b6bf7e7db6f2119f2f0ae7edfa803ac59da0.zip
media-libs/libsdl: Add live package targeting sdl12-compat
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/21749 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/libsdl-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/libsdl/libsdl-9999.ebuild b/media-libs/libsdl/libsdl-9999.ebuild
new file mode 100644
index 000000000000..2acec880995c
--- /dev/null
+++ b/media-libs/libsdl/libsdl-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit git-r3 cmake-multilib
+
+DESCRIPTION="Simple Direct Media Layer (sdl-1.2 compatibility)"
+HOMEPAGE="https://github.com/libsdl-org/sdl12-compat"
+EGIT_REPO_URI="https://github.com/libsdl-org/sdl12-compat"
+LICENSE="ZLIB"
+SLOT="0"
+RESTRICT="!test? ( test )"
+
+# First line are fakes and just there for compat with other ebuilds
+IUSE="
+ oss alsa nas X dga xv xinerama fbcon tslib aalib opengl libcaca +sound +video +joystick custom-cflags pulseaudio static-libs
+ test
+"
+
+# IUSE inheritance dropped: dga, xv, fbcon, tflib, aalib, libcaca, custom-cflags, static-libs
+DEPEND="
+ media-libs/libsdl2[oss?,alsa?,nas?,xinerama?,opengl?,sound?,video?,joystick?,pulseaudio?]
+ X? ( || (
+ media-libs/libsdl2[X]
+ media-libs/libsdl2[wayland]
+ ) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSDL12TESTS=$(usex test)
+ )
+
+ cmake-multilib_src_configure
+}