summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-02-19 12:49:30 +0300
committerSam James <sam@gentoo.org>2022-03-08 13:32:19 +0000
commit93b6417f1b55aefc05b91fec7b67eadd32b1f733 (patch)
tree2aa4e2a88378a5d76295ee10fc7b91f2ac40c259 /media-plugins/gst-plugins-cdparanoia
parentmedia-libs/libfreeaptx: Change to multilib build (diff)
downloadgentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.tar.gz
gentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.tar.bz2
gentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.zip
media-libs/gstreamer: Bump to 1.20.0
Gstreamer 1.20.0 version bump, includes - all existing 1.18.4 plugins except for two dropped upstream (gst-plugins-libmms and gst-plugins-ofa) - libnice-0.1.18 version bump required by gst-plugins-webrtc in 1.20.0 - required multilib change for libldac for new plugin gst-plugins-ldac - required multilib change for libopenaptx and libfreeaptx for new plugin gst-plugins-openaptx As discussed, this change adds a LICENSE to each of gstreamer modules which now require explicit opt-in for (A)GPL plugins for (A)GPL plugins we will not perform explicit license acceptance for affected gstreamer plugin, instead we will rely on a user accepting the license of dependency: - gstreamer change added explicit opt-in https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1084 - I looked at affected gstreamer plugins and looks like all are correctly license-compatible according to compatibility matrix https://www.gnu.org/licenses/gpl-faq.html#AllCompatibility - if a user is not willing to accept the license of corresponding (A)GPL dependency, such dependency will not be available and affected gstreamer plugin will not be built - Upstream gstreamer team will look into updating/fixing plugin license display available via gst-inspect-1.0 <plugin name> | grep License as currently it is just "GPL" which is not specific enough (should be GPL-2, GPL-2+, GPL-3 etc.) Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-cdparanoia')
-rw-r--r--media-plugins/gst-plugins-cdparanoia/Manifest1
-rw-r--r--media-plugins/gst-plugins-cdparanoia/gst-plugins-cdparanoia-1.20.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-cdparanoia/Manifest b/media-plugins/gst-plugins-cdparanoia/Manifest
index b5169db2edc8..16e7dbff8e45 100644
--- a/media-plugins/gst-plugins-cdparanoia/Manifest
+++ b/media-plugins/gst-plugins-cdparanoia/Manifest
@@ -1,2 +1,3 @@
DIST gst-plugins-base-1.16.3.tar.xz 3953616 BLAKE2B c78713d0aa77a7e8c8043377a7b7959e8159baa3c3b81751b6dc825137c26fe8e52d3ff2c9c734bdda1d01a087b67d1bce4da66de390aad8169c74001c8f620c SHA512 d44d4da9cb27a6b8e59cb3f0714cc71809c0f14b42ef8d4a2dddbb940efbcb9634a40596d3cdc7391016f6e758005c14aabe1f8f30bb597a57d85c2d94045e75
DIST gst-plugins-base-1.18.4.tar.xz 3169512 BLAKE2B 8b5a7a08641532631842e2ec02379b116ae0f08cda7654d123dbb2d56f97667b94ffc716b389a14ad034d0edb36587d8edc2c4f53782135c53def248fa60d0a3 SHA512 c750d68404462807ff03f441e232c4d98752a9bceeec3038fb37a105942f25499bde0660ca688b6f3204c58eb6a2e3f33671e979018c8bd829e7591455961a6a
+DIST gst-plugins-base-1.20.0.tar.xz 3286080 BLAKE2B 52d5b7c80538ddea1699cc279756d69a4db6478298e4b38961ed32e67d9612cf8ace5ac304d8131175fb759606e495de2365ea5d764e9ca085478db1fd3c2fc0 SHA512 d04b1a3ea6c4bc484aca820c5d3272e54824a6934d537bd6d39f6d542deb4a5f7f7854b88e2759e14f3e35adde72a56a2b0dd8fc5cf4c97473989a80a2195ebd
diff --git a/media-plugins/gst-plugins-cdparanoia/gst-plugins-cdparanoia-1.20.0.ebuild b/media-plugins/gst-plugins-cdparanoia/gst-plugins-cdparanoia-1.20.0.ebuild
new file mode 100644
index 000000000000..54e10a774b4d
--- /dev/null
+++ b/media-plugins/gst-plugins-cdparanoia/gst-plugins-cdparanoia-1.20.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-base
+
+inherit gstreamer-meson
+
+DESCRIPTION="CD Audio Source (cdda) plugin for GStreamer"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-sound/cdparanoia-3.10.2-r6[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ gstreamer_system_package audio_dep:gstreamer-audio
+}