summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/forked-daapd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/forked-daapd/files')
-rw-r--r--media-sound/forked-daapd/files/daapd.confd11
-rw-r--r--media-sound/forked-daapd/files/daapd.initd31
-rw-r--r--media-sound/forked-daapd/files/forked-daapd-23.2-fix-arg-enable.patch57
3 files changed, 99 insertions, 0 deletions
diff --git a/media-sound/forked-daapd/files/daapd.confd b/media-sound/forked-daapd/files/daapd.confd
new file mode 100644
index 000000000000..8b268509861b
--- /dev/null
+++ b/media-sound/forked-daapd/files/daapd.confd
@@ -0,0 +1,11 @@
+# Set the log level (0-5)
+#LOG_LEVEL=2
+
+# Specify the log domains. Comma-separated, choose from: config,
+# daap, db, httpd, main, mdns, misc, rsp, scan, xcode, event, remote,
+# dacp, ffmpeg, artwork, player, raop, laudio, dmap, dbperf, spotify,
+# lastfm, cache
+#LOG_DOMAINS=main,config
+
+# ffid to be broadcast in mDNS records
+#FFID=homeserver
diff --git a/media-sound/forked-daapd/files/daapd.initd b/media-sound/forked-daapd/files/daapd.initd
new file mode 100644
index 000000000000..cc3c8e8d6e6e
--- /dev/null
+++ b/media-sound/forked-daapd/files/daapd.initd
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+
+# Override in /etc/conf.d/daapd
+LOG_LEVEL=${LOG_LEVEL:-2}
+LOG_DOMAINS=${LOG_DOMAINS:-'main,mdns,db,scan'}
+FFID=${FFID:-daapd}
+
+PIDFILE=/var/run/forked-daapd.pid
+
+depend() {
+ need avahi-dnsconfd
+}
+
+start() {
+ ebegin "Starting daapd"
+ start-stop-daemon --start forked-daapd \
+ --pidfile "$PIDFILE" \
+ -- \
+ -P "$PIDFILE" \
+ -d "$LOG_LEVEL" \
+ -b "$FFID" \
+ -D "$LOG_DOMAINS"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping daapd"
+ start-stop-daemon --stop forked-daapd \
+ --pidfile "$PIDFILE"
+ eend $?
+}
diff --git a/media-sound/forked-daapd/files/forked-daapd-23.2-fix-arg-enable.patch b/media-sound/forked-daapd/files/forked-daapd-23.2-fix-arg-enable.patch
new file mode 100644
index 000000000000..7c4297ef0e9f
--- /dev/null
+++ b/media-sound/forked-daapd/files/forked-daapd-23.2-fix-arg-enable.patch
@@ -0,0 +1,57 @@
+--- configure.ac.orig 2015-07-20 18:03:12.270584746 -0500
++++ configure.ac 2015-07-20 18:03:00.050585581 -0500
+@@ -51,25 +51,35 @@
+ AC_SYS_LARGEFILE
+ AC_TYPE_OFF_T
+
+-AC_ARG_ENABLE(flac, AS_HELP_STRING([--enable-flac], [extract FLAC metadata with libflac (default=no)]),
+- use_flac=true;
+- CPPFLAGS="${CPPFLAGS} -DFLAC")
+-
+-AC_ARG_ENABLE(musepack, AS_HELP_STRING([--enable-musepack], [extract Musepack metadata with taglib (default=no)]),
+- use_musepack=true;
+- CPPFLAGS="${CPPFLAGS} -DMUSEPACK")
+-
+-AC_ARG_ENABLE(itunes, AS_HELP_STRING([--enable-itunes], [enable iTunes library support (default=no)]),
+- use_itunes=true;
+- CPPFLAGS="${CPPFLAGS} -DITUNES")
+-
+-AC_ARG_ENABLE(spotify, AS_HELP_STRING([--enable-spotify], [enable Spotify library support (default=no)]),
+- use_spotify=true;
+- CPPFLAGS="${CPPFLAGS} -DSPOTIFY")
+-
+-AC_ARG_ENABLE(lastfm, AS_HELP_STRING([--enable-lastfm], [enable LastFM support (default=no)]),
+- use_lastfm=true;
+- CPPFLAGS="${CPPFLAGS} -DLASTFM")
++AC_ARG_ENABLE(flac, AS_HELP_STRING([--enable-flac], [extract FLAC metadata with libflac (default=no)]))
++AS_IF([test "x$enable_flac" = "xyes"], [
++ use_flac=true;
++ CPPFLAGS="${CPPFLAGS} -DFLAC"
++])
++
++AC_ARG_ENABLE(musepack, AS_HELP_STRING([--enable-musepack], [extract Musepack metadata with taglib (default=no)]))
++AS_IF([test "x$enable_musepack" = "xyes"], [
++ use_musepack=true;
++ CPPFLAGS="${CPPFLAGS} -DMUSEPACK"
++])
++
++AC_ARG_ENABLE(itunes, AS_HELP_STRING([--enable-itunes], [enable iTunes library support (default=no)]))
++AS_IF([test "x$enable_itunes" = "xyes"], [
++ use_itunes=true;
++ CPPFLAGS="${CPPFLAGS} -DITUNES"
++])
++
++AC_ARG_ENABLE(spotify, AS_HELP_STRING([--enable-spotify], [enable Spotify library support (default=no)]))
++AS_IF([test "x$enable_spotify" = "xyes"], [
++ use_spotify=true;
++ CPPFLAGS="${CPPFLAGS} -DSPOTIFY"
++])
++
++AC_ARG_ENABLE(lastfm, AS_HELP_STRING([--enable-lastfm], [enable LastFM support (default=no)]))
++AS_IF([test "x$enable_lastfm" = "xyes"], [
++ use_lastfm=true;
++ CPPFLAGS="${CPPFLAGS} -DLASTFM"
++])
+
+ case "$host" in
+ *-*-linux-*)