summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas PARLANT <nicolas.parlant@parhuet.fr>2024-12-18 19:58:09 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2024-12-28 01:04:40 +0100
commit9aa9b585c2276c70943dc888124a864d224e70e0 (patch)
treefc6e0c4df9709e6d03983733169db54e769b1e57 /media-sound/id3ted
parentmedia-sound/ncmpcpp: drop 0.9.2_p20221231, 0.9.2_p20240724 (diff)
downloadgentoo-9aa9b585c2276c70943dc888124a864d224e70e0.tar.gz
gentoo-9aa9b585c2276c70943dc888124a864d224e70e0.tar.bz2
gentoo-9aa9b585c2276c70943dc888124a864d224e70e0.zip
media-sound/id3ted: fix build with taglib2
no upstream PR as repo is archive update EAPI 7 -> 8 Add media-libs/taglib:= slot op, ABI break imminent Signed-off-by: Nicolas PARLANT <nicolas.parlant@parhuet.fr> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/id3ted')
-rw-r--r--media-sound/id3ted/files/id3ted-1.0-fix-build-taglib2.patch47
-rw-r--r--media-sound/id3ted/id3ted-1.0-r1.ebuild29
2 files changed, 76 insertions, 0 deletions
diff --git a/media-sound/id3ted/files/id3ted-1.0-fix-build-taglib2.patch b/media-sound/id3ted/files/id3ted-1.0-fix-build-taglib2.patch
new file mode 100644
index 000000000000..46437c6d10e5
--- /dev/null
+++ b/media-sound/id3ted/files/id3ted-1.0-fix-build-taglib2.patch
@@ -0,0 +1,47 @@
+no upstream PR as repo is archive
+--- a/fileio.cpp
++++ b/fileio.cpp
+@@ -60,11 +60,11 @@ bool FileIO::isRegular(const char *path) {
+
+
+ bool FileIO::isReadable(const char *path) {
+- return TagLib::File::isReadable(path);
++ return !access(path, R_OK);
+ }
+
+ bool FileIO::isWritable(const char *path) {
+- return TagLib::File::isWritable(path);
++ return !access(path, W_OK);
+ }
+
+ string FileIO::sizeHumanReadable(unsigned long size) {
+--- a/id3ted.h
++++ b/id3ted.h
+@@ -30,7 +30,6 @@
+
+ using namespace std;
+ using namespace TagLib;
+-using TagLib::uint;
+
+ void warn(const char* fmt, ...);
+
+--- a/mp3file.cpp
++++ b/mp3file.cpp
+@@ -343,7 +343,7 @@ bool MP3File::save() {
+ if (tags & 2 && id3v2Tag != NULL && id3v2Tag->isEmpty())
+ strip(2);
+
+- return file.save(tags, false);
++ return file.save();
+ }
+
+ bool MP3File::strip(int tags) {
+@@ -391,7 +391,7 @@ void MP3File::showInfo() const {
+ break;
+ }
+
+- int length = properties->length();
++ int length = properties->lengthInSeconds();
+ printf("MPEG %s Layer %d %s\n", version, properties->layer(), channelMode);
+ printf("bitrate: %d kBit/s, sample rate: %d Hz, length: %02d:%02d:%02d\n",
+ properties->bitrate(), properties->sampleRate(),
diff --git a/media-sound/id3ted/id3ted-1.0-r1.ebuild b/media-sound/id3ted/id3ted-1.0-r1.ebuild
new file mode 100644
index 000000000000..6c16c266036b
--- /dev/null
+++ b/media-sound/id3ted/id3ted-1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Command-line ID3 Tag Editor"
+HOMEPAGE="https://github.com/xyb3rt/id3ted"
+SRC_URI="https://github.com/xyb3rt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/taglib:=
+ sys-apps/file"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-outofbounds.patch"
+ "${FILESDIR}/${P}-fix-build-taglib2.patch"
+)
+
+pkg_setup() {
+ export PREFIX="/usr"
+ tc-export CXX
+}