summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-04-09 10:58:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-04-09 10:58:38 -0500
commit979f9b8b7ba7307bcd7679ba92e5eb2f7b9ec4a7 (patch)
tree7def6d6c92e689d5fc68fd25160caeb88038b8df /media-sound/mangler
parentsys-devel/gcc: stable 10.2.0-r5 for hppa, bug #762907 (diff)
downloadgentoo-979f9b8b7ba7307bcd7679ba92e5eb2f7b9ec4a7.tar.gz
gentoo-979f9b8b7ba7307bcd7679ba92e5eb2f7b9ec4a7.tar.bz2
gentoo-979f9b8b7ba7307bcd7679ba92e5eb2f7b9ec4a7.zip
media-sound/mangler: fix version-info bug
Closes: https://bugs.gentoo.org/778377 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'media-sound/mangler')
-rw-r--r--media-sound/mangler/files/mangler-version-info.patch19
-rw-r--r--media-sound/mangler/mangler-1.2.5-r1.ebuild4
2 files changed, 22 insertions, 1 deletions
diff --git a/media-sound/mangler/files/mangler-version-info.patch b/media-sound/mangler/files/mangler-version-info.patch
new file mode 100644
index 000000000000..200c8e7ecab9
--- /dev/null
+++ b/media-sound/mangler/files/mangler-version-info.patch
@@ -0,0 +1,19 @@
+commit 2581fbd54434df6dc4babd48bb41eaf7f5d6d06a
+Author: orbea <orbea@riseup.net>
+Date: Wed Apr 7 10:01:31 2021 -0700
+
+ libventrilo3: Fix -version-info typo.
+
+diff --git a/libventrilo3/Makefile.am b/libventrilo3/Makefile.am
+index a934acf..c2fea99 100644
+--- a/libventrilo3/Makefile.am
++++ b/libventrilo3/Makefile.am
+@@ -7,7 +7,7 @@ libventrilo3_la_SOURCES = libventrilo3.c libventrilo3_message.c ventrilo3_hand
+
+ libventrilo3_la_LIBADD = $(speex_LIBS) $(opus_LIBS) $(LIBS) -lm
+
+-libventrilo3_la_LDFLAGS = -version 0:0:0
++libventrilo3_la_LDFLAGS = -version-info 0:0:0
+
+ include_HEADERS = ventrilo3.h
+
diff --git a/media-sound/mangler/mangler-1.2.5-r1.ebuild b/media-sound/mangler/mangler-1.2.5-r1.ebuild
index 8f58aefd5e7c..bad5f2f06fcd 100644
--- a/media-sound/mangler/mangler-1.2.5-r1.ebuild
+++ b/media-sound/mangler/mangler-1.2.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,6 +33,8 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/mangler-version-info.patch" )
+
src_configure() {
tc-export CC