summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-15 09:51:44 +0000
committerSam James <sam@gentoo.org>2023-02-15 09:51:44 +0000
commit501d68999d858a4dea36114a599ec2aa57944b3d (patch)
tree3c2889ad8ad480d227d28b3e5be533bc7f7399c8 /media-sound/mp3info
parentdev-util/scanmem: fix build w/ musl (diff)
downloadgentoo-501d68999d858a4dea36114a599ec2aa57944b3d.tar.gz
gentoo-501d68999d858a4dea36114a599ec2aa57944b3d.tar.bz2
gentoo-501d68999d858a4dea36114a599ec2aa57944b3d.zip
media-sound/mp3info: fix build w/ musl
Closes: https://bugs.gentoo.org/717014 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/mp3info')
-rw-r--r--media-sound/mp3info/files/mp3info-0.8.5a-musl.patch12
-rw-r--r--media-sound/mp3info/mp3info-0.8.5a-r1.ebuild3
2 files changed, 14 insertions, 1 deletions
diff --git a/media-sound/mp3info/files/mp3info-0.8.5a-musl.patch b/media-sound/mp3info/files/mp3info-0.8.5a-musl.patch
new file mode 100644
index 000000000000..1b190c29d61d
--- /dev/null
+++ b/media-sound/mp3info/files/mp3info-0.8.5a-musl.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/717014
+--- a/mp3tech.c
++++ b/mp3tech.c
+@@ -279,7 +279,7 @@ char *header_mode(mp3header *h) {
+ }
+
+ int sameConstant(mp3header *h1, mp3header *h2) {
+- if((*(uint*)h1) == (*(uint*)h2)) return 1;
++ if((*(unsigned int*)h1) == (*(unsigned int*)h2)) return 1;
+
+ if((h1->version == h2->version ) &&
+ (h1->layer == h2->layer ) &&
diff --git a/media-sound/mp3info/mp3info-0.8.5a-r1.ebuild b/media-sound/mp3info/mp3info-0.8.5a-r1.ebuild
index 11ba9807f0ff..0015b7270459 100644
--- a/media-sound/mp3info/mp3info-0.8.5a-r1.ebuild
+++ b/media-sound/mp3info/mp3info-0.8.5a-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,6 +27,7 @@ PATCHES=(
"${FILESDIR}/${P}-ldflags.patch"
"${FILESDIR}/${P}-tinfo.patch"
"${FILESDIR}/${P}-format-security.patch"
+ "${FILESDIR}/${P}-musl.patch"
)
src_compile() {