summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/specimen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/specimen')
-rw-r--r--media-sound/specimen/Manifest1
-rw-r--r--media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch22
-rw-r--r--media-sound/specimen/files/specimen-0.5.2_rc3-underlinking.patch79
-rw-r--r--media-sound/specimen/metadata.xml10
-rw-r--r--media-sound/specimen/specimen-0.5.2_rc3-r1.ebuild49
5 files changed, 161 insertions, 0 deletions
diff --git a/media-sound/specimen/Manifest b/media-sound/specimen/Manifest
new file mode 100644
index 000000000000..627bd65f533a
--- /dev/null
+++ b/media-sound/specimen/Manifest
@@ -0,0 +1 @@
+DIST specimen-0.5.2-rc3.tar.gz 267948 SHA256 249cf434ee81828b46c383dbf6b1873564f227f2461c9956b539be0a3c2feb72 SHA512 0fbe298ef9652b8f8535fc4382ec71457c882a7fb05412cb1621e7aa566a293b71f4a2600eaaa4336093ec73b9dd6bb53371565ef0f02d7e400d497718c384f4 WHIRLPOOL dbf93e766280d1f8459f1a08189ebe939c121d89771cab2d5127d8e352d3c143885d371b9c4c468a15b85ffdfa988c781e57671ff33386b757a86799dbda0e81
diff --git a/media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch b/media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch
new file mode 100644
index 000000000000..2e3cf2ba9125
--- /dev/null
+++ b/media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch
@@ -0,0 +1,22 @@
+Index: specimen-0.5.2-rc3/src/jackdriver.c
+===================================================================
+--- specimen-0.5.2-rc3.orig/src/jackdriver.c
++++ specimen-0.5.2-rc3/src/jackdriver.c
+@@ -81,7 +81,7 @@ static int process (jack_nframes_t frame
+ jack_midi_event_t jack_midi_event;
+ jack_nframes_t event_index = 0;
+ #ifdef HAVE_JACK_MIDI
+- jack_nframes_t event_count = jack_midi_get_event_count(midi_buf, frames);
++ jack_nframes_t event_count = jack_midi_get_event_count(midi_buf);
+ #endif /* HAVE_JACK_MIDI */
+ #ifdef HAVE_OLD_JACK_MIDI
+ jack_nframes_t event_count = jack_midi_port_get_info(midi_buf, frames)->event_count;
+@@ -123,7 +123,7 @@ static int process (jack_nframes_t frame
+ /* send the JACK MIDI events to the mixer */
+ while (event_index < event_count) {
+
+- jack_midi_event_get(&jack_midi_event, midi_buf,event_index, frames);
++ jack_midi_event_get(&jack_midi_event, midi_buf,event_index);
+ midi_data = jack_midi_event.buffer;
+
+ /* TODO: handle 14-bit controllers and RPNs and NRPNs */
diff --git a/media-sound/specimen/files/specimen-0.5.2_rc3-underlinking.patch b/media-sound/specimen/files/specimen-0.5.2_rc3-underlinking.patch
new file mode 100644
index 000000000000..6267d7ad572d
--- /dev/null
+++ b/media-sound/specimen/files/specimen-0.5.2_rc3-underlinking.patch
@@ -0,0 +1,79 @@
+--- configure.ac
++++ configure.ac
+@@ -1,10 +1,10 @@
+ # -*- autoconf -*-
+ # Process this file with autoconf to produce a configure script.
+
+-AC_INIT(configure.ac)
+-AM_INIT_AUTOMAKE(specimen, 0.5.2-rc3)
+-AM_CONFIG_HEADER(src/config.h)
+-
++AC_INIT([specimen], [0.5.2-rc3])
++AC_CONFIG_HEADERS([src/config.h])
++AM_INIT_AUTOMAKE
++m4_include([acx_pthread.m4])
+
+ # compilation
+ with_debug="no"
+@@ -13,9 +13,7 @@
+ [enable debugging information, accepting a performance penalty (default is NO)])],
+ [if test x$enable_debug = xyes; then with_debug=yes ; fi])
+
+-if test x$with_debug = xno; then
+- CFLAGS="-O3"
+-else
++if test x$with_debug != xno; then
+ AC_DEFINE(DEBUG, 1, [[whether to display debugging output or not]])
+ fi
+
+@@ -48,13 +46,14 @@
+ AC_FUNC_MALLOC
+ AC_CHECK_FUNCS([floor gettimeofday pow strchr strdup])
+
++dnl Check for libm for sin()
++AC_SEARCH_LIBS([sin], [m], [], [
++ AC_MSG_ERROR([unable to find the sin() function])
++])
++
+ # pthreads
+ ACX_PTHREAD
+
+-SPECIMEN_CFLAGS="-Wall -Werror"
+-AC_SUBST(SPECIMEN_CFLAGS)
+-CFLAGS="$SPECIMEN_CFLAGS $CFLAGS"
+-
+ config_error="no"
+
+ # gtk
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -11,7 +11,7 @@
+ specimen_SOURCES += lashdriver.c lashdriver.h
+ endif
+
+-INCLUDES = \
++AM_CPPFLAGS = \
+ @ALSA_CFLAGS@ \
+ @JACK_CFLAGS@ \
+ @LIBSAMPLERATE_CFLAGS@ \
+
+--- src/gui/Makefile.am
++++ src/gui/Makefile.am
+@@ -12,14 +12,14 @@
+ paramselector.c paramselector.h patchlist.c patchlist.h midisection.c \
+ midisection.h channelsection.c channelsection.h
+
+-INCLUDES = \
++AM_CPPFLAGS = \
+ -l.. \
+ @GTK_CFLAGS@ \
+ @LIBGNOMECANVAS_CFLAGS@ \
+ @PHAT_CFLAGS@
+
+ if HAVE_LASH
+-INCLUDES += @LASH_CFLAGS@
++AM_CPPFLAGS += @LASH_CFLAGS@
+ endif
+
+ libgui_a_CFLAGS = $(CFLAGS) -I.. -DINSTALLDIR=\"$(datadir)\"
diff --git a/media-sound/specimen/metadata.xml b/media-sound/specimen/metadata.xml
new file mode 100644
index 000000000000..ea3e2d913f8b
--- /dev/null
+++ b/media-sound/specimen/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription>
+ Specimen is a midi controlled audio sampler for GNU/Linux systems. It
+ allows you to create music using various sound files, or "samples", in
+ tandem with a midi sequencer.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-sound/specimen/specimen-0.5.2_rc3-r1.ebuild b/media-sound/specimen/specimen-0.5.2_rc3-r1.ebuild
new file mode 100644
index 000000000000..03c7f3a6dc55
--- /dev/null
+++ b/media-sound/specimen/specimen-0.5.2_rc3-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_P=${P/_/-}
+
+DESCRIPTION="A Midi Controllable Audio Sampler"
+HOMEPAGE="http://zhevny.com/specimen"
+SRC_URI="http://zhevny.com/${PN}/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc sparc x86"
+IUSE="lash"
+
+RDEPEND=">=media-sound/jack-audio-connection-kit-0.109.2
+ >=media-libs/alsa-lib-0.9
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ >=media-libs/phat-0.4
+ dev-libs/libxml2:2
+ x11-libs/gtk+:2
+ gnome-base/libgnomecanvas
+ lash? ( media-sound/lash )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-jackmidi.patch" \
+ "${FILESDIR}/${P}-underlinking.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable lash)
+}
+
+src_install() {
+ default
+ dodoc AUTHORS BUGS ChangeLog NEWS PROFILE \
+ README ROADMAP TODO STYLE TODO WISHLIST
+ doicon pixmaps/${PN}.png
+ make_desktop_entry ${PN} Specimen ${PN}
+}