summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-21 18:04:30 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-21 18:13:30 +0100
commit51c4f47c76597913de2c00b96f1c0a71b3eee82e (patch)
treefa22dabe3ece8ebc9600ea2a145050b19402dd30 /media-sound
parentdev-lang/perl,virtual/perl-Module-CoreList: Bump to 5.22.3 Final (diff)
downloadgentoo-51c4f47c76597913de2c00b96f1c0a71b3eee82e.tar.gz
gentoo-51c4f47c76597913de2c00b96f1c0a71b3eee82e.tar.bz2
gentoo-51c4f47c76597913de2c00b96f1c0a71b3eee82e.zip
media-sound/ecasound: python-single-r1, EAPI=6
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ecasound/ecasound-2.6.0-r1.ebuild (renamed from media-sound/ecasound/ecasound-2.6.0.ebuild)47
-rw-r--r--media-sound/ecasound/ecasound-2.9.1-r1.ebuild (renamed from media-sound/ecasound/ecasound-2.9.1.ebuild)70
2 files changed, 51 insertions, 66 deletions
diff --git a/media-sound/ecasound/ecasound-2.6.0.ebuild b/media-sound/ecasound/ecasound-2.6.0-r1.ebuild
index 3b0e3ca6bca0..99d0d192d101 100644
--- a/media-sound/ecasound/ecasound-2.6.0.ebuild
+++ b/media-sound/ecasound/ecasound-2.6.0-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=3
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
-inherit eutils python
+inherit eutils python-single-r1
DESCRIPTION="a package for multitrack audio processing"
HOMEPAGE="http://ecasound.seul.org/ecasound"
@@ -15,7 +16,7 @@ SLOT="1"
KEYWORDS="amd64 ~ppc x86"
IUSE="alsa audiofile debug doc jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
-RDEPEND="python? ( dev-lang/python )
+RDEPEND="python? ( ${PYTHON_DEPS} )
jack? ( media-sound/jack-audio-connection-kit )
media-libs/ladspa-sdk
audiofile? ( media-libs/audiofile )
@@ -30,15 +31,17 @@ RDEPEND="python? ( dev-lang/python )
sys-libs/readline"
DEPEND="${RDEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_configure() {
- local PYConf
+ local pyconf=()
- if use python; then
- PYConf="--enable-pyecasound=c
- --with-python-includes=$(python_get_includedir)
- --with-python-modules=$(python_get_libdir)"
- else
- PYConf="$myconf --disable-pyecasound"
+ if use python ; then
+ pyconf=( "--with-python-modules=${EPREFIX}/usr/$(get_libdir)/${EPYTHON}" )
fi
econf \
@@ -50,28 +53,18 @@ src_configure() {
$(use_enable libsamplerate) \
$(use_enable ncurses) \
$(use_enable oss) \
+ $(use_enable python pyecasound c) \
$(use_enable ruby rubyecasound) \
$(use_enable sndfile) \
--enable-shared \
--with-largefile \
--enable-sys-readline \
- ${PYConf} || die "econf failed"
+ "${pyconf[@]}"
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc BUGS NEWS README TODO Documentation/*.txt
- use doc && dohtml Documentation/*.html
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize ecacontrol.py eci.py pyeca.py
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup ecacontrol.py eci.py pyeca.py
- fi
+ emake DESTDIR="${D}" install
+ use python && python_optimize
+ dodoc BUGS NEWS README TODO
+ use doc && dodoc Documentation/*.html
}
diff --git a/media-sound/ecasound/ecasound-2.9.1.ebuild b/media-sound/ecasound/ecasound-2.9.1-r1.ebuild
index a17e5c60fb1e..db40f645c4b3 100644
--- a/media-sound/ecasound/ecasound-2.9.1.ebuild
+++ b/media-sound/ecasound/ecasound-2.9.1-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-PYTHON_DEPEND="python? 2"
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
-inherit eutils python autotools
+inherit autotools eutils python-single-r1
DESCRIPTION="a package for multitrack audio processing"
HOMEPAGE="http://ecasound.seul.org/ecasound"
@@ -16,48 +16,47 @@ SLOT="1"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="alsa audiofile debug doc jack libsamplerate lv2 mikmod ncurses oil osc oss
python ruby sndfile static-libs test"
-REQUIRED_USE="test? ( lv2 )"
-
-RDEPEND="sys-libs/readline
- alsa? ( media-libs/alsa-lib )
- audiofile? ( media-libs/audiofile )
- jack? ( media-sound/jack-audio-connection-kit )
- libsamplerate? ( media-libs/libsamplerate )
- lv2? ( >=media-libs/lilv-0.5.0 )
+REQUIRED_USE="test? ( lv2 )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="sys-libs/readline:0=
+ alsa? ( media-libs/alsa-lib:= )
+ audiofile? ( media-libs/audiofile:= )
+ jack? ( virtual/jack:= )
+ libsamplerate? ( media-libs/libsamplerate:= )
+ lv2? ( >=media-libs/lilv-0.5.0:= )
media-libs/ladspa-sdk
- mikmod? ( media-libs/libmikmod:0 )
- ncurses? ( sys-libs/ncurses )
- oil? ( dev-libs/liboil )
- osc? ( media-libs/liblo )
+ mikmod? ( media-libs/libmikmod:0= )
+ ncurses? ( sys-libs/ncurses:0= )
+ oil? ( dev-libs/liboil:= )
+ osc? ( media-libs/liblo:= )
+ python? ( ${PYTHON_DEPS} )
ruby? ( dev-lang/ruby )
- sndfile? ( media-libs/libsndfile )"
+ sndfile? ( media-libs/libsndfile:= )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
pkg_setup() {
- if use python ; then
- python_set_active_version 2
- python_pkg_setup
- fi
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.8.1-ldflags.patch
+ eapply "${FILESDIR}"/${PN}-2.8.1-ldflags.patch
+ eapply_user
- if use python ; then
- sed -i -e "s:\$(ecasoundc_libs):\0 $(python_get_library -l):" \
- pyecasound/Makefile.am || die "sed failed"
- fi
+# if use python ; then
+# sed -i -e "s:\$(ecasoundc_libs):\0 $(python_get_library -l):" \
+# pyecasound/Makefile.am || die "sed failed"
+# fi
eautoreconf
}
src_configure() {
- local pyconf
+ local pyconf=()
if use python ; then
- pyconf="--with-python-includes=${EPREFIX}$(python_get_includedir)
- --with-python-modules=${EPREFIX}$(python_get_libdir)"
+ pyconf=( "--with-python-modules=${EPREFIX}/usr/$(get_libdir)/${EPYTHON}" )
fi
econf \
@@ -79,24 +78,17 @@ src_configure() {
$(use_enable ruby rubyecasound) \
$(use_enable sndfile) \
$(use_enable static-libs static) \
- ${pyconf}
+ "${pyconf[@]}"
}
src_install() {
default
+ use python && python_optimize
if use doc ; then
- dohtml Documentation/*.html
+ dodoc Documentation/*.html
dodoc Documentation/programmers_guide/ecasound_programmers_guide.txt
fi
prune_libtool_files
}
-
-pkg_postinst() {
- use python && python_mod_optimize ecacontrol.py eci.py pyeca.py
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup ecacontrol.py eci.py pyeca.py
-}