summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2021-05-31 20:14:28 +0100
committerTony Vroon <chainsaw@gentoo.org>2021-05-31 20:14:55 +0100
commit98f91452d5abe876b19e2be4253b666e01eeea1e (patch)
tree06f97d2b386654e99e898d537d657f32829538a6 /media-sound
parentmedia-libs/alsa-ucm-conf: Version bump to 1.2.5 (diff)
downloadgentoo-98f91452d5abe876b19e2be4253b666e01eeea1e.tar.gz
gentoo-98f91452d5abe876b19e2be4253b666e01eeea1e.tar.bz2
gentoo-98f91452d5abe876b19e2be4253b666e01eeea1e.zip
media-sound/alsa-utils: Version bump to 1.2.5
Upstream changelog: https://alsa-project.org/wiki/Changes_v1.2.4_v1.2.5#alsa-utils Closes: https://bugs.gentoo.org/720898 Signed-Off-By: Tony Vroon <chainsaw@gentoo.org> Package-Manager: Portage-3.0.18, Repoman-3.0.2
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/Manifest1
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.2.5.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
index d04366a09319..6ea5f9e51f21 100644
--- a/media-sound/alsa-utils/Manifest
+++ b/media-sound/alsa-utils/Manifest
@@ -1,3 +1,4 @@
DIST alsa-utils-1.2.2.tar.bz2 1274821 BLAKE2B 79b6cd719dbf36ca65b186c6682c9617fb89cb76aa530e4f40850004170703990054b5e96f700c652b11781e0086490824ce2433e33b17c03655fea089f59ceb SHA512 30598c658f3f2ad71a5ce7911b09ae13add54b293bcf3bebb053371d84a91528bd64fd376f167456b2e27e2546a2279019678e099247513e5142b283af756fd9
DIST alsa-utils-1.2.3.tar.bz2 1277105 BLAKE2B 70037123de16d4d267fbe862acba31144e1f060cb01c294cf0691d9378e1f04b108c9f3a5e071979abe9b5c1c15a49facc9e0be73122caaf812047a514e4de4d SHA512 5aeba2e5b7279c62d4df85b61a26b3f41e5465bac5a0b94c7bbe1299f7aa38e8cf2a1f749f618289a63b61f76609fe54169fcbe70792b45adc8957811b672012
DIST alsa-utils-1.2.4.tar.bz2 1286259 BLAKE2B 41eb0b8186c1956c19d8f8b28863ab54c66ff531b9ec5c48cc6c5ed8ca249d135614112ce412d6adb6f21982235e06a4148591777cce00d17ea537aacbd664ad SHA512 13080abda55269513b3751044dac292d695e273073a62d74ed4a32c68f448a2b015fe16604650821a6398b6ef6a7b6008cb9f0b7fb7f4ee1fa2b4eb2dcf29770
+DIST alsa-utils-1.2.5.tar.bz2 1326676 BLAKE2B 52cbe978390e1b5600bf7422e67ece1d24a946d99acddbc059bf6eb3a0b8dfe37cc573167013296e923bf1597973eb55b2580eaf849e088822ba7b2afc14279f SHA512 0e319e553c9c209a46f5c83c50007bd82acf1c9cf78649978b3ab6fbb4349f51c1c7c6a975a8c24d25ba07ad5325e74d2c34dc5c89180998a0f63d1326fde8b1
diff --git a/media-sound/alsa-utils/alsa-utils-1.2.5.ebuild b/media-sound/alsa-utils/alsa-utils-1.2.5.ebuild
new file mode 100644
index 000000000000..507876a36c16
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.2.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="https://alsa-project.org/"
+SRC_URI="https://www.alsa-project.org/files/pub/utils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bat doc +libsamplerate +ncurses nls selinux"
+
+CDEPEND=">=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7:0= )
+ bat? ( sci-libs/fftw:= )"
+DEPEND="${CDEPEND}
+ doc? ( app-text/xmlto )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-alsa )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.8-missing_header.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
+ --disable-alsaconf
+ --disable-maintainer-mode
+ --with-asound-state-dir="${EPREFIX}"/var/lib/alsa
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="${EPREFIX}/$(get_udevdir)"/rules.d
+ $(use_enable bat)
+ $(use_enable libsamplerate alsaloop)
+ $(use_enable ncurses alsamixer)
+ $(use_enable nls)
+ $(usex doc '' --disable-xmlto)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc seq/*/README.*
+
+ newinitd "${FILESDIR}"/alsasound.initd-r8 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+
+ # ALSA lib parser.c:1266:(uc_mgr_scan_master_configs) error: could not
+ # scan directory /usr/share/alsa/ucm: No such file or directory
+ # alsaucm: unable to obtain card list: No such file or directory
+ keepdir /usr/share/alsa/ucm
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}