summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-23 12:45:45 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-23 12:46:10 +0200
commit347ff1a15274fe00f1d05b2e072771e47c8a9f6a (patch)
treeb731106e85f1e9dc136cddf392667b68ada97d1f /media-tv
parentdev-python/pytest-virtualenv: keyworded 1.2.11 for ppc, bug #631608 (diff)
downloadgentoo-347ff1a15274fe00f1d05b2e072771e47c8a9f6a.tar.gz
gentoo-347ff1a15274fe00f1d05b2e072771e47c8a9f6a.tar.bz2
gentoo-347ff1a15274fe00f1d05b2e072771e47c8a9f6a.zip
media-tv/xmltv: Half the work to make this compatible to Perl 5.26
Now the configure phase works. Unfortunately the written Makefile still calls Perl, requiring modules in . Bug: https://bugs.gentoo.org/630474 Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/xmltv/files/xmltv-0.5.68-perl526-1.patch13
-rw-r--r--media-tv/xmltv/xmltv-0.5.68.ebuild4
2 files changed, 16 insertions, 1 deletions
diff --git a/media-tv/xmltv/files/xmltv-0.5.68-perl526-1.patch b/media-tv/xmltv/files/xmltv-0.5.68-perl526-1.patch
new file mode 100644
index 000000000000..4a23d783c25f
--- /dev/null
+++ b/media-tv/xmltv/files/xmltv-0.5.68-perl526-1.patch
@@ -0,0 +1,13 @@
+diff -ruN xmltv-0.5.68.orig/Makefile.PL xmltv-0.5.68/Makefile.PL
+--- xmltv-0.5.68.orig/Makefile.PL 2016-06-02 07:05:01.000000000 +0200
++++ xmltv-0.5.68/Makefile.PL 2017-09-23 12:20:18.128841958 +0200
+@@ -6,6 +6,9 @@
+ use File::Basename ();
+ use File::Find;
+
++# Needed later for Perl 5.26
++use lib q[.];
++
+ # Don't use ':config pass_through' because that requires Getopt::Long
+ # 2.24 or later, and we don't have a clean way to require that.
+ #
diff --git a/media-tv/xmltv/xmltv-0.5.68.ebuild b/media-tv/xmltv/xmltv-0.5.68.ebuild
index f69e0b7e73e9..73ffc2be3e9f 100644
--- a/media-tv/xmltv/xmltv-0.5.68.ebuild
+++ b/media-tv/xmltv/xmltv-0.5.68.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -87,6 +87,8 @@ src_prepare() {
-e "/^@docs/s:doc/COPYING ::" \
Makefile.PL || die
+ epatch "${FILESDIR}/${P}-perl526-1.patch"
+
epatch_user
}