summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChaosEngine <andrzej.pauli@gmail.com>2020-05-30 16:11:09 +0200
committerSam James <sam@gentoo.org>2021-08-14 00:28:06 +0100
commit547d473472b58b22729234b9d213f2a2abdca3fd (patch)
treecdda433af9f3617b154ed0dec2703aabd419a920 /media-video/mjpg-streamer
parentmedia-plugins/gst-plugins-mpeg2enc: subscribe to media-video/mjpegtools subslot (diff)
downloadgentoo-547d473472b58b22729234b9d213f2a2abdca3fd.tar.gz
gentoo-547d473472b58b22729234b9d213f2a2abdca3fd.tar.bz2
gentoo-547d473472b58b22729234b9d213f2a2abdca3fd.zip
media-video/mjpg-streamer: bump to 0_pre20200524-r1
Closes: https://bugs.gentoo.org/724802 Closes: https://bugs.gentoo.org/665122 Package-Manager: Portage-2.3.99, Repoman 2.3.22 Signed-off-by: Andrzej Pauli <andrzej.pauli@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/mjpg-streamer')
-rw-r--r--media-video/mjpg-streamer/Manifest1
-rw-r--r--media-video/mjpg-streamer/metadata.xml6
-rw-r--r--media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r1.ebuild91
3 files changed, 98 insertions, 0 deletions
diff --git a/media-video/mjpg-streamer/Manifest b/media-video/mjpg-streamer/Manifest
index d7dd01615711..0cc52fbbb0e1 100644
--- a/media-video/mjpg-streamer/Manifest
+++ b/media-video/mjpg-streamer/Manifest
@@ -1 +1,2 @@
DIST mjpg-streamer-0_pre20120621.tar.bz2 471546 BLAKE2B 3ede2a60062bba7c91ddfa0d7151e32cd8dac11a083cc6a88dc350a523174685b2ff066fa99db13b82a6a4960d370b97b27aa3663ac323fa54908bb0108857d0 SHA512 dfc6077ec03fe4f239d8e25b65b7808bd489a954d8cf3aeed444e68fd9536720c2c888a5fa9f4b8d0152dab5ca0bd166a46f2cb22a357ba816eb5bc79ff11332
+DIST mjpg-streamer-0_pre20200524.tar.gz 711183 BLAKE2B 3a40f20f518a53c0c6046cf37728c46c2a843a1dd0ef0086c77940b5133f1337445b1edb2c21edc1bbacc588f7c7b45b1530871c944695c2ae02cf327fde6847 SHA512 d6e910f6693b27c16c33749458affcb4d9336bd15c642156c452fcbc4a8c2ba9f4a6102e6b94f698fc6fb48da9564a09cb0f804a5ac52201e566adf798a70ba2
diff --git a/media-video/mjpg-streamer/metadata.xml b/media-video/mjpg-streamer/metadata.xml
index 2e4cb6515fd8..3df394f71ec1 100644
--- a/media-video/mjpg-streamer/metadata.xml
+++ b/media-video/mjpg-streamer/metadata.xml
@@ -24,6 +24,8 @@
it's content</flag>
<flag name="input-uvc">Plugin that sends video stream from UVC
compatible camera</flag>
+ <flag name="input-http">Plugin that takes http-input</flag>
+ <flag name="input-ptp2">Plugin that sends video stream from PTP2 compatible camera</flag>
<flag name="output-file">Plugin that saves received content under given
location</flag>
<flag name="output-udp">Plugin receiving content over UDP and storing to
@@ -33,7 +35,11 @@
<flag name="output-autofocus">Auto focusing plugin</flag>
<flag name="output-rtsp">Plugin which provides a mechanism to take
snapshots with a trigger from a UDP packet</flag>
+ <flag name="output-viewer">Plugin which allows to see output with viewer</flag>
+ <flag name="output-zmqserver">Plugin which provides zmqserver processing</flag>
<flag name="www">Installs WWW content</flag>
+ <flag name="http-management">Enable experimental HTTP management option</flag>
+ <flag name="wxp-compat">Enable camera WXP compatible format</flag>
</use>
<upstream>
<remote-id type="sourceforge">mjpg-streamer</remote-id>
diff --git a/media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r1.ebuild b/media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r1.ebuild
new file mode 100644
index 000000000000..e0d1f254f9ea
--- /dev/null
+++ b/media-video/mjpg-streamer/mjpg-streamer-0_pre20200524-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="MJPG-streamer takes JPGs from Linux-UVC compatible webcams"
+HOMEPAGE="https://github.com/jacksonliam/mjpg-streamer"
+EGIT_COMMIT="85f89a8c321e799fabb1693c5d133f3fb48ee748"
+SRC_URI="https://github.com/jacksonliam/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+INPUT_PLUGINS="input-testpicture input-control input-file input-uvc input-http input-ptp2"
+OUTPUT_PLUGINS="output-file output-udp output-http output-autofocus output-rtsp output-viewer output-zmqserver"
+IUSE_PLUGINS="${INPUT_PLUGINS} ${OUTPUT_PLUGINS}"
+IUSE="input-testpicture input-control +input-file input-uvc input-http input-ptp2
+ output-file output-udp +output-http output-autofocus output-rtsp output-viewer output-zmqserver
+ www http-management wxp-compat"
+REQUIRED_USE="|| ( ${INPUT_PLUGINS} )
+ || ( ${OUTPUT_PLUGINS} )"
+
+RDEPEND="virtual/jpeg
+ input-uvc? ( media-libs/libv4l )
+ input-ptp2? ( media-libs/libgphoto2 )
+ output-zmqserver? (
+ dev-libs/protobuf-c
+ net-libs/zeromq
+ )"
+DEPEND="${RDEPEND}
+ input-testpicture? ( media-gfx/imagemagick )"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}/${PN}-experimental"
+
+src_prepare() {
+ sed -i -e "s|.*RPATH.*||g" CMakeLists.txt || die
+ if use wxp-compat; then
+ sed -i -e \
+ 's|^add_feature_option(WXP_COMPAT "Enable compatibility with WebcamXP" OFF)|add_feature_option(WXP_COMPAT "Enable compatibility with WebcamXP" ON)|g' \
+ CMakeLists.txt || die
+ fi
+
+ local flag switch
+ for flag in ${IUSE_PLUGINS}; do
+ use ${flag} && switch='' || switch='#'
+ flag=${flag/input-/input_}
+ flag=${flag/output-/output_}
+ sed -i -e \
+ "s|^add_subdirectory(plugins\/${flag})|${switch}add_subdirectory(plugins/${flag})|" \
+ CMakeLists.txt || die
+ done
+ if use http-management; then
+ sed -i -e \
+ 's|^add_feature_option(ENABLE_HTTP_MANAGEMENT "Enable experimental HTTP management option" OFF)|add_feature_option(ENABLE_HTTP_MANAGEMENT "Enable experimental HTTP management option" ON)|g' \
+ plugins/output_http/CMakeLists.txt || die
+ fi
+ sed -e "s|@LIBDIR@|$(get_libdir)/${PN}/$(get_libdir)|g" "${FILESDIR}/${PN}.initd" > ${PN}.initd || die
+
+ default
+}
+
+src_install() {
+ into /usr
+ dobin ${PN//-/_}
+ into "/usr/$(get_libdir)/${PN}"
+ dolib.so *.so
+
+ if use www ; then
+ insinto /usr/share/${PN}
+ doins -r www
+ fi
+
+ dodoc README.md TODO
+
+ newinitd ${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ systemd_dounit mjpg_streamer@.service
+}
+
+pkg_postinst() {
+ elog "Remember to set an input and output plugin for mjpg-streamer."
+
+ if use www ; then
+ echo
+ elog "An example webinterface has been installed into"
+ elog "/usr/share/mjpg-streamer/www for your usage."
+ fi
+}