summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-09-03 23:18:53 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-09-14 13:15:42 +0200
commit3252a86b2afff788707c84c540504cca87ac8630 (patch)
tree67a3b02d1a36b2e476547aece02efa5477567c95 /media-video/rtmpdump/rtmpdump-9999.ebuild
parentmedia-video/rtmpdump: Shrink DESCRIPTION. (diff)
downloadgentoo-3252a86b2afff788707c84c540504cca87ac8630.tar.gz
gentoo-3252a86b2afff788707c84c540504cca87ac8630.tar.bz2
gentoo-3252a86b2afff788707c84c540504cca87ac8630.zip
media-video/rtmpdump: Move to EAPI6 and git-r3.
Specify dev-libs/openssl and dev-libs/libressl SLOT. Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2210 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-video/rtmpdump/rtmpdump-9999.ebuild')
-rw-r--r--media-video/rtmpdump/rtmpdump-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/media-video/rtmpdump/rtmpdump-9999.ebuild b/media-video/rtmpdump/rtmpdump-9999.ebuild
index c9348c0dbd97..4c568c33bd0a 100644
--- a/media-video/rtmpdump/rtmpdump-9999.ebuild
+++ b/media-video/rtmpdump/rtmpdump-9999.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="6"
-inherit git-2 multilib toolchain-funcs multilib-minimal
+inherit git-r3 multilib toolchain-funcs multilib-minimal
DESCRIPTION="RTMP client intended to stream audio or video flash content"
HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
@@ -24,6 +24,9 @@ DEPEND="ssl? (
)"
RDEPEND="${DEPEND}"
+DOCS=( README ChangeLog )
+HTML_DOCS=( rtmpdump.1.html rtmpgw.8.html )
+
pkg_setup() {
if ! use ssl && { use gnutls || use polarssl; }; then
ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
@@ -32,6 +35,8 @@ pkg_setup() {
}
src_prepare() {
+ default
+
# fix #571106 by restoring pre-GCC5 inline semantics
append-cflags -std=gnu89
# fix Makefile ( bug #298535 , bug #318353 and bug #324513 )
@@ -65,9 +70,7 @@ multilib_src_compile() {
multilib_src_install() {
mkdir -p "${ED}"/usr/$(get_libdir) || die
- if multilib_is_native_abi; then
- dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
- else
+ if ! multilib_is_native_abi; then
cd librtmp || die
fi
emake DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man" \