summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-11 05:24:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-11 05:24:28 +0200
commit7b6d4b48c29b1e65ba2118b532d68ad2e12fc179 (patch)
tree393b6a214b350cc3ea57c91d66e56908e1ac2c33 /media-video
parentdev-ros/laser_filters: Bump to 1.8.4 (diff)
downloadgentoo-7b6d4b48c29b1e65ba2118b532d68ad2e12fc179.tar.gz
gentoo-7b6d4b48c29b1e65ba2118b532d68ad2e12fc179.tar.bz2
gentoo-7b6d4b48c29b1e65ba2118b532d68ad2e12fc179.zip
media-video/libva-utils: Bump to 1.8.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-video')
-rw-r--r--media-video/libva-utils/Manifest1
-rw-r--r--media-video/libva-utils/libva-utils-1.8.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/media-video/libva-utils/Manifest b/media-video/libva-utils/Manifest
index 2552fd3afbe3..5bcd8c698263 100644
--- a/media-video/libva-utils/Manifest
+++ b/media-video/libva-utils/Manifest
@@ -1 +1,2 @@
DIST libva-utils-1.8.0.tar.gz 1011595 SHA256 2a7590c8428d0b453b004702c4c515669403cea27f9f17b2560b38da337ec943 SHA512 020cf1d5af7a78ecb4806afe69d34106525086f10b007dddb8d36c0243b670c311df537d969c8b60222b4afc7bfc08c1d594843339af72618886eecfd03887ec WHIRLPOOL 46e76c555a69878e5cb553f3895752aafc821012afefec69b55f35014659e49ab3e30bcd5f94a9ffd86cd1c3fee467d215f58b3e10b69c54d1e630d78144a4b3
+DIST libva-utils-1.8.1.tar.gz 1011602 SHA256 cbd7a88b9b2592106879d271008c9e2236457e5bf4a647efe4bb3d3eaabaf94c SHA512 7b60cf773d7156bf5579754d0525a8cae07b5e63416fd1c6481a9bada388515f8f14d23661c11689599af7ddd192440f96f2c8873b539cf93e7db0550d4e1aae WHIRLPOOL 8d48567146729ab8423dbc52f65a1c004fd6dbca28eda27aecce415c7b0f54d5e973692ce7d7550f7058e59933cdaea21cfe8784107fb7227ca6a02ec9bf8699
diff --git a/media-video/libva-utils/libva-utils-1.8.1.ebuild b/media-video/libva-utils/libva-utils-1.8.1.ebuild
new file mode 100644
index 000000000000..ef34dbe2e6cd
--- /dev/null
+++ b/media-video/libva-utils/libva-utils-1.8.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/01org/libva-utils"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-utils ${SCM} multilib
+
+DESCRIPTION="Collection of utilities and tests for VA-API"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/01org/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm test wayland X"
+
+RDEPEND="
+ >=x11-libs/libva-1.8[drm?,wayland?,X?]
+ drm? ( >=x11-libs/libdrm-2.4 )
+ X? (
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ )
+ wayland? ( >=dev-libs/wayland-1.0.6 )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( drm wayland X )"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable drm)
+ $(use_enable test tests)
+ )
+ autotools-utils_src_configure
+}