summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/bigeye
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/bigeye')
-rw-r--r--net-analyzer/bigeye/Manifest2
-rw-r--r--net-analyzer/bigeye/bigeye-0.3-r3.ebuild40
-rw-r--r--net-analyzer/bigeye/files/bigeye-0.3-overflow.patch11
-rw-r--r--net-analyzer/bigeye/metadata.xml5
4 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/bigeye/Manifest b/net-analyzer/bigeye/Manifest
new file mode 100644
index 000000000000..00da8328b267
--- /dev/null
+++ b/net-analyzer/bigeye/Manifest
@@ -0,0 +1,2 @@
+DIST bigeye-0.3-gcc34.diff.bz2 2774 SHA256 06e50f31e6e162502dc9e24db416301ad7bbd5439b7611faa405020085668738 SHA512 8ed54aa7b95aac8703e2bf99fde985cbbe7e62f7a6b549e58b2b54856336c5560c450a8c6ad9cbcdcd6bf61c842797c1abca001cfca20ff82614d8c328cab4ba WHIRLPOOL 72ea0009f5c55369fa5faf0e0b89d13a62ec77e7c1a3691a848ebffb9b906134b48faa7daab4682eaa304dfc34f622f6157ec40473af166ad3feaf480f73add2
+DIST bigeye-0.3.tgz 32462 SHA256 e03aacd1797dece3b8a1521f7df44dd63f8417e988ce0be218079ae49cd7490d SHA512 73a146fd2f5df86a3d16dec05cf3f278393347f341a5cc319feccf6d23e1f2fe9d29070ac154a5b2336ade146843ab163e3545e9aefad1a0fa8903928d9b1ed0 WHIRLPOOL 491699b8470472ecd9907b4d5a2e207c34ab3ed9777cdaaf3cd323daaaadb80ee8e39dbc6e718cc808393ba65daeddc0b248b5c7b46fea78765fb3d656969a7f
diff --git a/net-analyzer/bigeye/bigeye-0.3-r3.ebuild b/net-analyzer/bigeye/bigeye-0.3-r3.ebuild
new file mode 100644
index 000000000000..afaaf2925af2
--- /dev/null
+++ b/net-analyzer/bigeye/bigeye-0.3-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="network utility dump and simple honeypot utility"
+HOMEPAGE="http://violating.us/projects/bigeye/"
+SRC_URI="http://violating.us/projects/bigeye/download/${P}.tgz
+ mirror://gentoo/${P}-gcc34.diff.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/${P}-gcc34.diff \
+ "${FILESDIR}"/${P}-overflow.patch
+ sed -i README \
+ -e "s|-- /messages/|-- /usr/share/bigeye/messages/|g" \
+ || die "sed README"
+}
+
+src_compile() {
+ cd src || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} bigeye.c emulate.c -o bigeye || die
+}
+
+src_install() {
+ dobin src/bigeye
+
+ insinto /usr/share/bigeye
+ doins sig.file
+ doins -r messages
+
+ dodoc README
+}
diff --git a/net-analyzer/bigeye/files/bigeye-0.3-overflow.patch b/net-analyzer/bigeye/files/bigeye-0.3-overflow.patch
new file mode 100644
index 000000000000..1ca159a65b79
--- /dev/null
+++ b/net-analyzer/bigeye/files/bigeye-0.3-overflow.patch
@@ -0,0 +1,11 @@
+--- a/src/bigeye.c
++++ b/src/bigeye.c
+@@ -787,7 +787,7 @@
+ local.sin_family = AF_INET;
+ local.sin_port = htons(porta);
+ local.sin_addr.s_addr = INADDR_ANY;
+- bzero(&(local.sin_zero),sizeof(local));
++ memset(&(local.sin_zero), "\0", sizeof(local.sin_zero));
+
+ if(setsockopt(sock_a, SOL_SOCKET, SO_REUSEADDR, &on, sizeof(on)) < 0) {
+ perror("setsockopt");
diff --git a/net-analyzer/bigeye/metadata.xml b/net-analyzer/bigeye/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/bigeye/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>