summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-19 03:01:14 +0100
committerSam James <sam@gentoo.org>2022-10-19 03:02:05 +0100
commit3c0f503329f70145681b5a2d4d89d4267697d584 (patch)
tree167861b8398f964d129f9a150b4f8017fe80668b /net-analyzer/bing
parentsys-apps/osinfo-db: Version bump to 20221018 (diff)
downloadgentoo-3c0f503329f70145681b5a2d4d89d4267697d584.tar.gz
gentoo-3c0f503329f70145681b5a2d4d89d4267697d584.tar.bz2
gentoo-3c0f503329f70145681b5a2d4d89d4267697d584.zip
net-analyzer/bing: add 1.3.5
Bug: https://bugs.gentoo.org/861149 Closes: https://bugs.gentoo.org/874057 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/bing')
-rw-r--r--net-analyzer/bing/Manifest1
-rw-r--r--net-analyzer/bing/bing-1.3.5.ebuild33
-rw-r--r--net-analyzer/bing/files/bing-1.3.5-Add-missing-string.h-for-memcpy.patch17
3 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/bing/Manifest b/net-analyzer/bing/Manifest
index 52c4ade6d53a..a5cff71f03e5 100644
--- a/net-analyzer/bing/Manifest
+++ b/net-analyzer/bing/Manifest
@@ -1 +1,2 @@
DIST bing_1.1.3.orig.tar.gz 38847 BLAKE2B ba01ff0e9a53fa8e9cd44ee085d78ae8d8891cc5478697a0d8fb13917c9a4104a672dcc7aba0c6c91e7f0084ac4254b6f565cf44486b6162225c5a21cb1614a7 SHA512 df56f93047454a02b305154b12898b063c340e96778db9e11114ac4598446648b3ed5fe4304e0f3e33f612069b0f0e4e231396ee878655683f923ad5418d6242
+DIST bing_1.3.5.orig.tar.gz 81083 BLAKE2B b6d7b9de4181cbe5054e2260482d6d2f6026e433815924fc5a8c74e4bb2d2da465a57e31e588b4d30f7e7b1c577440c4018b463df46278e8dc90f01e9d710ea6 SHA512 187c0dd8aff289943d044402cb072a64f9eb8470295ab4d3e94e78f1f8388c6737929b8ed6c11b551fc866bba4c45c3fbb1aa7b5ca1a6c798f313db9902d003f
diff --git a/net-analyzer/bing/bing-1.3.5.ebuild b/net-analyzer/bing/bing-1.3.5.ebuild
new file mode 100644
index 000000000000..7d3c5ef5ae8a
--- /dev/null
+++ b/net-analyzer/bing/bing-1.3.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A point-to-point bandwidth measurement tool"
+HOMEPAGE="http://fgouget.free.fr/bing/index-en.shtml"
+SRC_URI="mirror://debian/pool/main/b/bing/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.5-Add-missing-string.h-for-memcpy.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e "s|#COPTIM = -g| COPTIM = ${CFLAGS}|" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin bing
+ doman unix/bing.8
+ dodoc ChangeLog Readme.{1st,txt}
+}
diff --git a/net-analyzer/bing/files/bing-1.3.5-Add-missing-string.h-for-memcpy.patch b/net-analyzer/bing/files/bing-1.3.5-Add-missing-string.h-for-memcpy.patch
new file mode 100644
index 000000000000..424a591c1548
--- /dev/null
+++ b/net-analyzer/bing/files/bing-1.3.5-Add-missing-string.h-for-memcpy.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/874057
+
+From dafa483ba52e334cdc138a4f9e5999d2d5cc5d9b Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 19 Oct 2022 02:58:47 +0100
+Subject: [PATCH] Add missing <string.h> for memcpy
+
+--- a/bing_probes.c
++++ b/bing_probes.c
+@@ -10,6 +10,7 @@
+ #include <errno.h>
+ #include <malloc.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ /* types.h provides u_short on HPUX10 and Solaris */
+ #include <sys/types.h>