summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-16 07:02:43 +0000
committerSam James <sam@gentoo.org>2022-05-16 19:56:40 +0000
commit7527905c4777bb0c1afe4336bfd963a269463722 (patch)
treed823f86e4447141787130584a4521ee8cdcfdf47 /net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild
parentnet-analyzer/cacti: add 1.2.20 (diff)
downloadgentoo-7527905c4777bb0c1afe4336bfd963a269463722.tar.gz
gentoo-7527905c4777bb0c1afe4336bfd963a269463722.tar.bz2
gentoo-7527905c4777bb0c1afe4336bfd963a269463722.zip
net-analyzer/cacti-spine: add 1.2.20
Bug: https://bugs.gentoo.org/834597 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild')
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild
new file mode 100644
index 000000000000..a8ac30938351
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-db/mysql-connector-c:=
+ dev-libs/openssl:=
+ net-analyzer/net-snmp:="
+RDEPEND="${DEPEND}
+ >net-analyzer/cacti-0.8.8"
+BDEPEND="sys-apps/help2man"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # Drop CONFIG_SHELL after 1.2.x (fix is on develop branch)
+ CONFIG_SHELL="${BROOT}"/bin/bash econf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}