summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ipguard
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ipguard')
-rw-r--r--net-analyzer/ipguard/Manifest1
-rw-r--r--net-analyzer/ipguard/files/ipguard.confd8
-rw-r--r--net-analyzer/ipguard/ipguard-1.04.ebuild50
-rw-r--r--net-analyzer/ipguard/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/net-analyzer/ipguard/Manifest b/net-analyzer/ipguard/Manifest
new file mode 100644
index 000000000000..0068522ca939
--- /dev/null
+++ b/net-analyzer/ipguard/Manifest
@@ -0,0 +1 @@
+DIST ipguard-1.04.tar.gz 24566 SHA256 95bf97ae2c58827e34d40daa7065c5107d39a67eb92e2164f7758846f43c41fe SHA512 c29c3f594e09ad1c06ca7297f794ddfada48da7ec2b98786694cd6af7508cbff232889e0c90718d96519297870b93132b7b0f9f310a0e4d7a7c2d54a30ca893c WHIRLPOOL 2536d29f074fbb940dc5d8b828f1742d2712b8cbebb5374a271d7a7c2c0540642a6fc511ddbd179211ae78568e86504a6a418f6257cbbdabc01b6134187a2ab7
diff --git a/net-analyzer/ipguard/files/ipguard.confd b/net-analyzer/ipguard/files/ipguard.confd
new file mode 100644
index 000000000000..fc7fb66cd46c
--- /dev/null
+++ b/net-analyzer/ipguard/files/ipguard.confd
@@ -0,0 +1,8 @@
+# ipguard configuration file
+
+# IFACE - the name of the network interface you want to monitor
+# IFACE=eth0
+IFACE=eth0
+
+# OPTS - command line options (see ipguard(8)
+OPTS="-u 300 -xz -r"
diff --git a/net-analyzer/ipguard/ipguard-1.04.ebuild b/net-analyzer/ipguard/ipguard-1.04.ebuild
new file mode 100644
index 000000000000..37f7f7f0afbc
--- /dev/null
+++ b/net-analyzer/ipguard/ipguard-1.04.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Tool designed to protect LAN IP adress space by ARP spoofing"
+HOMEPAGE="http://ipguard.deep.perm.ru/"
+SRC_URI="${HOMEPAGE}files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ net-libs/libnet
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's|-g ||g' \
+ -e 's| @$(CC)| $(CC)|g' \
+ -e 's| -s | |g' \
+ -e 's| -o | $(CFLAGS) $(LDFLAGS)&|g' \
+ -e 's|$(PREFIX)|${D}&|g' \
+ -e 's|/man/|/share&|g' \
+ Makefile || die
+ sed -i \
+ -e 's|opts=|extra_commands=|g' \
+ -e 's|/var/run/|/run/|g' \
+ -e 's|-u 300 -xz|${OPTS} ${IFACE}|g' \
+ doc/${PN}.gentoo || die
+ sed -i \
+ -e 's|/var/run/|/run/|g' \
+ doc/${PN}.8 ${PN}.h || die
+}
+
+src_compile() {
+ emake LIBNET_CONFIG=libnet-config CC=$(tc-getCC) PREFIX=\"${EPREFIX:-/usr}\"
+}
+
+src_install() {
+ emake LIBNET_CONFIG=libnet-config DESTDIR="${D}" PREFIX=\"${EPREFIX:-/usr}\" install
+ newinitd doc/${PN}.gentoo ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ dodoc doc/{NEWS,README*,ethers.sample}
+}
diff --git a/net-analyzer/ipguard/metadata.xml b/net-analyzer/ipguard/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/ipguard/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>