summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nagios-sap-ccms-plugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nagios-sap-ccms-plugin')
-rw-r--r--net-analyzer/nagios-sap-ccms-plugin/Manifest2
-rw-r--r--net-analyzer/nagios-sap-ccms-plugin/files/nagios-sap-ccms-plugin-0.8-gentoo.patch61
-rw-r--r--net-analyzer/nagios-sap-ccms-plugin/metadata.xml19
-rw-r--r--net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.7.3-r1.ebuild52
-rw-r--r--net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.8.ebuild67
5 files changed, 201 insertions, 0 deletions
diff --git a/net-analyzer/nagios-sap-ccms-plugin/Manifest b/net-analyzer/nagios-sap-ccms-plugin/Manifest
new file mode 100644
index 000000000000..f0259271ba74
--- /dev/null
+++ b/net-analyzer/nagios-sap-ccms-plugin/Manifest
@@ -0,0 +1,2 @@
+DIST sap-ccms-plugin-0.7.3.tar.gz 2948020 SHA256 ce3831bc8156f5fafe8fb4366bd9d4b2df4c85d55c92d4b38c41f10f701206eb
+DIST sap-ccms-plugin-0.8.tar.bz2 10143558 SHA256 6af24e4ac2f3dddc435394e49f491a32c1c1c447025479190e710f1132a708ee
diff --git a/net-analyzer/nagios-sap-ccms-plugin/files/nagios-sap-ccms-plugin-0.8-gentoo.patch b/net-analyzer/nagios-sap-ccms-plugin/files/nagios-sap-ccms-plugin-0.8-gentoo.patch
new file mode 100644
index 000000000000..8ded76b3b7d1
--- /dev/null
+++ b/net-analyzer/nagios-sap-ccms-plugin/files/nagios-sap-ccms-plugin-0.8-gentoo.patch
@@ -0,0 +1,61 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -1,5 +1,5 @@
+
+-VERSION=0.7.3
++VERSION=0.8
+ PLATFORM=$(shell uname -m)
+
+
+@@ -33,12 +33,10 @@
+ SUBDIRS = sap_moni
+ #C-Compiler
+
+-CC=gcc -DSAP_RFC_TIME
+-X_CFLAGS = $(CFLAGS)
++X_CFLAGS = $(CFLAGS) $(LDFLAGS) -DSAP_RFC_TIME
+ SHARED_OBJECTS=libs/$(PLATFORM)/librfccm.so
+
+ ifeq ($(patsubst i%86,x86,$(PLATFORM)), x86)
+- CC=gcc -DSAP_RFC_TIME
+ SHARED_OBJECTS=libs/x86/librfccm.so
+ endif
+
+--- a/src/sap_moni/Makefile 2009-03-16 12:34:26.000000000 +0100
++++ b/src/sap_moni/Makefile 2010-10-20 01:24:14.000000000 +0200
+@@ -1,23 +1,16 @@
+-PLATFORM=$(shell uname -m)
+-
+ #used files
+-SRC_INI = iniparser.c dictionary.c strlib.c
++SRC_INI = dictionary.c strlib.c
+ OBJ_INI = $(SRC_INI:.c=.o)
+ OBJ=ctype_b.o agnt_rfc.o agnt_mon.o $(OBJ_INI)
+
+ SHARED = sap_moni.so
+
+ #C-Compiler
+-CC=gcc -DSAP_RFC_TIME
+-X_CFLAGS=$(CFLAGS) -fPIC
+-
+-ifeq ($(PLATFORM),ppc64)
+- CC=gcc -m64 -DSAP_RFC_TIME
+-endif
++X_CFLAGS=$(CFLAGS) -fPIC -DSAP_RFC_TIME
+
+ #Rules
+ shared: $(OBJ)
+- $(CC) -shared $ $(X_CFLAGS) -o $(SHARED) $(OBJ) -ldl -lm
++ $(CC) -shared $ $(X_CFLAGS) $(LDFLAGS) -o $(SHARED) $(OBJ) -ldl -lm -liniparser
+
+
+ .SUFFIXES: .c .o
+@@ -26,7 +19,7 @@
+
+ #Dependencies
+ agnt_rfc.o: saprfc.h sapitab.h agnt_def.h
+-agnt_mon.o: agnt_def.h iniparser.h sapitab.h
++agnt_mon.o: agnt_def.h sapitab.h
+
+
+ #------
diff --git a/net-analyzer/nagios-sap-ccms-plugin/metadata.xml b/net-analyzer/nagios-sap-ccms-plugin/metadata.xml
new file mode 100644
index 000000000000..bee3b9073f9f
--- /dev/null
+++ b/net-analyzer/nagios-sap-ccms-plugin/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>andrew@ahamilto.net</email>
+ <name>Andrew Hamilton</name>
+ <description>Maintainer. Assign bugs to him.</description>
+ </maintainer>
+ <maintainer>
+ <email>creffett@gentoo.org</email>
+ <name>Chris Reffett</name>
+ <description>Proxy maintainer. CC him on bugs.</description>
+ </maintainer>
+ <herd>proxy-maintainers</herd>
+ <herd>sysadmin</herd>
+ <upstream>
+ <remote-id type="sourceforge">nagios-sap-ccms</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.7.3-r1.ebuild b/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..2f5e3e04e64d
--- /dev/null
+++ b/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.7.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit multilib
+
+MY_P="sap-ccms-plugin-${PV}"
+
+DESCRIPTION="Nagios plugin that provides an interface to SAP CCMS
+Infrastructure"
+HOMEPAGE="http://sourceforge.net/projects/nagios-sap-ccms/"
+SRC_URI="mirror://sourceforge/nagios-sap-ccms/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="net-analyzer/nagios-core"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ cd "${S}/src"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd "${S}/src"
+ exeinto /usr/$(get_libdir)/nagios/plugins
+
+ for file in {check_sap{,_cons,_instance,_instance_cons,_mult_no_thr,_multiple,_system,_system_cons},create_cfg,sap_change_thr}
+ do
+ doexe ${file}
+ done
+
+ chown -R root:nagios "${D}"/usr/$(get_libdir)/nagios/plugins || die "Failed Chown of ${D}usr/$(get_libdir)/nagios/plugins"
+
+ dolib.so sap_moni.so
+ cd "${S}/config"
+
+ dodir /etc/sapmon
+ insinto /etc/sapmon
+ doins "${S}"/config/*
+}
+
+pkg_postinst() {
+ elog "Have a look at /etc/sapmon for configuring ${PN}"
+ elog "Further information can be found at"
+ elog "http://nagios-sap-ccms.sourceforge.net/"
+}
diff --git a/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.8.ebuild b/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.8.ebuild
new file mode 100644
index 000000000000..cec284635c32
--- /dev/null
+++ b/net-analyzer/nagios-sap-ccms-plugin/nagios-sap-ccms-plugin-0.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="sap-ccms-plugin-${PV}"
+
+DESCRIPTION="Nagios plugin that provides an interface to SAP CCMS
+Infrastructure"
+HOMEPAGE="http://sourceforge.net/projects/nagios-sap-ccms/"
+SRC_URI="mirror://sourceforge/nagios-sap-ccms/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+QA_PRESTRIPPED="/usr/lib/librfccm.so"
+QA_FLAGS_IGNORED="/usr/lib/librfccm.so"
+
+DEPEND="
+ net-analyzer/nagios-core
+ dev-libs/iniparser
+"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${PN/-plugin*}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i src/sap_moni/* \
+ -e 's|#include "iniparser.h"|#include <iniparser.h>|g' \
+ || die "sed sap_moni/"
+}
+
+src_compile() {
+ emake -C src CC=$(tc-getCC)
+}
+
+src_install() {
+ cd "${S}/src"
+ exeinto /usr/$(get_libdir)/nagios/plugins
+
+ for file in {check_sap{,_cons,_instance,_instance_cons,_mult_no_thr,_multiple,_system,_system_cons},create_cfg,sap_change_thr}
+ do
+ doexe ${file}
+ done
+
+ chown -R root:nagios "${D}"/usr/$(get_libdir)/nagios/plugins || die "Failed Chown of ${D}usr/$(get_libdir)/nagios/plugins"
+
+ dolib.so sap_moni.so
+ newlib.so $(readlink librfccm.so) librfccm.so
+ cd "${S}/config"
+
+ dodir /etc/sapmon
+ insinto /etc/sapmon
+ doins "${S}"/config/*
+}
+
+pkg_postinst() {
+ elog "Have a look at /etc/sapmon for configuring ${PN}"
+ elog "Further information can be found at"
+ elog "http://nagios-sap-ccms.sourceforge.net/"
+}