summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-03 11:32:58 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-03 11:35:43 +0100
commita3e6e55df70c95004b330fb5f530e4e0d1d9456c (patch)
tree4e931f35ca2315b639bc203cceb38012d7d20850 /net-analyzer/netselect
parentacct-group/turnserver: new group for coturn 235 (diff)
downloadgentoo-a3e6e55df70c95004b330fb5f530e4e0d1d9456c.tar.gz
gentoo-a3e6e55df70c95004b330fb5f530e4e0d1d9456c.tar.bz2
gentoo-a3e6e55df70c95004b330fb5f530e4e0d1d9456c.zip
net-analyzer/netselect: Add live ebuild
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/netselect')
-rw-r--r--net-analyzer/netselect/netselect-9999.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/netselect/netselect-9999.ebuild b/net-analyzer/netselect/netselect-9999.ebuild
new file mode 100644
index 000000000000..de08fdebbdfa
--- /dev/null
+++ b/net-analyzer/netselect/netselect-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="Ultrafast implementation of ping"
+HOMEPAGE="http://apenwarr.ca/netselect/"
+EGIT_REPO_URI="
+ https://github.com/apenwarr/${PN}
+"
+SRC_URI="
+ ipv6? ( https://dev.gentoo.org/~jer/${PN}-0.4-ipv6.patch.xz )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="ipv6"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4-bsd.patch
+ "${FILESDIR}"/${PN}-0.4-flags.patch
+)
+
+src_unpack() {
+ use ipv6 && unpack ${A}
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ use ipv6 && PATCHES+=( "${WORKDIR}"/${PN}-0.4-ipv6.patch )
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ dobin netselect
+
+ if ! use prefix ; then
+ fowners root:wheel /usr/bin/netselect
+ fperms 4711 /usr/bin/netselect
+ fi
+
+ dodoc HISTORY README
+
+ doman netselect.1
+}