summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-11-20 10:04:16 +0100
committerJeroen Roovers <jer@gentoo.org>2017-11-20 10:04:29 +0100
commitcd4fe5605f7abf42d8c93566bc99b6f2e6bc0fba (patch)
tree70013f4ebfbbcbb1e9be8b456e04d59864230af1 /net-analyzer/nodebrain
parentsys-kernel/ck-sources: v.bump (4.14.0) (diff)
downloadgentoo-cd4fe5605f7abf42d8c93566bc99b6f2e6bc0fba.tar.gz
gentoo-cd4fe5605f7abf42d8c93566bc99b6f2e6bc0fba.tar.bz2
gentoo-cd4fe5605f7abf42d8c93566bc99b6f2e6bc0fba.zip
net-analyzer/nodebrain: Add missing include (bug #637486).
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/nodebrain')
-rw-r--r--net-analyzer/nodebrain/files/nodebrain-0.9.04-include.patch10
-rw-r--r--net-analyzer/nodebrain/nodebrain-0.9.04-r1.ebuild47
-rw-r--r--net-analyzer/nodebrain/nodebrain-9999.ebuild5
3 files changed, 60 insertions, 2 deletions
diff --git a/net-analyzer/nodebrain/files/nodebrain-0.9.04-include.patch b/net-analyzer/nodebrain/files/nodebrain-0.9.04-include.patch
new file mode 100644
index 000000000000..61d98a673375
--- /dev/null
+++ b/net-analyzer/nodebrain/files/nodebrain-0.9.04-include.patch
@@ -0,0 +1,10 @@
+--- a/lib/nbhash.c
++++ b/lib/nbhash.c
+@@ -81,6 +81,7 @@
+ */
+ #include <nb/nbi.h>
+ #include <stddef.h>
++#include <stdint.h>
+
+ struct TYPE *typeHash;
+
diff --git a/net-analyzer/nodebrain/nodebrain-0.9.04-r1.ebuild b/net-analyzer/nodebrain/nodebrain-0.9.04-r1.ebuild
new file mode 100644
index 000000000000..8c76a34f5374
--- /dev/null
+++ b/net-analyzer/nodebrain/nodebrain-0.9.04-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Monitor and do event correlation"
+HOMEPAGE="http://nodebrain.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nodebrain/nodebrain-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+CDEPEND="
+ dev-libs/libedit
+"
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ sys-apps/texinfo
+"
+RDEPEND="
+ ${CDEPEND}
+ !sys-boot/netboot
+ !www-apps/nanoblogger
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.14-include.patch
+ "${FILESDIR}"/${PN}-0.9.04-include.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --include=/usr/include
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+
+ dodoc -r AUTHORS ChangeLog NEWS README THANKS sample/ html/
+}
diff --git a/net-analyzer/nodebrain/nodebrain-9999.ebuild b/net-analyzer/nodebrain/nodebrain-9999.ebuild
index c27ee0d59ed0..36adf58b091f 100644
--- a/net-analyzer/nodebrain/nodebrain-9999.ebuild
+++ b/net-analyzer/nodebrain/nodebrain-9999.ebuild
@@ -29,6 +29,7 @@ RDEPEND="
"
PATCHES=(
"${FILESDIR}"/${PN}-0.8.14-include.patch
+ "${FILESDIR}"/${PN}-0.9.04-include.patch
)
src_prepare() {
@@ -46,7 +47,7 @@ src_configure() {
src_install() {
default
- dodoc -r AUTHORS ChangeLog NEWS README THANKS sample/ html/
-
prune_libtool_files
+
+ dodoc -r AUTHORS ChangeLog NEWS README THANKS sample/ html/
}