summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ssmping
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ssmping')
-rw-r--r--net-analyzer/ssmping/Manifest1
-rw-r--r--net-analyzer/ssmping/files/ssmping-0.9-build.patch23
-rw-r--r--net-analyzer/ssmping/metadata.xml10
-rw-r--r--net-analyzer/ssmping/ssmping-0.9.1.ebuild24
4 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/ssmping/Manifest b/net-analyzer/ssmping/Manifest
new file mode 100644
index 000000000000..cc1b3370eb31
--- /dev/null
+++ b/net-analyzer/ssmping/Manifest
@@ -0,0 +1 @@
+DIST ssmping-0.9.1.tar.gz 16863 SHA256 22103a37eaa28489169a0927bc01e0596c3485fc4d29fc8456c07fd2c70fca6d SHA512 7929b43867f29ac7f93298820149fd326d8540187a59e4f28f226e1c0dbfcdc60dc3da437de250e4082a2d6bd845ae9e619bf3b592b824dd8d529bf093cdedff WHIRLPOOL 0e69588c71917e01469f600696a0e9dcef936eb4a0515c70339ca9ee6c268f9f22e4e8f1d91e39635d41ad510473f5708aa3aa3d5b37e82dcfa725f3cda6541f
diff --git a/net-analyzer/ssmping/files/ssmping-0.9-build.patch b/net-analyzer/ssmping/files/ssmping-0.9-build.patch
new file mode 100644
index 000000000000..586819ca0dd5
--- /dev/null
+++ b/net-analyzer/ssmping/files/ssmping-0.9-build.patch
@@ -0,0 +1,23 @@
+fixup build errors/warnings
+
+http://bugs.gentoo.org/240750
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,5 @@
+ PREFIX ?= /usr/local
++CPPFLAGS += -D_GNU_SOURCE
+
+ all: ssmping asmping ssmpingd mcfirst
+
+--- a/ssmping.c
++++ b/ssmping.c
+@@ -22,7 +22,7 @@
+ uint16_t size;
+ uint32_t intface;
+ struct sockaddr_storage name, ucaddr, mcaddr, grpaddr;
+- size_t namelen;
++ socklen_t namelen;
+ #ifdef WIN32
+ WORD wVersionRequested;
+ WSADATA wsaData;
diff --git a/net-analyzer/ssmping/metadata.xml b/net-analyzer/ssmping/metadata.xml
new file mode 100644
index 000000000000..b5353e0b229e
--- /dev/null
+++ b/net-analyzer/ssmping/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>venaas@uninett.no</email>
+ <name>Stig Venaas (upstream)</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/ssmping/ssmping-0.9.1.ebuild b/net-analyzer/ssmping/ssmping-0.9.1.ebuild
new file mode 100644
index 000000000000..5d242e12c51e
--- /dev/null
+++ b/net-analyzer/ssmping/ssmping-0.9.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool for testing multicast connectivity"
+HOMEPAGE="http://www.venaas.no/multicast/ssmping/"
+LICENSE="public-domain"
+SRC_URI="http://www.venaas.no/multicast/ssmping/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9-build.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin ssmping asmping mcfirst
+ dosbin ssmpingd
+ doman ssmping.1 asmping.1 mcfirst.1
+}