summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 01:43:47 +0100
committerSam James <sam@gentoo.org>2021-04-03 17:10:31 +0100
commita2bffd02321901c7237635515a4f486333544b30 (patch)
treeed1b349389adb5c74d0e2b7d86582ad38b17417b /net-analyzer/tleds
parentnet-analyzer/thc-ipv6: EAPI 7, consistent style, misc QA (diff)
downloadgentoo-a2bffd02321901c7237635515a4f486333544b30.tar.gz
gentoo-a2bffd02321901c7237635515a4f486333544b30.tar.bz2
gentoo-a2bffd02321901c7237635515a4f486333544b30.zip
net-analyzer/tleds: port to EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/tleds')
-rw-r--r--net-analyzer/tleds/files/tleds.conf.d2
-rw-r--r--net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild21
2 files changed, 13 insertions, 10 deletions
diff --git a/net-analyzer/tleds/files/tleds.conf.d b/net-analyzer/tleds/files/tleds.conf.d
index 477408d30ed0..cfca606342c9 100644
--- a/net-analyzer/tleds/files/tleds.conf.d
+++ b/net-analyzer/tleds/files/tleds.conf.d
@@ -1,4 +1,4 @@
-# Copyright 2003-2004 Gentoo Foundation
+# Copyright 2003-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
IFACE="eth0"
diff --git a/net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild b/net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild
index 56abdfd1f3cd..34d41cc96fc2 100644
--- a/net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild
+++ b/net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
MY_P="${P/_/}"
-S="${WORKDIR}/${MY_P/eta11/}"
DESCRIPTION="Blinks keyboard LEDs indicating outgoing and incoming network packets on selected network interface"
HOMEPAGE="http://www.hut.fi/~jlohikos/tleds_orig.html"
SRC_URI="
http://www.hut.fi/~jlohikos/tleds/public/${MY_P/11/10}.tgz
http://www.hut.fi/~jlohikos/tleds/public/${MY_P}.patch.bz2
"
+S="${WORKDIR}/${MY_P/eta11/}"
LICENSE="GPL-2"
SLOT="0"
@@ -22,14 +23,16 @@ DEPEND="X? ( x11-libs/libX11 )"
RDEPEND="${DEPEND}"
src_prepare() {
- # code patches
- epatch \
- "${WORKDIR}"/${MY_P}.patch \
- "${FILESDIR}"/${P}-gentoo.patch
+ default
+
+ eapply "${WORKDIR}"/${MY_P}.patch
+ eapply "${FILESDIR}"/${P}-gentoo.patch
}
src_compile() {
- emake CC=$(tc-getCC) $(usex X all tleds)
+ emake \
+ CC="$(tc-getCC)" \
+ $(usex X all tleds)
}
src_install() {