summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-08-29 18:30:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-01 20:02:29 +0300
commit3ef2ed354cc4af367dd40bd446294c6185951b36 (patch)
tree1a6ea543360708898fb11102741237c028a1f658 /net-analyzer/wtfis
parentnet-analyzer/wtfis: fix dependency (diff)
downloadgentoo-3ef2ed354cc4af367dd40bd446294c6185951b36.tar.gz
gentoo-3ef2ed354cc4af367dd40bd446294c6185951b36.tar.bz2
gentoo-3ef2ed354cc4af367dd40bd446294c6185951b36.zip
net-analyzer/wtfis: add 0.7.1
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/32509 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-analyzer/wtfis')
-rw-r--r--net-analyzer/wtfis/Manifest1
-rw-r--r--net-analyzer/wtfis/wtfis-0.7.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/wtfis/Manifest b/net-analyzer/wtfis/Manifest
index 38bab75700da..209244788be0 100644
--- a/net-analyzer/wtfis/Manifest
+++ b/net-analyzer/wtfis/Manifest
@@ -1,3 +1,4 @@
DIST wtfis-0.6.1.gh.tar.gz 472803 BLAKE2B 9764d54d88bc8709b67673200a295bc0520438733b45c98d779e088bbcf57778007caf7fa0dcafed881d94bb6b7216f8f00b30b0b0bd528252c18e449865c382 SHA512 75f44416979f7196879a5a3f528caed7154c29f6a79b9ba116bba98f609b5d4bf9f2f78c2eba1e1629fa9f50c60b5678adac98150843fc1ffbedff8bcae3f0f3
DIST wtfis-0.6.2.gh.tar.gz 473959 BLAKE2B 776b8cafa5acca6648c168198b47ae9f47b8d72b8454880adcb6e63280f9bf60c83184e5ce3054058232eecbf80ead880d4d454ce3b7ca664d4a0bf1d4451e59 SHA512 11ca3987d4ee8e66ad662136b7d4262c26556359c253382fefae3b70aa1c09b95c326a5347299c519eaf54724099402917977ad322eb07dbec765a9d21f39549
DIST wtfis-0.7.0.gh.tar.gz 545486 BLAKE2B ac4272ce7b1a1b6c0f0a3c17af155e4be25ac6e466ddcb983f3b9eb20c3e20be29447092c515e1429fd51c79bc89ed282b46886c05eaae97bb31d5816d57ba57 SHA512 678c504ca7c682b1fd0bde345fb6007513e5ecaa5a7dc77f220778ee1de10636b44462e319a8d67b9fbe10c77f29ce2c31692a82777ca91713fd257c28c407f5
+DIST wtfis-0.7.1.gh.tar.gz 548395 BLAKE2B fbcc19358a0a357fdc9f4b5f27d4bda60e20a118c3c3b7cdfd90fad956d2ef0375efe4f0c8a3a94bfa8a6657d5bb710eaacb403b8c3d446921b963e3e8909442 SHA512 9a77c17e1e922e6d17aba9c6cc7364c8b65bc401cbca311280a4eef958056238aef87c2a8891c1bce5848083d1a7e5e00b0b63ead5ffefdea80ae7baee40c845
diff --git a/net-analyzer/wtfis/wtfis-0.7.1.ebuild b/net-analyzer/wtfis/wtfis-0.7.1.ebuild
new file mode 100644
index 000000000000..c710b351a5ba
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-0.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-2.0.3[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.31.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.4.2[${PYTHON_USEDEP}]
+ <dev-python/rich-13.5.0[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.29.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest