summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-06-30 12:14:05 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-06-30 12:14:15 +0200
commitc95edf1f15ed912075324ecb74a2f2c3483889ce (patch)
tree6dc8b4720507dc63a9765daa7ec2869a05959c57 /net-analyzer/zabbix
parentdev-python/rq: add 1.9.0 (diff)
downloadgentoo-c95edf1f15ed912075324ecb74a2f2c3483889ce.tar.gz
gentoo-c95edf1f15ed912075324ecb74a2f2c3483889ce.tar.bz2
gentoo-c95edf1f15ed912075324ecb74a2f2c3483889ce.zip
net-analyzer/zabbix: added support for additional tls backends
thanks to Timo Gurr <tgurr@gentoo.org> for the initial patch Closes: https://bugs.gentoo.org/586456 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'net-analyzer/zabbix')
-rw-r--r--net-analyzer/zabbix/metadata.xml10
-rw-r--r--net-analyzer/zabbix/zabbix-4.0.30-r1.ebuild13
-rw-r--r--net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild13
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild13
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.8-r1.ebuild13
-rw-r--r--net-analyzer/zabbix/zabbix-5.2.4-r1.ebuild13
-rw-r--r--net-analyzer/zabbix/zabbix-5.2.6-r1.ebuild13
-rw-r--r--net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild13
8 files changed, 71 insertions, 30 deletions
diff --git a/net-analyzer/zabbix/metadata.xml b/net-analyzer/zabbix/metadata.xml
index 3bb2164c1a5c..40e6f474daf0 100644
--- a/net-analyzer/zabbix/metadata.xml
+++ b/net-analyzer/zabbix/metadata.xml
@@ -16,13 +16,15 @@ configure different types of notifications for pre-defined events.
<flag name="agent2">Enable go-based zabbix agent 2 (for to-be-monitored machines)</flag>
<flag name="frontend">Enable zabbix web frontend</flag>
<flag name="ipv6">Turn on support of IPv6</flag>
- <flag name="proxy">Enable proxy support</flag>
+ <flag name="java">Enable Zabbix Java JMX Management Gateway</flag>
+ <flag name="libxml2">Use libxml2 client library</flag>
+ <flag name="mbedtls">Use net-libs/mbedtls as TLS backend</flag>
+ <flag name="odbc">Enable Database Monitor and use UnixODBC Library by default</flag>
<flag name="openipmi">Enable openipmi things</flag>
+ <flag name="openssl">Use dev-libs/openssl as TLS backend</flag>
+ <flag name="proxy">Enable proxy support</flag>
<flag name="server">Enable zabbix server</flag>
<flag name="ssh">SSH v2 based checks</flag>
- <flag name="odbc">Enable Database Monitor and use UnixODBC Library by default</flag>
<flag name="static">Build statically linked binaries</flag>
- <flag name="java">Enable Zabbix Java JMX Management Gateway</flag>
- <flag name="libxml2">Use libxml2 client library</flag>
</use>
</pkgmetadata>
diff --git a/net-analyzer/zabbix/zabbix-4.0.30-r1.ebuild b/net-analyzer/zabbix/zabbix-4.0.30-r1.ebuild
index 6be99de828fb..cfc7eafddcc0 100644
--- a/net-analyzer/zabbix/zabbix-4.0.30-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.0.30-r1.ebuild
@@ -16,10 +16,11 @@ LICENSE="GPL-2"
SLOT="0/$(ver_cut 1-2)"
WEBAPP_MANUAL_SLOT="yes"
KEYWORDS="amd64 x86"
-IUSE="+agent curl frontend ipv6 java ldap libxml2 mysql odbc openipmi oracle +postgres proxy server snmp sqlite ssh ssl static xmpp"
+IUSE="+agent curl frontend gnutls ipv6 java ldap libxml2 mbedtls mysql odbc openipmi +openssl oracle +postgres proxy server snmp sqlite ssh ssl static xmpp"
REQUIRED_USE="|| ( agent frontend proxy server )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) )
+ ssl? ( ^^ ( gnutls mbedtls openssl ) )
static? ( !oracle !snmp )"
COMMON_DEPEND="
@@ -44,7 +45,11 @@ COMMON_DEPEND="
snmp? ( net-analyzer/net-snmp )
sqlite? ( dev-db/sqlite )
ssh? ( net-libs/libssh2 )
- ssl? ( dev-libs/openssl:=[-bindist(-)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0= )
+ mbedtls? ( net-libs/mbedtls:0= )
+ openssl? ( dev-libs/openssl:=[-bindist(-)] )
+ )
xmpp? ( dev-libs/iksemel )
"
@@ -139,17 +144,19 @@ src_configure() {
$(use_enable server) \
$(use_enable static) \
$(use_with curl libcurl) \
+ $(use_with gnutls) \
$(use_with ldap) \
$(use_with libxml2) \
+ $(use_with mbedtls) \
$(use_with mysql) \
$(use_with odbc unixodbc) \
$(use_with openipmi openipmi) \
+ $(use_with openssl) \
$(use_with oracle) \
$(use_with postgres postgresql) \
$(use_with snmp net-snmp) \
$(use_with sqlite sqlite3) \
$(use_with ssh ssh2) \
- $(use_with ssl openssl) \
$(use_with xmpp jabber)
}
diff --git a/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild b/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild
index 4d7efb9ec0b4..d1235337a343 100644
--- a/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild
@@ -16,8 +16,9 @@ LICENSE="GPL-2"
SLOT="0/$(ver_cut 1-2)"
WEBAPP_MANUAL_SLOT="yes"
KEYWORDS="~amd64 ~x86"
-IUSE="+agent curl frontend ipv6 java ldap libxml2 mysql odbc openipmi oracle +postgres proxy server snmp sqlite ssh ssl static xmpp"
+IUSE="+agent curl frontend gnutls ipv6 java ldap libxml2 mbedtls mysql odbc openipmi +openssl oracle +postgres proxy server snmp sqlite ssh ssl static xmpp"
REQUIRED_USE="|| ( agent frontend proxy server )
+ ssl? ( ^^ ( gnutls mbedtls openssl ) )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) )
static? ( !oracle !snmp )"
@@ -44,7 +45,11 @@ COMMON_DEPEND="
snmp? ( net-analyzer/net-snmp )
sqlite? ( dev-db/sqlite )
ssh? ( net-libs/libssh2 )
- ssl? ( dev-libs/openssl:=[-bindist(-)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0= )
+ mbedtls? ( net-libs/mbedtls:0= )
+ openssl? ( dev-libs/openssl:=[-bindist(-)] )
+ )
xmpp? ( dev-libs/iksemel )
"
@@ -139,17 +144,19 @@ src_configure() {
$(use_enable server) \
$(use_enable static) \
$(use_with curl libcurl) \
+ $(use_with gnutls) \
$(use_with ldap) \
$(use_with libxml2) \
+ $(use_with mbedtls) \
$(use_with mysql) \
$(use_with odbc unixodbc) \
$(use_with openipmi openipmi) \
+ $(use_with openssl) \
$(use_with oracle) \
$(use_with postgres postgresql) \
$(use_with snmp net-snmp) \
$(use_with sqlite sqlite3) \
$(use_with ssh ssh2) \
- $(use_with ssl openssl) \
$(use_with xmpp jabber)
}
diff --git a/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild b/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
index 1ca944df3695..cff0c42d44be 100644
--- a/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
@@ -247,10 +247,11 @@ LICENSE="GPL-2"
SLOT="0/$(ver_cut 1-2)"
WEBAPP_MANUAL_SLOT="yes"
KEYWORDS="~amd64 ~x86"
-IUSE="+agent +agent2 curl frontend ipv6 java ldap libxml2 mysql odbc openipmi oracle +postgres proxy server snmp sqlite ssh ssl static"
+IUSE="+agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy server snmp sqlite ssh ssl static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) )
+ ssl? ( ^^ ( gnutls openssl ) )
static? ( !oracle !snmp )"
COMMON_DEPEND="
@@ -275,7 +276,10 @@ COMMON_DEPEND="
snmp? ( net-analyzer/net-snmp )
sqlite? ( dev-db/sqlite )
ssh? ( net-libs/libssh2 )
- ssl? ( dev-libs/openssl:=[-bindist(-)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0= )
+ openssl? ( dev-libs/openssl:=[-bindist(-)] )
+ )
"
RDEPEND="${COMMON_DEPEND}
@@ -370,17 +374,18 @@ src_configure() {
$(use_enable server) \
$(use_enable static) \
$(use_with curl libcurl) \
+ $(use_with gnutls) \
$(use_with ldap) \
$(use_with libxml2) \
$(use_with mysql) \
$(use_with odbc unixodbc) \
$(use_with openipmi openipmi) \
+ $(use_with openssl) \
$(use_with oracle) \
$(use_with postgres postgresql) \
$(use_with snmp net-snmp) \
$(use_with sqlite sqlite3) \
- $(use_with ssh ssh2) \
- $(use_with ssl openssl)
+ $(use_with ssh ssh2)
}
src_compile() {
diff --git a/net-analyzer/zabbix/zabbix-5.0.8-r1.ebuild b/net-analyzer/zabbix/zabbix-5.0.8-r1.ebuild
index ec4ebfeb4372..76c918cf464e 100644
--- a/net-analyzer/zabbix/zabbix-5.0.8-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.8-r1.ebuild
@@ -16,10 +16,11 @@ LICENSE="GPL-2"
SLOT="0/$(ver_cut 1-2)"
WEBAPP_MANUAL_SLOT="yes"
KEYWORDS="amd64 x86"
-IUSE="+agent curl frontend ipv6 java ldap libxml2 mysql odbc openipmi oracle +postgres proxy server snmp sqlite ssh ssl static"
+IUSE="+agent curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy server snmp sqlite ssh ssl static"
REQUIRED_USE="|| ( agent frontend proxy server )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) )
+ ssl? ( ^^ ( gnutls openssl ) )
static? ( !oracle !snmp )"
COMMON_DEPEND="
@@ -44,7 +45,10 @@ COMMON_DEPEND="
snmp? ( net-analyzer/net-snmp )
sqlite? ( dev-db/sqlite )
ssh? ( net-libs/libssh2 )
- ssl? ( dev-libs/openssl:=[-bindist(-)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0= )
+ openssl? ( dev-libs/openssl:=[-bindist(-)] )
+ )
"
RDEPEND="${COMMON_DEPEND}
@@ -138,17 +142,18 @@ src_configure() {
$(use_enable server) \
$(use_enable static) \
$(use_with curl libcurl) \
+ $(use_with gnutls) \
$(use_with ldap) \
$(use_with libxml2) \
$(use_with mysql) \
$(use_with odbc unixodbc) \
$(use_with openipmi openipmi) \
+ $(use_with openssl) \
$(use_with oracle) \
$(use_with postgres postgresql) \
$(use_with snmp net-snmp) \
$(use_with sqlite sqlite3) \
- $(use_with ssh ssh2) \
- $(use_with ssl openssl)
+ $(use_with ssh ssh2)
}
src_compile() {
diff --git a/net-analyzer/zabbix/zabbix-5.2.4-r1.ebuild b/net-analyzer/zabbix/zabbix-5.2.4-r1.ebuild
index ec4ebfeb4372..76c918cf464e 100644
--- a/net-analyzer/zabbix/zabbix-5.2.4-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.2.4-r1.ebuild
@@ -16,10 +16,11 @@ LICENSE="GPL-2"
SLOT="0/$(ver_cut 1-2)"
WEBAPP_MANUAL_SLOT="yes"
KEYWORDS="amd64 x86"
-IUSE="+agent curl frontend ipv6 java ldap libxml2 mysql odbc openipmi oracle +postgres proxy server snmp sqlite ssh ssl static"
+IUSE="+agent curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy server snmp sqlite ssh ssl static"
REQUIRED_USE="|| ( agent frontend proxy server )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) )
+ ssl? ( ^^ ( gnutls openssl ) )
static? ( !oracle !snmp )"
COMMON_DEPEND="
@@ -44,7 +45,10 @@ COMMON_DEPEND="
snmp? ( net-analyzer/net-snmp )
sqlite? ( dev-db/sqlite )
ssh? ( net-libs/libssh2 )
- ssl? ( dev-libs/openssl:=[-bindist(-)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0= )
+ openssl? ( dev-libs/openssl:=[-bindist(-)] )
+ )
"
RDEPEND="${COMMON_DEPEND}
@@ -138,17 +142,18 @@ src_configure() {
$(use_enable server) \
$(use_enable static) \
$(use_with curl libcurl) \
+ $(use_with gnutls) \
$(use_with ldap) \
$(use_with libxml2) \
$(use_with mysql) \
$(use_with odbc unixodbc) \
$(use_with openipmi openipmi) \
+ $(use_with openssl) \
$(use_with oracle) \
$(use_with postgres postgresql) \
$(use_with snmp net-snmp) \
$(use_with sqlite sqlite3) \
- $(use_with ssh ssh2) \
- $(use_with ssl openssl)
+ $(use_with ssh ssh2)
}
src_compile() {
diff --git a/net-analyzer/zabbix/zabbix-5.2.6-r1.ebuild b/net-analyzer/zabbix/zabbix-5.2.6-r1.ebuild
index 1e6a115bef76..2b2efbe976a3 100644
--- a/net-analyzer/zabbix/zabbix-5.2.6-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.2.6-r1.ebuild
@@ -256,11 +256,12 @@ LICENSE="GPL-2"
SLOT="0/$(ver_cut 1-2)"
WEBAPP_MANUAL_SLOT="yes"
KEYWORDS="~amd64 ~x86"
-IUSE="+agent +agent2 curl frontend ipv6 java ldap libxml2 mysql odbc openipmi oracle +postgres proxy server snmp sqlite ssh ssl static"
+IUSE="+agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy server snmp sqlite ssh ssl static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) )
+ ssl? ( ^^ ( gnutls openssl ) )
static? ( !oracle !snmp )"
COMMON_DEPEND="
@@ -285,7 +286,10 @@ COMMON_DEPEND="
snmp? ( net-analyzer/net-snmp )
sqlite? ( dev-db/sqlite )
ssh? ( net-libs/libssh2 )
- ssl? ( dev-libs/openssl:=[-bindist(-)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0= )
+ openssl? ( dev-libs/openssl:=[-bindist(-)] )
+ )
"
RDEPEND="${COMMON_DEPEND}
@@ -380,17 +384,18 @@ src_configure() {
"$(use_enable server)" \
"$(use_enable static)" \
"$(use_with curl libcurl)" \
+ "$(use_with gnutls)" \
"$(use_with ldap)" \
"$(use_with libxml2)" \
"$(use_with mysql)" \
"$(use_with odbc unixodbc)" \
"$(use_with openipmi openipmi)" \
+ "$(use_with openssl)" \
"$(use_with oracle)" \
"$(use_with postgres postgresql)" \
"$(use_with snmp net-snmp)" \
"$(use_with sqlite sqlite3)" \
- "$(use_with ssh ssh2)" \
- "$(use_with ssl openssl)"
+ "$(use_with ssh ssh2)"
}
src_compile() {
diff --git a/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild b/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild
index e3e427e7f2aa..03f172c30f5a 100644
--- a/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild
@@ -272,10 +272,11 @@ LICENSE="GPL-2"
SLOT="0/$(ver_cut 1-2)"
WEBAPP_MANUAL_SLOT="yes"
KEYWORDS="~amd64 ~x86"
-IUSE="+agent +agent2 curl frontend ipv6 java ldap libxml2 mysql odbc openipmi oracle +postgres proxy server snmp sqlite ssh ssl static"
+IUSE="+agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy server snmp sqlite ssh ssl static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) )
+ ssl? ( ^^ ( gnutls openssl ) )
static? ( !oracle !snmp )"
COMMON_DEPEND="
@@ -300,7 +301,10 @@ COMMON_DEPEND="
snmp? ( net-analyzer/net-snmp )
sqlite? ( dev-db/sqlite )
ssh? ( net-libs/libssh2 )
- ssl? ( dev-libs/openssl:=[-bindist(-)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0= )
+ openssl? ( dev-libs/openssl:=[-bindist(-)] )
+ )
"
RDEPEND="${COMMON_DEPEND}
@@ -395,17 +399,18 @@ src_configure() {
"$(use_enable server)" \
"$(use_enable static)" \
"$(use_with curl libcurl)" \
+ "$(use_with gnutls)" \
"$(use_with ldap)" \
"$(use_with libxml2)" \
"$(use_with mysql)" \
"$(use_with odbc unixodbc)" \
"$(use_with openipmi openipmi)" \
+ "$(use_with openssl)" \
"$(use_with oracle)" \
"$(use_with postgres postgresql)" \
"$(use_with snmp net-snmp)" \
"$(use_with sqlite sqlite3)" \
- "$(use_with ssh ssh2)" \
- "$(use_with ssl openssl)"
+ "$(use_with ssh ssh2)"
}
src_compile() {