summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-01-20 14:52:46 +0000
committerThomas Deutschmann <whissi@gentoo.org>2021-02-03 21:25:41 +0100
commit098056da2c62be61849596935272e8bec59a24fa (patch)
treefd6acf50bdb39f4e19dd965ffd355ea044c1e5fb /net-analyzer
parentsys-fs/bindfs: 1.14.9 (diff)
downloadgentoo-098056da2c62be61849596935272e8bec59a24fa.tar.gz
gentoo-098056da2c62be61849596935272e8bec59a24fa.tar.bz2
gentoo-098056da2c62be61849596935272e8bec59a24fa.zip
net-analyzer/linkchecker: bump to 10.0.0
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19139 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/linkchecker/Manifest1
-rw-r--r--net-analyzer/linkchecker/linkchecker-10.0.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/linkchecker/Manifest b/net-analyzer/linkchecker/Manifest
index ed397cd02a29..81c0c47c79cb 100644
--- a/net-analyzer/linkchecker/Manifest
+++ b/net-analyzer/linkchecker/Manifest
@@ -1 +1,2 @@
+DIST linkchecker-10.0.0.tar.gz 512754 BLAKE2B ce6a83c57b3ab2a891913b1912d51315db4465fe5ae201b4a906d200c5f1807f53a5504fefca367f577239c2af99cb0dab7f744ccfe430e074fc85ddf063d2a0 SHA512 c16c52b63dd13f1afe31bfe294fb303b321af88fab1a8c7e8c94a32d1f330131e0188738b37806558e532109dac93656298878337538c7a83205f2a1fa73faa6
DIST linkchecker-10.0.0_pre20200729.tar.gz 401694 BLAKE2B f1a0918c30b292e569fd3168eee152e63ba7266f0ef848a55601e0205d8b0521cb653db77c8dc7b5d1140b493c95e50d76acba44e961586159f2b691e6898353 SHA512 35c49ca5de06688667e39f4eb0d8a048e565fe460a4aff125a484e3966c62cbea95fd95154cb2b544c0f4987f66012793726cf890d604321ed83970654a318f6
diff --git a/net-analyzer/linkchecker/linkchecker-10.0.0.ebuild b/net-analyzer/linkchecker/linkchecker-10.0.0.ebuild
new file mode 100644
index 000000000000..ed64f325657c
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-10.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit bash-completion-r1 distutils-r1 optfeature
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="https://github.com/linkcheck/linkchecker"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/linkcheck/linkchecker.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/linkchecker/linkchecker/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="sqlite"
+# requires libs not present in portage yet
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-9.3-bash-completion.patch"
+)
+
+DOCS=(
+ doc/changelog.txt
+ doc/upgrading.txt
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp config/linkchecker-completion ${PN}
+}
+
+pkg_postinst() {
+ optfeature "bash-completion support" dev-python/argcomplete[${PYTHON_USEDEP}]
+ optfeature "Virus scanning" app-antivirus/clamav
+ optfeature "Geo IP support" dev-python/geoip-python[${PYTHON_USEDEP}]
+ optfeature "GNOME proxy settings support" dev-python/pygobject[${PYTHON_USEDEP}]
+}