summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-04 17:15:25 +0100
committerSam James <sam@gentoo.org>2023-10-04 17:47:16 +0100
commit650a8732378431afd6d66c131f7962ac9b5a0743 (patch)
tree7bf1b9a4bed9c302fef914fe7426f1a9e0bd37a4 /net-analyzer
parentnet-analyzer/httping: add github upstream metadata (diff)
downloadgentoo-650a8732378431afd6d66c131f7962ac9b5a0743.tar.gz
gentoo-650a8732378431afd6d66c131f7962ac9b5a0743.tar.bz2
gentoo-650a8732378431afd6d66c131f7962ac9b5a0743.zip
net-analyzer/httping: add 2.9
Closes: https://bugs.gentoo.org/895528 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/httping/Manifest1
-rw-r--r--net-analyzer/httping/httping-2.9.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-analyzer/httping/Manifest b/net-analyzer/httping/Manifest
index 50d7e99a616d..c94047bd1d9c 100644
--- a/net-analyzer/httping/Manifest
+++ b/net-analyzer/httping/Manifest
@@ -1 +1,2 @@
DIST httping-2.5.tgz 71400 BLAKE2B da261827a4e2276816dbb2f9a6bac989f4ec0e7fc4b7686d51e57f8d4078ec3f94acef032b7042774e9cff57c8158696026e45d44ae1fbb00e52175c9c08b9a5 SHA512 397ce2eac91c9aede0eb19823bfca4e7f98c263937f5954c8a48d5248a251d2030e31f18decb7f7f8b0118ec0e16ec0a84ea4c943ccde7056b80de162954c355
+DIST httping-2.9.tar.gz 83674 BLAKE2B aa1e2b74756ebf62896ad2a4b89e68eff61f73f98ff881bba2fe4e14d2ed2a63af84a2780122ad845d1057ece3f37d567b7bf5d5b62a4b8487c58f1442a90fdf SHA512 74d4a98590b6862a2f15fffdf3bc58e3226a94c7aebbe60135695397b20e6cb71fe8c2af75b8525724f2f9ce6530d1f8eecd3193bc50f31d254bbb9903615019
diff --git a/net-analyzer/httping/httping-2.9.ebuild b/net-analyzer/httping/httping-2.9.ebuild
new file mode 100644
index 000000000000..e44e4a03bcc7
--- /dev/null
+++ b/net-analyzer/httping/httping-2.9.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="https://www.vanheusden.com/httping/"
+SRC_URI="https://github.com/folkertvanheusden/HTTPing/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/HTTPing-${PV}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="debug fftw l10n_nl ncurses ssl +tfo"
+
+RDEPEND="
+ fftw? ( sci-libs/fftw:3.0 )
+ ncurses? ( sys-libs/ncurses:0= )
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="ncurses? ( virtual/pkgconfig )"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.1-flags.patch
+)
+
+src_prepare() {
+ default
+
+ # Don't clobber toolchain defaults
+ sed -i -e 's:-D_FORTIFY_SOURCE=2::' Makefile || die
+
+ # doman does not get PN-LANG.CAT so we move things around and then point at
+ # it later
+ if use l10n_nl; then
+ mkdir nl || die
+ mv httping-nl.1 nl/httping.1 || die
+ fi
+
+}
+
+src_configure() {
+ # not an autotools script
+ echo > makefile.inc || die
+
+ if use ncurses ; then
+ local ncurses_flags="$($(tc-getPKG_CONFIG) --libs ncurses)"
+
+ # Don't require ncurses with unicode support
+ # bug #731950
+ sed -i -e "s/-lncursesw/${ncurses_flags}/" Makefile || die
+ append-libs "${ncurses_flags}"
+ fi
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ FW=$(usex fftw) \
+ DEBUG=$(usex debug) \
+ NC=$(usex ncurses) \
+ SSL=$(usex ssl) \
+ TFO=$(usex tfo)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+
+ use l10n_nl && doman -i18n=nl nl/httping.1
+}