summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2024-08-09 15:49:28 +0200
committerLouis Sautier <sbraz@gentoo.org>2024-08-09 15:51:12 +0200
commitc33ea8fdb98f3f3737079f2ab86c52d32e360ae4 (patch)
tree5e49708b5549c7467172ee60c1b17db6d5226bb7 /net-analyzer
parentnet-analyzer/nagios-plugins-linux-madrisan: drop 31 (diff)
downloadgentoo-c33ea8fdb98f3f3737079f2ab86c52d32e360ae4.tar.gz
gentoo-c33ea8fdb98f3f3737079f2ab86c52d32e360ae4.tar.bz2
gentoo-c33ea8fdb98f3f3737079f2ab86c52d32e360ae4.zip
net-analyzer/nagios-plugins-linux-madrisan: add 34
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/Manifest1
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-34.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/Manifest b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
index c7e2d98f4748..1d1541ab8c76 100644
--- a/net-analyzer/nagios-plugins-linux-madrisan/Manifest
+++ b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
@@ -1,2 +1,3 @@
DIST nagios-plugins-linux-madrisan-32.tar.xz 402976 BLAKE2B ef66934315f3ddbee1a2d84723477773549c9a5ed731853780ef15b9f44ea462256f730f854d517415dce2b944a4bf0abcbfa0623a7a1faffef4b5bbf162af76 SHA512 42392c123961bb17192344f20973a3d26c74aeef112638384d5b7a687e7117a3378d6efdb07ad15a7309f5db621404602e9c2beb0dcc4e207924d0d3a466ab59
DIST nagios-plugins-linux-madrisan-33.tar.xz 397516 BLAKE2B 39e428d7b44104e01f8101ec33d250b8317c2ab9a5772bd815baf91c14eb1aeffc2aaaec1696e338d9aa31ebd9cb67d10a2049bc78a1bd8fea813761def36d26 SHA512 9b0df712d799ea5ae1eca8135089e41f167446e40416dbfe090ec855476318b26d8fdc3865470bf6cf54e7dcbce483d1f577a886ef35023e983e2508a307df70
+DIST nagios-plugins-linux-madrisan-34.tar.xz 399116 BLAKE2B f5fae6818c0aa87a140238cde28e7ea24fb19976274e301df03308c97d980e1ddfca51861d6302321b3959f67e426fdcf501787525d3a81ab6850ccaf4cc6d34 SHA512 a189135c590c5086bc7b3c1bb9f5ec1d15c55a542d39a578743abe62678dad961115b7180a62dfaf7ffc9f63679e33d0d2253b51feeae775fa1c5a3a7cd22149
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-34.ebuild b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-34.ebuild
new file mode 100644
index 000000000000..4cb8f2a417f3
--- /dev/null
+++ b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-34.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="nagios-plugins-linux"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Additional and alternative Nagios plugins for Linux"
+HOMEPAGE="https://github.com/madrisan/nagios-plugins-linux"
+SRC_URI="https://github.com/madrisan/${MY_PN}/releases/download/v${PV}/${MY_P}.tar.xz -> ${P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="curl systemd"
+
+DEPEND="
+ curl? ( net-misc/curl:0= )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ # Avoid collision with net-analyzer/monitoring-plugins
+ # and net-analyzer/nagios-plugins
+ sed -ri "s/check_(load|swap|uptime|users)/&_madrisan/" plugins/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)/nagios/plugins"
+ # Most options are already defaults for Gentoo
+ --disable-hardening
+ $(use_enable curl libcurl)
+ $(use_enable systemd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake check VERBOSE=1
+}