summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHank Leininger <hlein@korelogic.com>2024-02-08 15:41:09 -0700
committerJoonas Niilola <juippis@gentoo.org>2024-03-04 09:53:47 +0200
commit1d29ef3e3ee3cfed5cc90e993c21d7abd7fe6d15 (patch)
tree6dc331533631156346e4b0f442b1d2715bb1fa78 /net-firewall/fwknop
parentsec-keys/openpgp-keys-fwknop: new package, add 20240208 (diff)
downloadgentoo-1d29ef3e3ee3cfed5cc90e993c21d7abd7fe6d15.tar.gz
gentoo-1d29ef3e3ee3cfed5cc90e993c21d7abd7fe6d15.tar.bz2
gentoo-1d29ef3e3ee3cfed5cc90e993c21d7abd7fe6d15.zip
net-firewall/fwknop: add 2.6.11
Signed-off-by: Hank Leininger <hlein@korelogic.com> Closes: https://bugs.gentoo.org/822741 Closes: https://bugs.gentoo.org/920793 Closes: https://github.com/gentoo/gentoo/pull/35236 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-firewall/fwknop')
-rw-r--r--net-firewall/fwknop/Manifest2
-rw-r--r--net-firewall/fwknop/fwknop-2.6.11.ebuild133
2 files changed, 135 insertions, 0 deletions
diff --git a/net-firewall/fwknop/Manifest b/net-firewall/fwknop/Manifest
index 53b2c9de54bf..9dca4d3387dd 100644
--- a/net-firewall/fwknop/Manifest
+++ b/net-firewall/fwknop/Manifest
@@ -1 +1,3 @@
DIST fwknop-2.6.10.tar.gz 1988197 BLAKE2B d4c2010c64ab160f0edc02e2b1530749ee47ff6ed16d6b556d366daef7ce5e22ef38fbbbf6e8cfaa14e0d9706ba2b65937b03c70b54b3429ff1732ae33c1852c SHA512 3b3e35eda574abd1759431c88677eea7078c54cb3252c0ee0e1019b5b8224ed8844d30760da70a952e1cd92b04715a547f6effabda54678f791fff9afa32cd80
+DIST fwknop-2.6.11.tar.bz2 1812061 BLAKE2B 7cfb8abc95fd8aa8a8d6774507fe4dea8deacc5aa4c9f5874c39dc2a3ab0c413cf479632a34027c76180cecd0a4fbf11d8cac5fe77f48993932fab13ea740a0b SHA512 79ce0585d075dffe77143b4d6ec3f8653ddad5f46cfb596e9f373be0065bdace7efdfe9cd341ebfaa7232d39f905affa81325b569635c8a44095fd551debadd7
+DIST fwknop-2.6.11.tar.bz2.asc 195 BLAKE2B 56ea868bd31fc4d06e3e976042bd3969f2c8df5bcb1e6a12d87c5740eb39b2eaf1118620be260e94b07758f4bc875e58f6b63a7989cdc08a32f049aa208b57a3 SHA512 2902a9ccb1c82baa4a96af5841d21ac873b606876fe01e8fbcf2b1e2a89c75965477f574c62a6f261f2af4420038ea6d41ef66af57b79742527054593e3cd3d7
diff --git a/net-firewall/fwknop/fwknop-2.6.11.ebuild b/net-firewall/fwknop/fwknop-2.6.11.ebuild
new file mode 100644
index 000000000000..2ae43d31f5f7
--- /dev/null
+++ b/net-firewall/fwknop/fwknop-2.6.11.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/fwknop.gpg
+inherit autotools linux-info readme.gentoo-r1 systemd tmpfiles verify-sig
+
+DESCRIPTION="Single Packet Authorization and Port Knocking application"
+HOMEPAGE="https://www.cipherdyne.org/fwknop/"
+SRC_URI="
+ https://www.cipherdyne.org/fwknop/download/${P}.tar.bz2
+ verify-sig? ( https://www.cipherdyne.org/fwknop/download/${P}.tar.bz2.asc )
+ "
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+client extras firewalld gdbm gpg +iptables nfqueue +server static-libs udp-server"
+
+DEPEND="
+ client? ( net-misc/wget[ssl] )
+ firewalld? ( net-firewall/firewalld )
+ gdbm? ( sys-libs/gdbm )
+ gpg? (
+ app-crypt/gpgme:=
+ dev-libs/libassuan
+ dev-libs/libgpg-error
+ )
+ iptables? ( net-firewall/iptables )
+ nfqueue? ( net-libs/libnetfilter_queue )
+ server? ( !nfqueue? ( !udp-server? ( net-libs/libpcap ) ) )
+ verify-sig? ( sec-keys/openpgp-keys-fwknop )
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="
+ nfqueue? ( server )
+ server? ( ^^ ( firewalld iptables ) )
+ udp-server? ( server )
+"
+
+##PATCHES=( "${FILESDIR}/${PN}-2.6.10_fno-common_fix.patch" )
+
+DOCS=( AUTHORS ChangeLog README )
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="
+Example configuration files were installed to '${EPREFIX}/etc/fwknopd/'.
+Please edit them to suit your needs and then remove the .example suffix.
+
+fwknopd supports several backends: firewalld, iptables, ipfw, pf, ipf.
+You can set the desired backend via FIREWALL_EXE option in fwknopd.conf
+instead of the default one chosen at compile time.
+"
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default_src_prepare
+
+ # Install example configs with .example suffix.
+ if use server; then
+ sed -i -e 's|conf;|conf.example;|g' Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}/run"
+ $(use_enable client)
+ $(use_enable !gdbm file-cache)
+ $(use_enable nfqueue nfq-capture)
+ $(use_enable server)
+ $(use_enable udp-server)
+ $(use_with gpg gpgme)
+ )
+ use firewalld && myeconfargs+=(--with-firewalld="${EPREFIX}/usr/sbin/firewalld")
+ use iptables && myeconfargs+=(--with-iptables="${EPREFIX}/sbin/iptables")
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default_src_install
+
+ if use extras; then
+ dodoc extras/apparmor/usr.sbin.fwknopd
+ dodoc extras/console-qr/console-qr.sh
+ dodoc extras/fwknop-launcher/*
+ fi
+
+ if use server; then
+ newinitd "${FILESDIR}/fwknopd.init" fwknopd
+ newconfd "${FILESDIR}/fwknopd.confd" fwknopd
+ systemd_dounit extras/systemd/fwknopd.service
+ newtmpfiles "${FILESDIR}/fwknopd.tmpfiles.conf" fwknopd.conf
+ readme.gentoo_create_doc
+ fi
+
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ if ! use static-libs ; then
+ find "${ED}" -type f -name libfko.a -delete || die
+ fi
+}
+
+pkg_postinst() {
+ if use server; then
+ readme.gentoo_print_elog
+
+ tmpfiles_process fwknopd.conf
+
+ if ! linux_config_exists || ! linux_chkconfig_present NETFILTER_XT_MATCH_COMMENT; then
+ echo
+ ewarn "fwknopd daemon relies on the 'comment' match in order to expire"
+ ewarn "created firewall rules, which is an important security feature."
+ ewarn "Please enable NETFILTER_XT_MATCH_COMMENT support in your kernel."
+ echo
+ fi
+ if use nfqueue && \
+ ! linux_config_exists || ! linux_chkconfig_present NETFILTER_XT_TARGET_NFQUEUE; then
+ echo
+ ewarn "fwknopd daemon relies on the 'NFQUEUE' target for NFQUEUE mode."
+ ewarn "Please enable NETFILTER_XT_TARGET_NFQUEUE support in your kernel."
+ echo
+ fi
+ fi
+}