summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-04-21 14:47:22 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-04-21 15:00:40 +0200
commit7f621196920f6520aaaabc822c3af6843cd5a5f4 (patch)
treeb10271459e03bde5d629515bfc12ecaf9d60f959 /net-im/rocketchat-desktop-bin
parentsys-power/thermald: Stabilize 2.4.8-r1 amd64, #839855 (diff)
downloadgentoo-7f621196920f6520aaaabc822c3af6843cd5a5f4.tar.gz
gentoo-7f621196920f6520aaaabc822c3af6843cd5a5f4.tar.bz2
gentoo-7f621196920f6520aaaabc822c3af6843cd5a5f4.zip
net-im/rocketchat-desktop-bin: add 3.8.4
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im/rocketchat-desktop-bin')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index f5f1aa502106..9a222b78e1dc 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.8.2-linux-x86_64.rpm 62202472 BLAKE2B 44ecfa459624e4cb44777183acb9e1a3d6737166c752db2c33fb298402bac4c4f9856c60cf9889d736902f4f4250c9e93c2e079736dcfadb1626b31f1ebe04e6 SHA512 afdff8f3d6b36e5a595ec684c0e5641fbeeaae031a75f715ddf42a4e4f212d81dd0e04dc6eee9bc4993be2d284f36f1c9900244794bdc29580000a61756a6832
+DIST rocketchat-3.8.4-linux-x86_64.rpm 62658984 BLAKE2B c4472cf13ce4d3cc7afcaee801bcbf8884acc96215b099f430c147e38be42b6f9b3a34f503c351728c3dbed3c1c4d71b3c2c9954980c89a5c2b0ba14660e91be SHA512 26594bb31e206278a22f4276c33119bc4635404c6e1d6a066576eeed9252ea5eebe3099a677377d0bd333844139397b3bd5b4e4cdf8a245924cf9a4ebaa3dcb6
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.4.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.4.ebuild
new file mode 100644
index 000000000000..258071fcfef4
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}-linux-x86_64.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Rocket.Chat/*"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}