summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-18 19:59:17 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-18 20:01:14 -0400
commit85c7c741e7461c68d823afdf3c016364bbbe7e3a (patch)
treed2a94759f1ab77fccbe6503a0ba05ead073d74cc /net-irc/weechat/files
parentdev-python/matplotlib: keyworded 2.1.2-r1 for ppc, bug #622420 (diff)
downloadgentoo-85c7c741e7461c68d823afdf3c016364bbbe7e3a.tar.gz
gentoo-85c7c741e7461c68d823afdf3c016364bbbe7e3a.tar.bz2
gentoo-85c7c741e7461c68d823afdf3c016364bbbe7e3a.zip
net-irc/weechat: version bump to 2.1
Diffstat (limited to 'net-irc/weechat/files')
-rw-r--r--net-irc/weechat/files/weechat-2.1-tinfo.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-irc/weechat/files/weechat-2.1-tinfo.patch b/net-irc/weechat/files/weechat-2.1-tinfo.patch
new file mode 100644
index 000000000000..e44e06e61f99
--- /dev/null
+++ b/net-irc/weechat/files/weechat-2.1-tinfo.patch
@@ -0,0 +1,28 @@
+Use pkgconfig to find ncurses libs in order to support separate libtinfo.
+
+--- weechat-2.1/src/gui/curses/normal/CMakeLists.txt
++++ weechat-2.1/src/gui/curses/normal/CMakeLists.txt
+@@ -29,7 +29,13 @@
+ ../gui-curses-window.c
+ )
+
+-find_package(Ncurses)
++find_package(PkgConfig)
++pkg_search_module(NCURSES ncursesw ncurses)
++
++if(NOT NCURSES_FOUND)
++ find_package(Ncurses)
++endif(NOT NCURSES_FOUND)
++
+ if(NCURSES_FOUND)
+ check_include_files(ncursesw/ncurses.h NCURSESW_HEADERS)
+ if(NCURSESW_HEADERS)
+@@ -54,7 +60,7 @@
+
+ add_dependencies(${EXECUTABLE} weechat_gui_curses_normal)
+
+-list(APPEND EXTRA_LIBS ${NCURSES_LIBRARY})
++list(APPEND EXTRA_LIBS ${NCURSES_LIBRARY} ${NCURSES_LIBRARIES})
+
+ # Due to circular references, we must link two times with libweechat_core.a and libweechat_gui_common.a
+ target_link_libraries(${EXECUTABLE} ${STATIC_LIBS} weechat_gui_curses_normal ${EXTRA_LIBS} ${STATIC_LIBS})