summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-01 18:02:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-01 18:23:19 +0200
commit9cff3b7eacaaa77e4e4af166a740a65b26ed5ba3 (patch)
tree216f63f804698d563dd46f89e358ae7fc5e877c5 /net-irc
parentnet-p2p/resilio-sync: drop 2.7.2.1375-r1 (diff)
downloadgentoo-9cff3b7eacaaa77e4e4af166a740a65b26ed5ba3.tar.gz
gentoo-9cff3b7eacaaa77e4e4af166a740a65b26ed5ba3.tar.bz2
gentoo-9cff3b7eacaaa77e4e4af166a740a65b26ed5ba3.zip
net-irc/rhapsody: bump to EAPI-8, add missing RDEPEND
- remove empty IUSE - fix indents Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/37867 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/rhapsody/rhapsody-0.28b-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-irc/rhapsody/rhapsody-0.28b-r1.ebuild b/net-irc/rhapsody/rhapsody-0.28b-r1.ebuild
new file mode 100644
index 000000000000..96c32e62df43
--- /dev/null
+++ b/net-irc/rhapsody/rhapsody-0.28b-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="IRC client intended to be displayed on a text console"
+HOMEPAGE="https://rhapsody.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${PN}_${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND=">=sys-libs/ncurses-5.0:0="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-uclibc.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_configure() {
+ PKGCONFIG="$(tc-getPKG_CONFIG)" \
+ ./configure -i /usr/share/rhapsody || die "configure failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LOCALFLAGS="${CFLAGS} -fcommon"
+}
+
+src_install() {
+ dobin rhapsody
+
+ insinto /usr/share/rhapsody/help
+ doins help/*.hlp
+
+ dodoc docs/CHANGELOG
+}