summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-02-27 10:53:56 -0800
committerJason Zaman <perfinion@gentoo.org>2022-02-27 16:40:48 -0800
commit8dc9a16879d3257ac91530034d9e9b1794aeb7e5 (patch)
tree2cf691252e3dfea80fa08bfb91f94df00e78fcc3 /net-libs/google-cloud-cpp/files
parentnet-libs/google-cloud-cpp: port to cmake.eclass (diff)
downloadgentoo-8dc9a16879d3257ac91530034d9e9b1794aeb7e5.tar.gz
gentoo-8dc9a16879d3257ac91530034d9e9b1794aeb7e5.tar.bz2
gentoo-8dc9a16879d3257ac91530034d9e9b1794aeb7e5.zip
net-libs/google-cloud-cpp: Drop old
Keep last cmake-utils version for now Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'net-libs/google-cloud-cpp/files')
-rw-r--r--net-libs/google-cloud-cpp/files/0001-Make-the-install-target-work.patch12
-rw-r--r--net-libs/google-cloud-cpp/files/0001-cmake-Fix-GOOGLE_CLOUD_CPP_GRPC_PROVIDER-pkg-config.patch33
-rw-r--r--net-libs/google-cloud-cpp/files/0002-cmake-set-library-soversions.patch130
-rw-r--r--net-libs/google-cloud-cpp/files/google-cloud-cpp-0.5.0-openssl.patch13
4 files changed, 0 insertions, 188 deletions
diff --git a/net-libs/google-cloud-cpp/files/0001-Make-the-install-target-work.patch b/net-libs/google-cloud-cpp/files/0001-Make-the-install-target-work.patch
deleted file mode 100644
index f84cb4be3c27..000000000000
--- a/net-libs/google-cloud-cpp/files/0001-Make-the-install-target-work.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur google-cloud-cpp-0.2.0.orig/google/cloud/storage/CMakeLists.txt google-cloud-cpp-0.2.0/google/cloud/storage/CMakeLists.txt
---- google-cloud-cpp-0.2.0.orig/google/cloud/storage/CMakeLists.txt 2018-09-28 00:39:41.170482472 +0800
-+++ google-cloud-cpp-0.2.0/google/cloud/storage/CMakeLists.txt 2018-09-28 00:42:09.679979597 +0800
-@@ -321,7 +321,7 @@
- PATTERN "testing/*"
- EXCLUDE)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/version_info.h DESTINATION
-- include/storage/client)
-+ include/google/cloud/storage)
-
- # Setup global variables used in the following *.in files.
- set(GOOGLE_CLOUD_CPP_CONFIG_VERSION_MAJOR ${STORAGE_CLIENT_VERSION_MAJOR})
diff --git a/net-libs/google-cloud-cpp/files/0001-cmake-Fix-GOOGLE_CLOUD_CPP_GRPC_PROVIDER-pkg-config.patch b/net-libs/google-cloud-cpp/files/0001-cmake-Fix-GOOGLE_CLOUD_CPP_GRPC_PROVIDER-pkg-config.patch
deleted file mode 100644
index a1b9a166ea3c..000000000000
--- a/net-libs/google-cloud-cpp/files/0001-cmake-Fix-GOOGLE_CLOUD_CPP_GRPC_PROVIDER-pkg-config.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From ef34b197dd23833c0dde9ea20f62681dbafa7a9b Mon Sep 17 00:00:00 2001
-From: Jason Zaman <jason@perfinion.com>
-Date: Fri, 7 Sep 2018 21:19:11 +0800
-Subject: [PATCH 1/2] cmake: Fix GOOGLE_CLOUD_CPP_GRPC_PROVIDER=pkg-config
-
-The grpc_cpp_plugin executable needs to be marked imported otherwise
-cmake will try (and fail) to build it. Also the location variable was
-typo'd.
-
-Signed-off-by: Jason Zaman <jason@perfinion.com>
----
- cmake/IncludeGrpc.cmake | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/cmake/IncludeGrpc.cmake b/cmake/IncludeGrpc.cmake
-index 36dcfe5c..c18f5cbc 100644
---- a/cmake/IncludeGrpc.cmake
-+++ b/cmake/IncludeGrpc.cmake
-@@ -225,9 +225,8 @@ elseif("${GOOGLE_CLOUD_CPP_GRPC_PROVIDER}" STREQUAL "pkg-config")
- ${PROTOBUF_SRC_ROOT_FOLDER}/vsprojects/${_PROTOBUF_ARCH_DIR}Release
- ${PROTOBUF_SRC_ROOT_FOLDER}/vsprojects/${_PROTOBUF_ARCH_DIR}Debug)
- mark_as_advanced(PROTOC_GRPCPP_PLUGIN_EXECUTABLE)
-- add_executable(grpc_cpp_plugin ${PROTOC_GRPC_PLUGIN_EXECUTABLE})
-+ add_executable(grpc_cpp_plugin IMPORTED)
- set_property(TARGET grpc_cpp_plugin
-- PROPERTY IMPORTED_LOCATION
-- ${PROTOC_GRPCPP_CPP_PLUGIN_EXECUTABLE})
-+ PROPERTY IMPORTED_LOCATION ${PROTOC_GRPCPP_PLUGIN_EXECUTABLE})
-
- endif ()
---
-2.16.4
-
diff --git a/net-libs/google-cloud-cpp/files/0002-cmake-set-library-soversions.patch b/net-libs/google-cloud-cpp/files/0002-cmake-set-library-soversions.patch
deleted file mode 100644
index 74a57711ed63..000000000000
--- a/net-libs/google-cloud-cpp/files/0002-cmake-set-library-soversions.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-From b1d6f58033be92661f91b221b878e333eb02fd7f Mon Sep 17 00:00:00 2001
-From: Jason Zaman <jason@perfinion.com>
-Date: Fri, 7 Sep 2018 22:35:24 +0800
-Subject: [PATCH 2/2] cmake: set library soversions
-
-Set library soversions so CMake sets the symlinks and soversions
-properly. Install the cmake files in the correct dir.
-
-Signed-off-by: Jason Zaman <jason@perfinion.com>
----
- google/cloud/CMakeLists.txt | 7 +++++++
- google/cloud/bigtable/CMakeLists.txt | 14 ++++++++++++++
- google/cloud/firestore/CMakeLists.txt | 12 ++++++++++--
- google/cloud/storage/CMakeLists.txt | 9 ++++++++-
- 4 files changed, 39 insertions(+), 3 deletions(-)
-
-diff --git a/google/cloud/CMakeLists.txt b/google/cloud/CMakeLists.txt
-index 3f3f8742..442f4e17 100644
---- a/google/cloud/CMakeLists.txt
-+++ b/google/cloud/CMakeLists.txt
-@@ -98,6 +98,13 @@ target_include_directories(google_cloud_cpp_common
- $<INSTALL_INTERFACE:include>)
- target_compile_options(google_cloud_cpp_common
- PUBLIC ${GOOGLE_CLOUD_CPP_EXCEPTIONS_FLAG})
-+set_target_properties(
-+ google_cloud_cpp_common
-+ PROPERTIES
-+ VERSION
-+ ${GOOGLE_CLOUD_CPP_VERSION_MAJOR}.${GOOGLE_CLOUD_CPP_VERSION_MINOR}.${GOOGLE_CLOUD_CPP_VERSION_PATCH}
-+ SOVERSION
-+ ${GOOGLE_CLOUD_CPP_VERSION_MAJOR})
-
- include(CreateBazelConfig)
- create_bazel_config(google_cloud_cpp_common)
-diff --git a/google/cloud/bigtable/CMakeLists.txt b/google/cloud/bigtable/CMakeLists.txt
-index 9ed778eb..fd9c8797 100644
---- a/google/cloud/bigtable/CMakeLists.txt
-+++ b/google/cloud/bigtable/CMakeLists.txt
-@@ -102,6 +102,13 @@ target_include_directories(bigtable_protos
- $<INSTALL_INTERFACE:include>)
- target_compile_options(bigtable_protos
- PUBLIC ${GOOGLE_CLOUD_CPP_EXCEPTIONS_FLAG})
-+set_target_properties(
-+ bigtable_protos
-+ PROPERTIES
-+ VERSION
-+ ${BIGTABLE_CLIENT_VERSION_MAJOR}.${BIGTABLE_CLIENT_VERSION_MINOR}.${BIGTABLE_CLIENT_VERSION_PATCH}
-+ SOVERSION
-+ ${BIGTABLE_CLIENT_VERSION_MAJOR})
- add_library(bigtable::protos ALIAS bigtable_protos)
-
- # Enable unit tests
-@@ -206,6 +213,13 @@ target_include_directories(bigtable_client
- $<INSTALL_INTERFACE:include>)
- target_compile_options(bigtable_client
- PUBLIC ${GOOGLE_CLOUD_CPP_EXCEPTIONS_FLAG})
-+set_target_properties(
-+ bigtable_client
-+ PROPERTIES
-+ VERSION
-+ ${BIGTABLE_CLIENT_VERSION_MAJOR}.${BIGTABLE_CLIENT_VERSION_MINOR}.${BIGTABLE_CLIENT_VERSION_PATCH}
-+ SOVERSION
-+ ${BIGTABLE_CLIENT_VERSION_MAJOR})
- add_library(bigtable::client ALIAS bigtable_client)
-
- include(CreateBazelConfig)
-diff --git a/google/cloud/firestore/CMakeLists.txt b/google/cloud/firestore/CMakeLists.txt
-index 88c5ad6d..c69e48fd 100644
---- a/google/cloud/firestore/CMakeLists.txt
-+++ b/google/cloud/firestore/CMakeLists.txt
-@@ -62,6 +62,13 @@ target_include_directories(firestore_client
- $<INSTALL_INTERFACE:include>)
- target_compile_options(firestore_client
- PUBLIC ${GOOGLE_CLOUD_CPP_EXCEPTIONS_FLAG})
-+set_target_properties(
-+ firestore_client
-+ PROPERTIES
-+ VERSION
-+ ${FIRESTORE_CLIENT_VERSION_MAJOR}.${FIRESTORE_CLIENT_VERSION_MINOR}.${FIRESTORE_CLIENT_VERSION_PATCH}
-+ SOVERSION
-+ ${FIRESTORE_CLIENT_VERSION_MAJOR})
- add_library(firestore::client ALIAS firestore_client)
-
- include(CreateBazelConfig)
-@@ -104,7 +111,8 @@ install(TARGETS
-
- # The exports can only be installed if all the dependencies are installed. CMake
- # needs to know where the submodules will be installed from,
--install(EXPORT firestore-targets DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/cmake)
-+install(EXPORT firestore-targets
-+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/firestore_client")
-
- install(TARGETS firestore_client
- EXPORT firestore-targets
-@@ -142,4 +150,4 @@ install(
- FILES "${CMAKE_CURRENT_BINARY_DIR}/firestore_client-config.cmake"
- "${CMAKE_CURRENT_BINARY_DIR}/firestore_client-config-version.cmake"
- DESTINATION
-- ${CMAKE_INSTALL_DATAROOTDIR}/cmake)
-+ "${CMAKE_INSTALL_LIBDIR}/cmake/firestore_client")
-diff --git a/google/cloud/storage/CMakeLists.txt b/google/cloud/storage/CMakeLists.txt
-index cef3954b..912391cc 100644
---- a/google/cloud/storage/CMakeLists.txt
-+++ b/google/cloud/storage/CMakeLists.txt
-@@ -205,6 +205,13 @@ target_include_directories(storage_client
- $<INSTALL_INTERFACE:include>)
- target_compile_options(storage_client
- PUBLIC ${GOOGLE_CLOUD_CPP_EXCEPTIONS_FLAG})
-+set_target_properties(
-+ storage_client
-+ PROPERTIES
-+ VERSION
-+ ${STORAGE_CLIENT_VERSION_MAJOR}.${STORAGE_CLIENT_VERSION_MINOR}.${STORAGE_CLIENT_VERSION_PATCH}
-+ SOVERSION
-+ ${STORAGE_CLIENT_VERSION_MAJOR})
-
- add_library(storage_client_testing
- testing/canonical_errors.h
-@@ -315,7 +322,7 @@ install(TARGETS storage_client
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
--install(DIRECTORY . DESTINATION include/storage/client
-+install(DIRECTORY . DESTINATION include/google/cloud/storage/client
- FILES_MATCHING
- PATTERN "*.h"
- PATTERN "testing/*"
---
-2.16.4
-
diff --git a/net-libs/google-cloud-cpp/files/google-cloud-cpp-0.5.0-openssl.patch b/net-libs/google-cloud-cpp/files/google-cloud-cpp-0.5.0-openssl.patch
deleted file mode 100644
index a5579909e8ab..000000000000
--- a/net-libs/google-cloud-cpp/files/google-cloud-cpp-0.5.0-openssl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ur google-cloud-cpp-0.5.0.orig/google/cloud/storage/CMakeLists.txt google-cloud-cpp-0.5.0/google/cloud/storage/CMakeLists.txt
---- google-cloud-cpp-0.5.0.orig/google/cloud/storage/CMakeLists.txt 2019-01-30 14:01:05.657031402 +0800
-+++ google-cloud-cpp-0.5.0/google/cloud/storage/CMakeLists.txt 2019-01-30 14:01:19.969968164 +0800
-@@ -215,9 +215,6 @@
- Crc32c::crc32c
- CURL::CURL
- Threads::Threads
-- OpenSSL::SSL
-- OpenSSL::Crypto
-- ZLIB::ZLIB
- PRIVATE storage_common_options)
- target_include_directories(storage_client
- PUBLIC $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}>