summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-12-25 20:21:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-12-25 20:22:15 +0100
commit112d6d4495c3e6547d53746c109fb689af18e0a9 (patch)
tree2da1afd6d27a6753ad6f0a5bd4b0877299fbf8e0 /net-libs/grpc
parentprofiles/arch: Remove xwayland[libei] USE masks where possible (diff)
downloadgentoo-112d6d4495c3e6547d53746c109fb689af18e0a9.tar.gz
gentoo-112d6d4495c3e6547d53746c109fb689af18e0a9.tar.bz2
gentoo-112d6d4495c3e6547d53746c109fb689af18e0a9.zip
net-libs/grpc: add 1.60.0
Closes: https://bugs.gentoo.org/915482 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-libs/grpc')
-rw-r--r--net-libs/grpc/Manifest1
-rw-r--r--net-libs/grpc/grpc-1.60.0.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/net-libs/grpc/Manifest b/net-libs/grpc/Manifest
index e2b42171062c..7f8917ce7461 100644
--- a/net-libs/grpc/Manifest
+++ b/net-libs/grpc/Manifest
@@ -2,3 +2,4 @@ DIST grpc-1.52.1.tar.gz 8686340 BLAKE2B 0076ddd4a2840892f4ad11885e18f782b6a64533
DIST grpc-1.55.1.tar.gz 9272441 BLAKE2B b2788d8deeb9791f04073294caa82c10e2cfe6376d09f396b51508a52f809e7f9f48d50ad5a62b2add652633b5c2d3b1ba07857b81111fa810202106251f440d SHA512 ecfa3a5affe33f160032f2ce42a9b44344d217359f68ee99305162ccabc911f44bc22512401183de74347e86add2ce20ec89da87ba6c14ab69874eb0835145d1
DIST grpc-1.56.1.tar.gz 11750628 BLAKE2B 52ea088d3d19fa7c1d1dc44899cd67bfd0132df2fd37690d855194d3196e4c26cfdd6fe589b5e4f802cdf88e70aad6c33b3ee98c1bd1bc47356d0dee9cdc706d SHA512 2bf9619edb60a6cec4cdaa89ee3c470c52b9745ea954bfe205aef6eb29bb55949de02e8c2afc7352eacdcd33fe4000861fd16fda9e5f66c87222674b17d6322a
DIST grpc-1.57.0.tar.gz 17337863 BLAKE2B 10c6fb35f606806aeb25cd55dd993d9af168eb8b1db64b4515830e2144dc44f35ce8f8329316a38d933b8032a0eff386591a0ddb87f2e405c5deaba012db2824 SHA512 b323de7c1f35b9de3fb7bf02ff4db6993abb0eee6860bbf2082818dda405fbe3a19fad91c5b48565cb65c6318de739bb91e47b5095801c078c6cbf3e8c73600c
+DIST grpc-1.60.0.tar.gz 17442762 BLAKE2B 35cc0ea938deb848ca91e3d5f8879b85b80f94ac09b582600f05fee1f55c162ae98f2f744480f69d78e78da0c0f2d9e198f812101daaa1f1959869f26ba7d97a SHA512 91c2406ed4198509ac0d5360b3da6898fa4f40f459eb6fff541faa44cc238eed98fd7489e7ef7a80a6f4a318bc5b9130eaa0ba1beaa358d1c074fc82825648ff
diff --git a/net-libs/grpc/grpc-1.60.0.ebuild b/net-libs/grpc/grpc-1.60.0.ebuild
new file mode 100644
index 000000000000..4a22cee5664a
--- /dev/null
+++ b/net-libs/grpc/grpc-1.60.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+MY_PV="${PV//_pre/-pre}"
+
+DESCRIPTION="Modern open source high performance RPC framework"
+HOMEPAGE="https://www.grpc.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+# format is 0/${CORE_SOVERSION//./}.${CPP_SOVERSION//./} , check top level CMakeLists.txt
+SLOT="0/37.160"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="doc examples test systemd"
+
+# look for submodule versions in third_party dir
+RDEPEND="
+ =dev-cpp/abseil-cpp-20230802.0*:=
+ >=dev-libs/re2-0.2021.11.01:=
+ >=dev-libs/openssl-1.1.1:0=[-bindist(-)]
+ >=dev-libs/protobuf-23.3:=
+ dev-libs/xxhash
+ >=net-dns/c-ares-1.15.0:=
+ sys-libs/zlib:=
+ systemd? ( sys-apps/systemd:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-cpp/benchmark
+ dev-cpp/gflags
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+# requires sources of many google tools
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+PATCHES=(
+)
+
+soversion_check() {
+ local core_sover cpp_sover
+ # extract quoted number. line we check looks like this: 'set(gRPC_CPP_SOVERSION "1.37")'
+ core_sover="$(grep 'set(gRPC_CORE_SOVERSION ' CMakeLists.txt | sed '/.*\"\(.*\)\".*/ s//\1/')"
+ cpp_sover="$(grep 'set(gRPC_CPP_SOVERSION ' CMakeLists.txt | sed '/.*\"\(.*\)\".*/ s//\1/')"
+ # remove dots, e.g. 1.37 -> 137
+ core_sover="${core_sover//./}"
+ cpp_sover="${cpp_sover//./}"
+ [[ ${core_sover} -eq $(ver_cut 2 ${SLOT}) ]] || die "fix core sublot! should be ${core_sover}"
+ [[ ${cpp_sover} -eq $(ver_cut 3 ${SLOT}) ]] || die "fix cpp sublot! should be ${cpp_sover}"
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # un-hardcode libdir
+ sed -i "s@/lib@/$(get_libdir)@" cmake/pkg-config-template.pc.in || die
+
+ # suppress network access, package builds fine without the submodules
+ mkdir "${S}/third_party/opencensus-proto/src" || die
+
+ soversion_check
+}
+
+src_configure() {
+ # https://github.com/grpc/grpc/issues/29652
+ filter-lto
+
+ local mycmakeargs=(
+ -DgRPC_INSTALL=ON
+ -DgRPC_ABSL_PROVIDER=package
+ -DgRPC_BACKWARDS_COMPATIBILITY_MODE=OFF
+ -DgRPC_CARES_PROVIDER=package
+ -DgRPC_INSTALL_CMAKEDIR="$(get_libdir)/cmake/${PN}"
+ -DgRPC_INSTALL_LIBDIR="$(get_libdir)"
+ -DgRPC_PROTOBUF_PROVIDER=package
+ -DgRPC_RE2_PROVIDER=package
+ -DgRPC_SSL_PROVIDER=package
+ -DgRPC_ZLIB_PROVIDER=package
+ -DgRPC_BUILD_TESTS=$(usex test)
+ -DCMAKE_CXX_STANDARD=17
+ -DCMAKE_DISABLE_FIND_PACKAGE_systemd=$(usex !systemd)
+ $(usex test '-DgRPC_BENCHMARK_PROVIDER=package' '')
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use examples; then
+ find examples -name '.gitignore' -delete || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ if use doc; then
+ find doc -name '.gitignore' -delete || die
+ local DOCS=( AUTHORS CONCEPTS.md README.md TROUBLESHOOTING.md doc/. )
+ fi
+
+ einstalldocs
+}