summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-11 14:19:31 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-11 14:29:49 +0100
commitb03156bbdb206c4648b8e854a2450f6837f7f350 (patch)
treeb6ed7b51ad92fda986c49717c11833dbefdb7425 /net-libs/libiscsi/libiscsi-9999.ebuild
parentnet-libs/libiscsi: Drop old (diff)
downloadgentoo-b03156bbdb206c4648b8e854a2450f6837f7f350.tar.gz
gentoo-b03156bbdb206c4648b8e854a2450f6837f7f350.tar.bz2
gentoo-b03156bbdb206c4648b8e854a2450f6837f7f350.zip
net-libs/libiscsi: Version Bump
transfer latest changes to live ebuild Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-libs/libiscsi/libiscsi-9999.ebuild')
-rw-r--r--net-libs/libiscsi/libiscsi-9999.ebuild45
1 files changed, 27 insertions, 18 deletions
diff --git a/net-libs/libiscsi/libiscsi-9999.ebuild b/net-libs/libiscsi/libiscsi-9999.ebuild
index bfb4ad5d3496..d3c3d7c5442b 100644
--- a/net-libs/libiscsi/libiscsi-9999.ebuild
+++ b/net-libs/libiscsi/libiscsi-9999.ebuild
@@ -1,28 +1,37 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-AUTOTOOLS_AUTORECONF="1"
-inherit autotools-utils
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-2
- SRC_URI=""
- EGIT_REPO_URI="git://github.com/sahlberg/libiscsi.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/sahlberg/libiscsi/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+inherit autotools eutils git-r3
DESCRIPTION="iscsi client library and utilities"
HOMEPAGE="https://github.com/sahlberg/libiscsi"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/sahlberg/libiscsi.git"
-LICENSE="GPL-2 LGPL-2"
SLOT="0"
-IUSE=""
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS=""
+IUSE="static-libs"
+
+RDEPEND="dev-libs/libgcrypt:0="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-manpages \
+ --disable-werror \
+ $(use_enable static-libs static)
+}
-DEPEND=""
-RDEPEND="${DEPEND}"
+src_install() {
+ default
+ prune_libtool_files
+}