summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-16 03:02:42 +0000
committerSam James <sam@gentoo.org>2024-01-16 03:14:39 +0000
commit6a20a163ee9cabbe8fc4c6903abdbf1f5baf230b (patch)
treea4a0dccf3d00598c2ef04ea98a6aaa54dda6e761 /net-libs/libsoup
parentwww-client/lynx: add 2.9.0 (diff)
downloadgentoo-6a20a163ee9cabbe8fc4c6903abdbf1f5baf230b.tar.gz
gentoo-6a20a163ee9cabbe8fc4c6903abdbf1f5baf230b.tar.bz2
gentoo-6a20a163ee9cabbe8fc4c6903abdbf1f5baf230b.zip
net-libs/libsoup: fix build w/ libxml2-2.12
Closes: https://bugs.gentoo.org/917556 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libsoup')
-rw-r--r--net-libs/libsoup/files/libxml2-2.12.patch36
-rw-r--r--net-libs/libsoup/libsoup-2.74.3.ebuild4
2 files changed, 39 insertions, 1 deletions
diff --git a/net-libs/libsoup/files/libxml2-2.12.patch b/net-libs/libsoup/files/libxml2-2.12.patch
new file mode 100644
index 000000000000..3190eeb6301c
--- /dev/null
+++ b/net-libs/libsoup/files/libxml2-2.12.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/917556
+https://gitlab.gnome.org/GNOME/libsoup/-/commit/ced3c5d8cad0177b297666343f1561799dfefb0d
+
+From ced3c5d8cad0177b297666343f1561799dfefb0d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 22 Nov 2023 18:49:10 -0800
+Subject: [PATCH] Fix build with libxml2-2.12.0 and clang-17
+
+Fixes build errors about missing function prototypes with clang-17
+
+Fixes
+| ../libsoup-2.74.3/libsoup/soup-xmlrpc-old.c:512:8: error: call to undeclared function 'xmlParseMemory'; ISO C99 and later do not support implicit function declarations
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/libsoup/soup-xmlrpc-old.c
++++ b/libsoup/soup-xmlrpc-old.c
+@@ -11,6 +11,7 @@
+
+ #include <string.h>
+
++#include <libxml/parser.h>
+ #include <libxml/tree.h>
+
+ #include "soup-xmlrpc-old.h"
+--- a/libsoup/soup-xmlrpc.c
++++ b/libsoup/soup-xmlrpc.c
+@@ -17,6 +17,7 @@
+
+ #include <string.h>
+ #include <errno.h>
++#include <libxml/parser.h>
+ #include <libxml/tree.h>
+ #include "soup-xmlrpc.h"
+ #include "soup.h"
+--
+GitLab
diff --git a/net-libs/libsoup/libsoup-2.74.3.ebuild b/net-libs/libsoup/libsoup-2.74.3.ebuild
index 7e1740520995..4287161e6fb3 100644
--- a/net-libs/libsoup/libsoup-2.74.3.ebuild
+++ b/net-libs/libsoup/libsoup-2.74.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -53,6 +53,8 @@ BDEPEND="
PATCHES=(
# Disable apache tests until they are usable on Gentoo, bug #326957
"${FILESDIR}"/disable-apache-tests.patch
+ # libxml2-2.12 fix, bug #917556
+ "${FILESDIR}"/libxml2-2.12.patch
)
src_prepare() {