summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-08-18 12:17:10 +0200
committerSam James <sam@gentoo.org>2020-08-19 14:33:12 +0000
commit4aa6126b3bd3b726d3832a0d8d5138beccb306c7 (patch)
tree4178c4b00f61d0f6695b9013502cedb0ab1f8376 /net-libs/libtelnet/libtelnet-0.23.ebuild
parentnet-libs/libtelnet: do not install '.a' files (diff)
downloadgentoo-4aa6126b3bd3b726d3832a0d8d5138beccb306c7.tar.gz
gentoo-4aa6126b3bd3b726d3832a0d8d5138beccb306c7.tar.bz2
gentoo-4aa6126b3bd3b726d3832a0d8d5138beccb306c7.zip
net-libs/libtelnet: bump to 0.23
Closes: https://bugs.gentoo.org/737616 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libtelnet/libtelnet-0.23.ebuild')
-rw-r--r--net-libs/libtelnet/libtelnet-0.23.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/libtelnet/libtelnet-0.23.ebuild b/net-libs/libtelnet/libtelnet-0.23.ebuild
new file mode 100644
index 000000000000..f497242059f6
--- /dev/null
+++ b/net-libs/libtelnet/libtelnet-0.23.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Simple RFC-complient TELNET implementation as a C library"
+HOMEPAGE="https://github.com/seanmiddleditch/libtelnet"
+SRC_URI="https://github.com/seanmiddleditch/libtelnet/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -type f -name '*.a' -delete || die
+}