summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-13 23:21:26 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-13 23:35:58 +0200
commitc1bc93122e06423e545ceee2377c4beaf8de970b (patch)
tree0a605b635603373de8ded9170cf902880f433e54 /net-libs/nodejs/nodejs-99999999.ebuild
parentsys-apps/gentoo-functions: Stabilize 0.14 ppc, #790038 (diff)
downloadgentoo-c1bc93122e06423e545ceee2377c4beaf8de970b.tar.gz
gentoo-c1bc93122e06423e545ceee2377c4beaf8de970b.tar.bz2
gentoo-c1bc93122e06423e545ceee2377c4beaf8de970b.zip
net-libs/nodejs: support python3_10
The version of jinja bundled with v8 (in all versions currently in the tree) still imports ABCs from collections rather than collections.abc, then again with that patched everything seems to be in order. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/nodejs/nodejs-99999999.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index 2b81f6a39ed8..2d45db3952a5 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
@@ -46,6 +46,10 @@ BDEPEND="${PYTHON_DEPS}
pax_kernel? ( sys-apps/elfix )"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-12.22.1-jinja_collections_abc.patch # still needed as of 2021-05-13
+)
+
pkg_pretend() {
(use x86 && ! use cpu_flags_x86_sse2) && \
die "Your CPU doesn't support the required SSE2 instruction."