summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2023-10-05 23:39:29 +0300
committerMart Raudsepp <leio@gentoo.org>2023-10-06 00:05:26 +0300
commita5f2be4e445c5ecb1b5f84cb96531c37977577cb (patch)
treed8694a92c46df4408303886443bcbd69b9e38365 /net-libs/srt
parentnet-libs/webkit-gtk: Version bump to 2.42.1 (diff)
downloadgentoo-a5f2be4e445c5ecb1b5f84cb96531c37977577cb.tar.gz
gentoo-a5f2be4e445c5ecb1b5f84cb96531c37977577cb.tar.bz2
gentoo-a5f2be4e445c5ecb1b5f84cb96531c37977577cb.zip
net-libs/srt: add 1.5.3
* Build with c++14 due to gtest usage requiring it now; though srt-1.5.1 was still fine without with the same gtest version * Enable experimental bonding support - there is no ill effect when not enabled via SRT socket options, but actually also works good in my experience * Always disable ENABLE_TESTING, as this controls the build of some developer testing tools, which don't have install targets, so for us it just increases compile time with USE=test but aren't actually used by unit tests. Closes: https://bugs.gentoo.org/911579 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-libs/srt')
-rw-r--r--net-libs/srt/Manifest1
-rw-r--r--net-libs/srt/srt-1.5.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-libs/srt/Manifest b/net-libs/srt/Manifest
index 1a37b93fb5a5..9916a246cda6 100644
--- a/net-libs/srt/Manifest
+++ b/net-libs/srt/Manifest
@@ -1,2 +1,3 @@
DIST srt-1.4.3.tar.gz 1602671 BLAKE2B ed4ec46cab887461f6dccfc2d695fe78a3782f42f4ef6c3ac5ba6e2ea068a7943eb8079c0a448f35864c575009d556363bcfe7d815d0f47a368001a3df478837 SHA512 5cd15fd0c7b324226ab096c1b6c6f81b4ce5600617e1bd2c38985f18d7d551c9a4a09b1e34c7a705c92ae54bb57c5d736ca7eff6e4992e67666aa167e0da855f
DIST srt-1.5.1.tar.gz 1694199 BLAKE2B 4c215ef936100b02b3a5a9aab6e9a715ecdb728517b0648e91f2144bb34a34cb1573c4e6905441a366ea281c9410c2d00d5ebc64144f327f7a115d81038942af SHA512 f3aa1f7773540e2dd31cd19b124eec3c3d830f59c08d953cae01e129a58db7e639bdf94c8a5a678435ae9a1d2402e2c77196fc9c4e75b42aa37d8eafcc16f436
+DIST srt-1.5.3.tar.gz 1706632 BLAKE2B fd053782e58602ccd06690c5785b68ff20531afd890678fbd77660e376887b0886cc020d449e2669672748c3d1a515b56d9fd94670c33d085eadb961220a7431 SHA512 5b576d6fd325515e05074e4568e3b65d1ae265e3e971db6e6242e5138243fc1594df1e3a7d90962385dac38abc34c4c4b0a567439050f8c0ff818b3b3d497efc
diff --git a/net-libs/srt/srt-1.5.3.ebuild b/net-libs/srt/srt-1.5.3.ebuild
new file mode 100644
index 000000000000..5f4428d36247
--- /dev/null
+++ b/net-libs/srt/srt-1.5.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Secure Reliable Transport (SRT) library and tools"
+HOMEPAGE="https://github.com/Haivision/srt"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/Haivision/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Haivision/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv -sparc ~x86 ~ppc-macos ~x64-macos"
+fi
+
+LICENSE="MPL-2.0"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="gnutls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ gnutls? (
+ dev-libs/nettle:0=[${MULTILIB_USEDEP}]
+ net-libs/gnutls:0=[${MULTILIB_USEDEP}]
+ )
+ !gnutls? (
+ dev-libs/openssl:0=[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ test? ( >=dev-cpp/gtest-1.10[${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_CXX_STD=c++14 # Required for gtest
+ -DENABLE_STATIC=OFF
+ # Bonding is experimental in 1.5, but works good and doesn't affect anything when not enabled with API calls
+ -DENABLE_BONDING=ON
+ -DENABLE_UNITTESTS=$(usex test)
+ -DENABLE_TESTING=OFF # Not installed developer/testing tools
+ -DUSE_GNUTLS=$(usex gnutls)
+ )
+ cmake-multilib_src_configure
+}
+
+multilib_src_test() {
+ cmake_src_test -j1
+}
+
+multilib_src_install() {
+ cmake_src_install
+ # remove old upstream temporary compatibility pc
+ rm "${ED}/usr/$(get_libdir)/pkgconfig/haisrt.pc" || die
+}